RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-04-2012, 09:09 PM   #1
Member
 
Join Date: Feb 2012
Posts: 83
generator shut down

7.5 model hdkaj spect h onan, runs for 2-4 minutes and shuts down with a code 33. It will restart right away and do the same thing any body have a fix for this.
__________________

Raybo is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-05-2012, 04:21 AM   #2
Senior Member
 
palehorse89's Avatar
 
Newmar Owners Club
Join Date: Oct 2009
Posts: 8,849
I think this might help you out....

http://www.cumminsonan.com/www/pdf/m.../981-0161C.pdf
__________________

__________________
2012 Essex 4544 2011 Jeep JK, M&G Braking, 2014 MTI 27' Hog Hauler, Wireless brake control, 2006 Ultra & 1989 Springer
palehorse89 is offline   Reply With Quote
Old 10-06-2012, 04:16 PM   #3
Member
 
Join Date: Feb 2012
Posts: 83
I purchased a service manual on line from cummins. It does not show how to test the high temperature sensor. I disconnected the wire from it and now it will run for 5 min. An shut off with code first of 3 then a 24. Which Says it did not sense a temp difference in 5 mins and will shut down as it did. Tomorrow I will try to replace the Sensor.
Raybo is offline   Reply With Quote
Old 10-06-2012, 07:20 PM   #4
Senior Member
 
palehorse89's Avatar
 
Newmar Owners Club
Join Date: Oct 2009
Posts: 8,849
please let us know what you find out
__________________
2012 Essex 4544 2011 Jeep JK, M&G Braking, 2014 MTI 27' Hog Hauler, Wireless brake control, 2006 Ultra & 1989 Springer
palehorse89 is offline   Reply With Quote
Old 10-06-2012, 07:30 PM   #5
KIX
Senior Member
 
KIX's Avatar
 
Join Date: Dec 2006
Location: St. Augustine, FL
Posts: 3,595
I also have a HDKAJ and a couple of years ago had the code 33 issue. I changed out the coolant temp sensor and solved the problem.
__________________
KIX
'02 Ultimate Advantage 40J Spartan MM - Cummins ISC
2013 Jeep Rubicon JK Unlimited
KIX is offline   Reply With Quote
Old 11-02-2012, 08:19 PM   #6
Member
 
Join Date: Feb 2012
Posts: 83
I replaced the temperature sensor and it works ok. Though the end of the sensor broke off and was corroded in the opening. had to drill it out not easy.
Raybo is offline   Reply With Quote
Old 11-02-2012, 09:33 PM   #7
Senior Member
 
palehorse89's Avatar
 
Newmar Owners Club
Join Date: Oct 2009
Posts: 8,849
Quote:
Originally Posted by Raybo View Post
I replaced the temperature sensor and it works ok. Though the end of the sensor broke off and was corroded in the opening. had to drill it out not easy.
Thanks for getting back to us and letting us know how you fixed it.
__________________
2012 Essex 4544 2011 Jeep JK, M&G Braking, 2014 MTI 27' Hog Hauler, Wireless brake control, 2006 Ultra & 1989 Springer
palehorse89 is offline   Reply With Quote
Old 11-02-2012, 09:43 PM   #8
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 30,118
Yes thanks for the follow up Raybo and welcome to the forum & irv2.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 11-03-2012, 09:49 AM   #9
Registered User
 
Iron Man's Avatar
 
Newmar Owners Club
Join Date: Jul 2006
Posts: 1,063
might be time for a coolant flush and change. Generators often get overlooked until they quit running. Mine is do for a coolant flush.
__________________

__________________
John, Pam, Nicholas, Aria
NKK 16073L
2007 Essex 4502
2015 GMC Seirra
Iron Man is offline   Reply With Quote
Reply

Tags
generator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 10:46 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×