RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-20-2017, 02:40 PM   #1
Junior Member
 
lulu444's Avatar
 
Join Date: Jun 2017
Posts: 11
hazard light aren't working

My RV is a 2003 Newmar mountain aire and
I'm trying to figure out why my hazard lights are not working. I've changed the fuse and still not working. What else should I check before going to the garage?
__________________

lulu444 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-20-2017, 02:46 PM   #2
Senior Member
 
znt1186's Avatar
 
Join Date: Nov 2014
Posts: 845
Look for the flasher control module. It should be in the rat's nest of wires in the dash in front of the driver. Turn on your turn signal and follow the sound. There is typically a module for the hazard markers and one for the turn signals located close to each other. Mine are even the same part number.
__________________

__________________
Zeb and Teena
2005 Mandalay, 2013 Ford Edge
znt1186 is offline   Reply With Quote
Old 06-20-2017, 03:17 PM   #3
Junior Member
 
lulu444's Avatar
 
Join Date: Jun 2017
Posts: 11
Thanks, by any chance would you have a picture?
lulu444 is offline   Reply With Quote
Old 06-20-2017, 03:51 PM   #4
Senior Member
 
damdannyboy's Avatar
 
Newmar Owners Club
Nor'easters Club
Workhorse Chassis Owner
Join Date: Jul 2010
Posts: 416
I ended up changing the multi switch my workhorse 2003 Newmar Scottsdale.
__________________
.....Damdannyboy........
2019 Northwood Arctic Fox 27 5L
damdannyboy is offline   Reply With Quote
Old 06-20-2017, 04:08 PM   #5
Registered User
 
Monaco Owners Club
Join Date: Nov 2002
Location: Columbus, MS
Posts: 40,916
Hi ! Welcome to IRV2! We're sure glad you joined the gang!

Sorry I can't help with your problem! Keep her between the ditches!

Good luck, happy trails, and God bless!
MSHappyCampers is offline   Reply With Quote
Old 06-20-2017, 04:22 PM   #6
Junior Member
 
lulu444's Avatar
 
Join Date: Jun 2017
Posts: 11
Quote:
Originally Posted by znt1186 View Post
Look for the flasher control module. It should be in the rat's nest of wires in the dash in front of the driver. Turn on your turn signal and follow the sound. There is typically a module for the hazard markers and one for the turn signals located close to each other. Mine are even the same part number.
Thanks
lulu444 is offline   Reply With Quote
Old 06-20-2017, 04:23 PM   #7
Junior Member
 
lulu444's Avatar
 
Join Date: Jun 2017
Posts: 11
Quote:
Originally Posted by damdannyboy View Post
I ended up changing the multi switch my workhorse 2003 Newmar Scottsdale.
Thanks
lulu444 is offline   Reply With Quote
Old 06-20-2017, 04:24 PM   #8
Junior Member
 
lulu444's Avatar
 
Join Date: Jun 2017
Posts: 11
Quote:
Originally Posted by MSHappyCampers View Post
Hi ! Welcome to IRV2! We're sure glad you joined the gang!

Sorry I can't help with your problem! Keep her between the ditches!

Good luck, happy trails, and God bless!
Thanks, between the ditches is the only place I want to be,
God bless
lulu444 is offline   Reply With Quote
Old 06-20-2017, 06:02 PM   #9
Senior Member
 
znt1186's Avatar
 
Join Date: Nov 2014
Posts: 845
Quote:
Originally Posted by lulu444 View Post
Thanks, by any chance would you have a picture?

I did find a picture I made so I would remember the numbers. I don't know if your MA is a diesel or gas. Mine is diesel on a Freightliner, and there is a removable panel on the dash above the steering wheel. That is where I found the said modules.Click image for larger version

Name:	IMAG0231.jpg
Views:	92
Size:	198.4 KB
ID:	165872
__________________
Zeb and Teena
2005 Mandalay, 2013 Ford Edge
znt1186 is offline   Reply With Quote
Old 06-20-2017, 06:04 PM   #10
Junior Member
 
lulu444's Avatar
 
Join Date: Jun 2017
Posts: 11
Mine is gas,would it be the same? Thanks so much for the picture it really helps.
lulu444 is offline   Reply With Quote
Old 06-20-2017, 06:15 PM   #11
Senior Member
 
znt1186's Avatar
 
Join Date: Nov 2014
Posts: 845
Probably not exactly, but they are all located under the dash around the steering wheel to my knowledge. Try the turn signals and listen to the sound to find that module. It may be close or even share the same one. Good luck.
__________________
Zeb and Teena
2005 Mandalay, 2013 Ford Edge
znt1186 is offline   Reply With Quote
Old 06-20-2017, 06:16 PM   #12
Junior Member
 
lulu444's Avatar
 
Join Date: Jun 2017
Posts: 11
Thanks so much, your information has been very valuable
lulu444 is offline   Reply With Quote
Old 06-20-2017, 06:41 PM   #13
Senior Member
 
damdannyboy's Avatar
 
Newmar Owners Club
Nor'easters Club
Workhorse Chassis Owner
Join Date: Jul 2010
Posts: 416
Lulu, you don't state what chassis you have? If it's a workhorse it will have two flasher controls under the top cover of the dash, the multi-switch is the wiper/cruse/directional switch on the side of steering column. Hope that helps
__________________
.....Damdannyboy........
2019 Northwood Arctic Fox 27 5L
damdannyboy is offline   Reply With Quote
Old 06-20-2017, 07:16 PM   #14
Community Moderator
 
TonyDi's Avatar


 
Newmar Owners Club
Join Date: Feb 2011
Location: Central NJ
Posts: 18,946


Glad to have you here in the forum with us.

Happy Trails!!!
__________________

__________________
Tony & Ruth........... FMCA#F416727
2016 London Aire 4519, Freightliner chassis, Cummins ISX, 2018 Jeep Wrangler Unlimited, Blue Ox Avail with AF1. TST 507 TPMS
TonyDi is offline   Reply With Quote
Reply

Tags
light



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slides wont come in and levelers aren't working shadowgaurdi Class A Motorhome Discussions 11 04-08-2016 04:38 PM
A/C and fridge aren't working jillie Newmar Owner's Forum 27 07-22-2011 10:32 AM
1990 right rear turn/hazard/brake lights not working MoHo2 Ford Motorhome Chassis Forum 2 08-10-2010 08:22 AM
Hazard Flasher not working burnhamtx National RV Owner's Forum 4 06-30-2010 08:34 AM
House batteries aren't charging. Joe Brunold Alpine Coach Owner's Forum 9 01-03-2009 09:28 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 12:28 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×