Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-12-2021, 03:57 PM   #1
Member
 
LandKPart2's Avatar
 
Join Date: Feb 2019
Location: Anywhere and everywhere
Posts: 41
HWH Auto Store Non Functional

My RV is: 2012 Ventana 3433. HWH Leveling System 725. I have the .pdf manual and found no help with the following issue:

The "Auto Store" function has quit working. Prior to it quitting it had a period of intermittent functionality. Sometimes it would work, other times not.

I can still retract my pads using the "manual" function on the control panel, and the Auto Level function works just fine. Is there a fuse? Do I need to start chasing wires?
Attached Thumbnails
Click image for larger version

Name:	243267355_594442615242078_162338241027453368_n.jpg
Views:	11
Size:	148.1 KB
ID:	345897  
LandKPart2 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-12-2021, 04:07 PM   #2
Senior Member
 
lass's Avatar
 
Join Date: Sep 2012
Location: Tarpon Springs, Fl.
Posts: 1,463
For what itís worth, my 2013 Ventana had the same problem and after a call to HWH, they determined that it was the control pad contact. Sent it to them and 2 weeks later plus $100.00 all was good. Still working after 3 years.

Hope that yours is as simple.
__________________
2013 Newmar Ventana 3434
2018 Wrangler JLU Rubicon
lass is offline   Reply With Quote
Old 10-12-2021, 04:09 PM   #3
Senior Member
 
Dutchstar411's Avatar


 
Newmar Owners Club
Join Date: Dec 2015
Location: Wellington, Florida
Posts: 1,146
Quote:
Originally Posted by LandKPart2 View Post
My RV is: 2012 Ventana 3433. HWH Leveling System 625S. I have the .pdf manual and found no help with the following issue:

The "Auto Store" function has quit working. Prior to it quitting it had a period of intermittent functionality. Sometimes it would work, other times not.

I can still retract my pads using the "manual" function on the control panel, and the Auto Level function works just fine. Is there a fuse? Do I need to start chasing wires?
Contact Paul with HWH, he's 3hrs behind EST. 602.549.3638
__________________
Ted & Nancy with our fur kids Mr. Vincent & Miss Daisy
2015 Newmar Dutch Star 4018
2002 Newmar Dutch Star 3852
Dutchstar411 is offline   Reply With Quote
Old 10-12-2021, 05:09 PM   #4
Senior Member
 
Mr JP's Avatar


 
Newmar Owners Club
Join Date: Dec 2009
Location: Southern Nevada
Posts: 706
I had issues with the HWH control pad also. I took it apart, it has micro switches that control each function. I sprayed contact cleaner in the non functional micro switch and put it back together. There are little spacers in-between the layers that can be lost easily. The control pad has worked great for over a couple of years now.
__________________
Just the Wife & Me!! & Lily our Yellow Lab
2011 Newmar Mountain Aire 4344 !!
450HP Cummins on a Freightliner Chassis !!
Mr JP is offline   Reply With Quote
Old 10-13-2021, 06:23 AM   #5
Senior Member
 
veraken's Avatar


 
Monaco Owners Club
Vintage RV Owners Club
Holiday Rambler Owners Club
Join Date: Jul 2012
Location: Lexington, SC
Posts: 2,373
Contact Paul at AZPETE on the Irv2 forum. He works for HWH and can answer your questions. His email is pfmaddox@att.net and his phone number is 602-549-3638. He is a Commercial Member and has posted that his phone is always on, and if not answered, leave a message.

He has helped others on this forum and I am sure he can help you.
__________________
Vera & Ken
1998 Holiday Rambler Imperial, RR8S Chassis
Cummins 6C8.3 mechanical engine, 325HP, 3060 Allison
Towing 2014 Ford Explorer
veraken is offline   Reply With Quote
Old 10-13-2021, 10:35 AM   #6
Senior Member
Commercial Member
 
Join Date: Jun 2005
Location: behind the steering wheel
Posts: 2,162
it does sound like the switch. if you want a repair number, find the AP number written on one of the circuit boards on the touch pad.
i can supply a RAP replacement part number and the hwh retail price.
even if you find it elsewhere, you will know what a fair price is.
if you need help, call me 602 549 3638

paul maddox
i work full time for hwh corp. i do not solicit part sales, and i do not do service work anymore except by assignment from hwh.
azpete is offline   Reply With Quote
Old 10-13-2021, 03:19 PM   #7
Member
 
LandKPart2's Avatar
 
Join Date: Feb 2019
Location: Anywhere and everywhere
Posts: 41
Quote:
Originally Posted by azpete View Post
it does sound like the switch. if you want a repair number, find the AP number written on one of the circuit boards on the touch pad.
i can supply a RAP replacement part number and the hwh retail price.
even if you find it elsewhere, you will know what a fair price is.
if you need help, call me 602 549 3638

paul maddox
i work full time for hwh corp. i do not solicit part sales, and i do not do service work anymore except by assignment from hwh.
Thanks Paul! I'm going to try one of the recommendations of using contact cleaner first (I always go easy and cheap first). If that doesn't work I'll contact you with those P/N's.
LandKPart2 is offline   Reply With Quote
Old 10-13-2021, 03:20 PM   #8
Member
 
LandKPart2's Avatar
 
Join Date: Feb 2019
Location: Anywhere and everywhere
Posts: 41
Quote:
Originally Posted by Mr JP View Post
I had issues with the HWH control pad also. I took it apart, it has micro switches that control each function. I sprayed contact cleaner in the non functional micro switch and put it back together. There are little spacers in-between the layers that can be lost easily. The control pad has worked great for over a couple of years now.
This will be step one... as soon as I'm near a hardware store to get contact cleaner.
LandKPart2 is offline   Reply With Quote
Old 10-13-2021, 03:23 PM   #9
Senior Member
 
Dutchstar411's Avatar


 
Newmar Owners Club
Join Date: Dec 2015
Location: Wellington, Florida
Posts: 1,146
Quote:
Originally Posted by LandKPart2 View Post
This will be step one... as soon as I'm near a hardware store to get contact cleaner.
Take pictures please, thanks
__________________
Ted & Nancy with our fur kids Mr. Vincent & Miss Daisy
2015 Newmar Dutch Star 4018
2002 Newmar Dutch Star 3852
Dutchstar411 is offline   Reply With Quote
Old 11-12-2021, 08:32 AM   #10
Member
 
LandKPart2's Avatar
 
Join Date: Feb 2019
Location: Anywhere and everywhere
Posts: 41
Many apologies... I failed to take pictures with the panel removed. There's not much there anyway. Once the control panel is lifted out of the arm rest you will see a couple of cables plugged into it and a circuit board layered with a small gap allowing for the micro switch movement. To clean the micro switches I used the small capillary tube that comes with the can of contact cleaner to squirt a small amount on the moveable parts. I also sprayed a bit on the cable connections. Its been working fine since then.
LandKPart2 is offline   Reply With Quote
Old 11-12-2021, 07:04 PM   #11
Senior Member
 
Mr JP's Avatar


 
Newmar Owners Club
Join Date: Dec 2009
Location: Southern Nevada
Posts: 706
Quote:
Originally Posted by LandKPart2 View Post
Many apologies... I failed to take pictures with the panel removed. There's not much there anyway. Once the control panel is lifted out of the arm rest you will see a couple of cables plugged into it and a circuit board layered with a small gap allowing for the micro switch movement. To clean the micro switches I used the small capillary tube that comes with the can of contact cleaner to squirt a small amount on the moveable parts. I also sprayed a bit on the cable connections. Its been working fine since then.
Glad to hear you got it fixed up
__________________
Just the Wife & Me!! & Lily our Yellow Lab
2011 Newmar Mountain Aire 4344 !!
450HP Cummins on a Freightliner Chassis !!
Mr JP is offline   Reply With Quote
Reply

Tags
hwh



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slide controls panel non-functional pdeinc Tiffin Owner's Forum 5 12-03-2019 07:23 AM
Demo non functional after tour Agesilaus RV Trip Wizard - Trip Planner Topics 2 08-31-2019 07:27 PM
Non-functional cruise control and how I fixed it with diagnostic procedure. funmoneypit Ford Motorhome Chassis Forum 6 07-28-2018 09:57 AM
Awning - Eclipse - outside switch non-functional Busskipper Travel Supreme Owner's Forum 2 08-29-2017 04:18 PM
I have a non-functional (wall) touch pad RW8804 Entegra Owner's Forum 16 10-11-2014 06:14 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 03:09 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.