RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-30-2020, 02:08 PM   #1
Member
 
Join Date: Mar 2014
Posts: 40
HWH jacks won't dump air before deploying

I have a 2019 LADP on a Sparten chassis. When we first bought it it would hurt and puff like a steampunk dream while driving. The Hadley air level system was very noisy. Back in June I got it to NIRVC in GA and they found a recall for that and performed the recall. Since then there are no more hissing and blowing noises, but when activating the HWH jacks, the air won't dump, nor will it refill the bags when retracting the jacks. I can lower the coach from the Hadley panel and return it to ride height from there, but the HWH panel doesn't. Everything else about the HWH system is working normally. After two unsuccessful attempts at a fix, Sparten has said it's a known problem on K3 chassis but they haven't identified a fix. I'm a tad frustrated since this started in June. Has anyone else had this issue?
jbstok is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-30-2020, 09:03 PM   #2
Senior Member
 
Newmar Owners Club
Spartan Chassis
Join Date: Jun 2017
Posts: 683
I have a 2018 Mountain Aire on a K3 chassis. I had the Hadley modification done such that the Hadley panel now only works when the engine is running.

Before and after the mod, I was able to dump air from the HWH panel.
flyboy013 is offline   Reply With Quote
Old 12-01-2020, 05:21 AM   #3
Senior Member
 
Join Date: Sep 2016
Location: Sarasota, FL
Posts: 4,294
Sounds like someone unplugged the line from the HWH panel to the master dump/fill valve?
__________________
Rick and Larrie Dee
1997 40' Newmar London Aire DP CTA 8.3 (Mechanical) 325 Spartan MM
Bringing her back to her glory.
'08 Jeep GC Overland.
RKins is offline   Reply With Quote
Old 12-01-2020, 07:28 AM   #4
Member
 
Join Date: Mar 2014
Posts: 40
Mine too only works when he engine is running, they just can't seem to figure out why the HWH deployment won't cause the air to dump. The delay is still there before the jacks begin to deploy but nothing happens during that time. Same for retraction.

I hope it is something as simple as a broken or disconnected wire, but they've had two shots at finding it with no results.

Thanks.
jbstok is offline   Reply With Quote
Old 12-02-2020, 06:24 AM   #5
Senior Member
 
Join Date: Sep 2016
Location: Sarasota, FL
Posts: 4,294
Reach out to Paul Maddox - (AZPETE on the Irv2 forum). He works for HWH and can answer your questions. His email is pfmaddox@att.net and his phone number is 602-549-3638. He is a Commercial Member and has posted that his phone is always on, and if not answered, leave a message.

He has helped others on this forum and I am sure he can help you. He helped me through the rebuild of my leveling system.
__________________
Rick and Larrie Dee
1997 40' Newmar London Aire DP CTA 8.3 (Mechanical) 325 Spartan MM
Bringing her back to her glory.
'08 Jeep GC Overland.
RKins is offline   Reply With Quote
Old 12-02-2020, 06:39 AM   #6
Senior Member
 
Newmar Owners Club
Spartan Chassis
Join Date: Jun 2017
Posts: 683
Read part 6 of the service manual. It provides a pretty detailed troubleshooting section including checking for voltage on specific connectors/pins.

https://www.hwhcorp.com/ml48380.pdf
flyboy013 is offline   Reply With Quote
Old 12-02-2020, 06:50 AM   #7
Senior Member
 
Forest River Owners Club
iRV2 No Limits Club
Join Date: May 2009
Location: Where I lay my head.
Posts: 1,492
Blog Entries: 5
I'm wondering if they are auto or manual jacks?

As AUTO Jacks have a re-set button. To perform a reset find an empty flat level parking lot. OPEN the JACKS Control box while setting in the driver's seat. If I recall correctly you hold the button for 5 to 10 seconds. (sorry not sure which but seemed center bottom) They will AUTO start the reset of the jacks as they will go down fully and back up dumping air and correcting themselves. Then once down for a few seconds, they will auto retract fully, and your all set. This I did on a Winnebago tour in 2005. Good Luck hope this will work for you.
Dogman635UT is offline   Reply With Quote
Old 12-02-2020, 07:56 AM   #8
Member
 
Join Date: Mar 2014
Posts: 40
Thanks everyone for the suggestions. I spoke with someone at Sparten yesterday and he made the right noises about getting to the bottom of it soon. We'll see.
jbstok is offline   Reply With Quote
Reply

Tags
air, hwh, jacks



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How get the the most solid stance deploying the jacks? Kahoona Class A Motorhome Discussions 11 11-12-2020 04:19 PM
Looking for part number for the air dump valve connected to the "dump" on HWH control michelb Freightliner Motorhome Chassis Forum 1 05-31-2019 10:30 PM
Rear HWH jacks not deploying - fuses? Sandy Swede Class A Motorhome Discussions 19 04-22-2018 03:38 PM
Deploying, Early Winterizing Questions jrizz1 MH-General Discussions & Problems 8 07-28-2013 12:42 PM


All times are GMT -6. The time now is 05:45 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.