RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-19-2019, 05:33 PM   #1
Senior Member
 
Any ole Joe's Avatar
 
Newmar Owners Club
Join Date: May 2016
Posts: 127
If it is not working... always do a visual inspection!

Our 07 Essex hydro hot has worked perfectly for the last 3 Ĺ years. Generally, had all the hot water we needed only using the AC electrical element. On our last trip, I noticed the water wasnít getting hot with AC (the overhead switch indicating on, heating status and electric heating element status showing green in the bay). Solution was easy, just used the diesel burner, of course, quickly had hot water.

Back home, doing general maintenance to prepare for our next trip. Used the hydro hot PDF to check the AC heating element. When I opened the electrical box to access the heating element, the pic below is what I found! Wow! Appears the wires grounded and melted most inside. I carefully inspected and replaced all the wires with the proper gage. Used a multimeter to check the Ohms resistance on the heating element (9.2 good). Checked the AC relay (the DC voltage side was good, but there was no continuity on the AC side). Bottom line, besides melted wires, the AC relay was bad. $31.

I erroneously thought the green lights said the AC heating element was good, so I continued to try to use it... this is not the case. These two green lights are just the first step in troubleshooting the heating element. So in the future... when something isnít working... Iím immediately putting eyes on it!
Click image for larger version

Name:	IMG_1117.jpg
Views:	16
Size:	231.4 KB
ID:	257406
__________________

__________________
Any Ole Joe
2007 Newmar Essex 4508
Any ole Joe is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-19-2019, 07:10 PM   #2
Senior Member
 
Jim_HiTek's Avatar
 
Join Date: Nov 2011
Location: Full time RV'er
Posts: 2,838
Wow. Good advice. That's exactly what I taught my technicians...look carefully before starting work.
__________________
'02 Winnebago Journey DL, DSDP, 36' of fun.

Visit my RV Travel & Repair Blog at : https://chaos.goblinbox.com
Jim_HiTek is online now   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windshield wiper not always working FixerCQI Monaco Owner's Forum 0 12-04-2018 10:46 AM
Slide Switches Not Always Working Daveb447 Winnebago Industries Owner's Forum 5 10-26-2014 07:58 AM
Tire Pressure Monitors - visual alarms Cramalot MH-General Discussions & Problems 6 05-13-2009 01:45 PM
Audio/Visual System Replacement?? Rick Coleman Alpine Coach Owner's Forum 19 03-04-2009 08:23 AM
Allegro Bus Audio-Visual Setup Pigman1 Tiffin Owner's Forum 5 10-11-2008 08:10 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 04:16 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×