RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-22-2020, 05:29 PM   #1
Senior Member
 
Join Date: May 2016
Posts: 262
Question Losing Electricity

Got home and hooked up to power and lost power won’t work on AC are generator. It just flashes for a second then goes off. Still have all 12 volt power. I know we hit some really bad spots on the way home thinking might have some loose wires. Had a new transfer switch put in it last year. How do I go about checking it ? It all has been working fine. What do I need to look for ? Thanks Ronnnie
__________________

okie mopar is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-22-2020, 06:22 PM   #2
Senior Member
 
Ljwt330's Avatar
 
Join Date: Jan 2018
Location: Capistrano Beach, California
Posts: 1,647
Common point for both shore and generator is the transfer switch. Remove the cover and check the connections at the outlet for the switch—the wires that go to your electrical panel. If no obviously loose connections, loosen then retighten them anyway.

If you are confident, check, tighten, then test the voltage at the inlet lugs with a meter, both connected to shore then disconnect and test on generator. Do you read 120 VAC from shore and from generator lugs? If not, check shore breaker and generator breakers.

If you are getting 120 VAC through the transfer switch, the problem moves to your panel and/or inverter.

BTW, what is it that “flashes for just a moment then goes off?” That could be a clue, but don’t know to what you refer.
__________________

__________________
Larry, Eileen, and Finley
2004 Alpine 36FDDS
Third motor home, first Alpine, no need for another.
Ljwt330 is offline   Reply With Quote
Old 03-22-2020, 07:24 PM   #3
Senior Member
 
Join Date: May 2016
Posts: 262
Lites

All the clocks coffee pot microwave are what blink. It work all time we were gone. But I hit a very bad stretch of road so was thinking about the wires
okie mopar is offline   Reply With Quote
Old 03-22-2020, 07:32 PM   #4
Senior Member
 
Ljwt330's Avatar
 
Join Date: Jan 2018
Location: Capistrano Beach, California
Posts: 1,647
Quote:
Originally Posted by okie mopar View Post
All the clocks coffee pot microwave are what blink. It work all time we were gone. But I hit a very bad stretch of road so was thinking about the wires
Got it.

Yes, it does seem to be a loose connection and if it happen on both shore and generator, the TS is the first place to check.
__________________
Larry, Eileen, and Finley
2004 Alpine 36FDDS
Third motor home, first Alpine, no need for another.
Ljwt330 is offline   Reply With Quote
Reply

Tags
electric



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Flat 2015 F150 cigarette lighter losing power and losing braking ie2special Toads and Motorhome Related Towing 3 06-03-2017 08:26 AM
Motor will not crank, no electricity Craig 2L29 Monaco Owner's Forum 26 02-11-2009 11:17 AM
Update on electricity issues mom2mastiffs Monaco Owner's Forum 1 08-31-2007 05:36 AM
Staying Cool & Using Less Electricity Doggie RV'ing On A Budget 11 06-06-2007 09:47 AM
2007 Essex Electricity Problems Richard&Jacki Newmar Owner's Forum 3 01-01-2007 06:33 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 09:29 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×