Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 02-25-2012, 11:39 AM   #1
Senior Member
 
deanjeep's Avatar
 
Join Date: Sep 2011
Location: Palmetto, FL
Posts: 302
Magnum inverter "fault" light

I have no experience with inverters. This coach has one. There is a small control panel inside (see pic). I don't know how to reset it. Everything seems to work fine. When I cut the power to the coach the inverter seems to do its job but the fault light stays on and the digital panel is blank. 2011 MADP. Thanks in advance.
Attached Thumbnails
Click image for larger version

Name:	image-545880800.jpg
Views:	81
Size:	498.5 KB
ID:	18207  
__________________
Dean & Heidi, 2011 Newmar Mountain Aire DP
deanjeep is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-25-2012, 04:57 PM   #2
Senior Member
 
deanjeep's Avatar
 
Join Date: Sep 2011
Location: Palmetto, FL
Posts: 302
Never mind, I got it!!! Had to unplug the remote wire from the back of the display and then plug it back in. Works fine now.
__________________
Dean & Heidi, 2011 Newmar Mountain Aire DP
deanjeep is offline   Reply With Quote
Old 02-26-2012, 12:05 PM   #3
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 30,742
Go to http://www.irv2.com/forums/attachmen...6&d=1295042602 page 37 section 6.2 of this PDF may have some info for your older control.
Can be found in http://www.irv2.com/forums/f103/orig...ods-18509.html.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GMAC Insurance and "RV Storage" feature meant2shop iRV2.com General Discussion 32 09-10-2012 10:32 PM
Fried My Inverter/Charger Gadget Man MH-General Discussions & Problems 30 03-16-2012 11:04 AM
Changing to from 32" to 40" OldHiker Newmar Owner's Forum 7 02-27-2012 08:17 PM
Another "upgraded to LED" thread. TravelingJ Technology: Internet, TV, Satellite, Cell Phones, etc. 2 02-24-2012 09:17 PM
Signal light dickschaak Travel Supreme Owner's Forum 22 02-24-2012 05:17 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 10:15 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.