RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-22-2018, 09:23 AM   #1
Member
 
Tbeau1957's Avatar
 
Join Date: Oct 2017
Posts: 40
No left brake light on trailer

I have a 2010 Newmar Essex with a spartan chassis.
I am having problems with my tow plug. I have all of my lights working except no left brake light? I have called Spartan and Newmar and nobody seems to be able to help. They say I must have a broken wire, but it just seems weird to me that I have the turn signal on the left but no brake light. Iím hoping someone can help.
Thanks Tom
__________________
2010 Newmar Essex ~ Spartan Chassis
Toad - 2017 Ford Raptor
Blue OX Avail, M&G Braking System
Tbeau1957 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-22-2018, 09:34 AM   #2
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 20,859
Does your coach have amber signal lights on the rear ?
If the coach has a separate signal ( amber ) light and brake light (red), and the trailer plug and trailer only one wire ( connection ) for both , then somewhere there will be a combiner box , that takes brake and signal inputs , and combines them to power the trailer plug.
If this is your set up , then the issue may be in the wiring that supplies the combiner box or the bow its self.
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 04-22-2018, 10:16 AM   #3
Member
 
Tbeau1957's Avatar
 
Join Date: Oct 2017
Posts: 40
Any idea where the converter box would be located?
__________________
2010 Newmar Essex ~ Spartan Chassis
Toad - 2017 Ford Raptor
Blue OX Avail, M&G Braking System
Tbeau1957 is offline   Reply With Quote
Old 04-22-2018, 10:29 AM   #4
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 20,859
If your coach has one , follow the wiring from the trailer plug back to the frame and rear cap , the combiner box will be about 2"x 3" x 1 1/2" .
I'll see if I can find a picture and maybe even it's correct name. BRB.
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 04-22-2018, 10:57 AM   #5
"Formerly Diplomat Don"
 
Dutch Star Don's Avatar
 
Newmar Owners Club
Join Date: Apr 2005
Location: Moorpark, Ca.
Posts: 16,091
"Tbeau1957"......This will sound silly, but is the trailer hitched to the motor home. Sometimes people will back up close and plug in to test lights. This often will cause a ground issue and will cause lights to do funny things.

Here is what the combiner box looks like. If you have one, as stated, it's usually tucked up near the trailer wiring in the back.

https://www.etrailer.com/Custom-Fit-...s/HM48895.html
__________________
Don & Mary
2019 Newmar Dutch Star 4018
2019 Ford Raptor
Dutch Star Don is offline   Reply With Quote
Old 04-22-2018, 11:23 AM   #6
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 20,859
I see Don beat me back , thanks Don for the link.
Sites that I visited had copyrighted the images.

Another thought that came to mind , but I can't imagine that Spartan or Newmar wouldn't have mentioned it.
There MAY be a set of fuses in the trailer wiring to protect the rest of the chassis from blown fuses if a wiring problem exists on the trailer.
Have you looked for a fuse box in the rear of the coach?
I have these photos from an 05 ? Spartan chassis , posted by another member , the box has the two white tape markers and was in a back compartment.
Attached Thumbnails
Click image for larger version

Name:	IMG_0506 (640x384).jpg
Views:	27
Size:	139.2 KB
ID:	200006   Click image for larger version

Name:	IMG_0507 (640x384).jpg
Views:	25
Size:	172.2 KB
ID:	200007  

__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 04-22-2018, 04:16 PM   #7
Senior Member
 
tyoneonit's Avatar
 
Newmar Owners Club
Join Date: Jan 2015
Location: Las Vegas NV
Posts: 227
Had the same issue, looked at everything then finally took the coiled power cord apart at the end where it plugs into our Jeep. Found several loose connections and one that had pulled out of itís connection. Tightened everything up, no problems since.
__________________
Dave & Kathy. Fulltimers
2017 Newmar DSDP 4369
2017 Jeep Grand Cherokee Summit.
tyoneonit is offline   Reply With Quote
Old 04-22-2018, 07:37 PM   #8
Senior Member
 
Join Date: Dec 2017
Location: Clearwater, Fl
Posts: 213
Quote:
Originally Posted by tyoneonit View Post
Had the same issue, looked at everything then finally took the coiled power cord apart at the end where it plugs into our Jeep. Found several loose connections and one that had pulled out of itís connection. Tightened everything up, no problems since.
Agree, check the easiest fixes first. Also in this case the most logical. If none of that solves the problem, then the guys above should probably be you next move.
BobKatMsu is offline   Reply With Quote
Old 04-22-2018, 07:49 PM   #9
Senior Member
 
Breezy2006's Avatar
 
Join Date: Jan 2017
Posts: 349
I had issues on an 06 Spartan chassis with toad lights and there was an inline fuse on the chassis batteries.
__________________
2017 Newmar Dutchstar 4369
Spartan - ISL 450 Cummins
2016 Jeep Grand Cherokee tow
Breezy2006 is offline   Reply With Quote
Old 04-23-2018, 05:30 AM   #10
Senior Member
 
mikelm48's Avatar
 
Newmar Owners Club
Spartan Chassis
Join Date: Nov 2010
Location: Grapevine, TX
Posts: 1,041
I had a similar problem. Check the fuses in the front bay under the driver's seat. There are fuses there for the trailer lights.
__________________
Mike
2005 Kountry Star 3907, ISC330, Spartan chassis, M&G braking, Blue Ox Aventa XL
mikelm48 is offline   Reply With Quote
Old 04-23-2018, 06:45 AM   #11
Member
 
Tbeau1957's Avatar
 
Join Date: Oct 2017
Posts: 40
I have been using a tester that plugs into the trailer plug
__________________
2010 Newmar Essex ~ Spartan Chassis
Toad - 2017 Ford Raptor
Blue OX Avail, M&G Braking System
Tbeau1957 is offline   Reply With Quote
Old 04-23-2018, 06:46 AM   #12
Member
 
Tbeau1957's Avatar
 
Join Date: Oct 2017
Posts: 40
I have checked fuses and they are marked stop/turn but my turn works just no brake
__________________
2010 Newmar Essex ~ Spartan Chassis
Toad - 2017 Ford Raptor
Blue OX Avail, M&G Braking System
Tbeau1957 is offline   Reply With Quote
Old 04-23-2018, 06:48 AM   #13
Member
 
Tbeau1957's Avatar
 
Join Date: Oct 2017
Posts: 40
I did order a converter but I would still like to find the original problem and make it right. I will look and see if I can find the converter box
__________________
2010 Newmar Essex ~ Spartan Chassis
Toad - 2017 Ford Raptor
Blue OX Avail, M&G Braking System
Tbeau1957 is offline   Reply With Quote
Old 04-23-2018, 08:04 AM   #14
Senior Member
 
Newmar Owners Club
Join Date: Apr 2013
Location: On the Road
Posts: 133
Quote:
Originally Posted by Tbeau1957 View Post
I have a 2010 Newmar Essex with a spartan chassis.

I am having problems with my tow plug. I have all of my lights working except no left brake light? I have called Spartan and Newmar and nobody seems to be able to help. They say I must have a broken wire, but it just seems weird to me that I have the turn signal on the left but no brake light. Iím hoping someone can help.

Thanks Tom


We have a 2014 Newmar Ventana 4036, and experienced the same problem. Check to make sure that the gap on the male prongs of the tow plug are open. One of ours had closed thus no left break light on the tow vehicle.
Gsgarland is offline   Reply With Quote
Reply

Tags
brake, light, trailer



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No left brake light on trailer Tbeau1957 Toads and Motorhome Related Towing 6 04-08-2018 08:22 PM
Laser printed page, left on dash left permanent reverse words on the vinyl. WH347 Class A Motorhome Discussions 28 07-03-2013 12:36 PM
Non Left Behind - No Runner Left Behind Wayne M Military / Veteran RVing 0 10-13-2012 08:05 AM
No left brake light..... Romer1 MH-General Discussions & Problems 5 05-06-2011 07:27 AM
Left Brake Light/Turn Signal Not Working On Towed Jeanne M. Winnebago Industries Owner's Forum 4 02-11-2008 07:43 AM


All times are GMT -6. The time now is 07:37 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.