Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-03-2021, 08:26 PM   #1
Senior Member
 
Hmf23's Avatar
 
Join Date: Jul 2015
Location: Elk Grove, Ca
Posts: 276
No lights on dash with Key, Where to start?

I got a call from my storage facility today, they went to move my unit to get another one out and said they got nothing when inserted the key and turned it, no lights nothing. Last used was in Jan, I confirmed when I left it that it was charging. He said the panel showed 14v and looked to be going through the inverter as it should. I'm heading down there to check it out tomorrow, any suggestions on what to look for? I plan on checking volts of batteries when not plugged in. I'm sure a call to Newmar may be in the cards as well.
__________________
Brad Hansen
2018 Mountain Aire 4531
NorCal
Hmf23 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-03-2021, 08:57 PM   #2
Senior Member
 
Join Date: Jul 2014
Posts: 26,822
If he is reading house battery voltage, that doesn't mean the chassis batteries are charged.

If your charge bridge solenoid failed, the chassis batteries may have run down.
twinboat is offline   Reply With Quote
Old 03-04-2021, 06:35 AM   #3
Rd1
Senior Member
 
Join Date: Mar 2016
Posts: 592
Another issue to consider, if the chassis bat is ok, and this is on a frieghtliner chassis, the 150A fuse in the pdm could be blown. that would cut power to the dash/ign etc. as well as hwh fws, among other issues.
__________________
17LADP/FCCC
Rd1 is offline   Reply With Quote
Old 03-04-2021, 09:53 PM   #4
Senior Member
 
Hmf23's Avatar
 
Join Date: Jul 2015
Location: Elk Grove, Ca
Posts: 276
Update: Went down to coach and trouble shooter and worked with Newmar. House batts at 13.4v and chassis was 3.4v when I arrived. Placed it on a battery charger for about 10 mins and she cam to life. Worked with Newmar to diagnose the issue. Home ever said Charge Bridge Solenoid was correct. Had the batts load tested and they were good just in need of a charge. I built a jumper wire with some clips to diagnose based off Newmar recommendations. After unit had run for a short while and charged up chassis batts a little bit they were at 12.1, once I put on the jumper the voltage jumped up to 13.3v and thats when Newmar said yep thats the issue. New one ships out tomorrow and will install next week.
__________________
Brad Hansen
2018 Mountain Aire 4531
NorCal
Hmf23 is offline   Reply With Quote
Old 03-04-2021, 10:00 PM   #5
Senior Member
 
2cyber71's Avatar
 
Join Date: Jul 2008
Location: Pennsylvania
Posts: 557
I don’t know what chassis you have but I got a recall from Freightliner on my dash.
It’s not complete yet and will notify me when to come in.
Check with your chassis manufacturer if you have the Recall.
Mine has the Mercedes dash.
Opps, I missed your second post.
__________________
2020 Winnebago Horizon 42Q
Maxum Chassis, 450 ISL
99 Storm 30H, 04 Southwind 32 VS, 07 Ellipse 40FD
2cyber71 is offline   Reply With Quote
Reply

Tags
dash, light, lights



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rig wouldn't start no power to dash and transmission key pad, lessons learned. jacwjames Monaco Owner's Forum 7 11-08-2020 10:16 PM
Dash lights, running lights and brake lights are intermittent! flyr4u Monaco Owner's Forum 8 05-27-2019 06:32 AM
Problem with tail-lights, dash lights, clearance lights...2001 Intrigue daryl989mich Country Coach Owners Forum 3 08-01-2018 11:19 AM
Marker lights and dash lights flash on start up Darin63 RV Systems & Appliances 6 06-17-2018 02:51 PM
Will not start and Allison transmission key pad does not light on start Jeff753 Monaco Owner's Forum 28 12-03-2017 06:54 PM


All times are GMT -6. The time now is 07:27 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.