RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-04-2014, 05:36 PM   #1
Senior Member
 
Mahakal's Avatar
 
Join Date: Aug 2012
Posts: 173
No Power in cluster Panel

Hello everyone,
My Mh was not cranking so today i removed the batteries and got it checked. Both batteries came out good with 13.47V. What do i check next to start the Mh. This is first time happening so please pardon me if i ask some basic questions. Thanks very much for the suggestions.
__________________

__________________
2015 Ace 30.2
1981 Hondamatic
Mahakal is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-04-2014, 07:50 PM   #2
Senior Member
 
Join Date: Aug 2008
Location: Naples FL
Posts: 343
Is there a chassis battery disconnect switch, I'm sure there is, check that.
__________________

__________________
2014 Essex, 2015 Ram 1500, 2008 Harley Road King
2 Dogs
jtovo is offline   Reply With Quote
Old 03-04-2014, 08:27 PM   #3
Senior Member
 
Mahakal's Avatar
 
Join Date: Aug 2012
Posts: 173
I don't know if there is chassis disconnect. I have a switch for house battery disconnect.
__________________
2015 Ace 30.2
1981 Hondamatic
Mahakal is offline   Reply With Quote
Old 03-05-2014, 05:31 AM   #4
Senior Member
 
Join Date: Aug 2008
Location: Naples FL
Posts: 343
Take a look at the manual, I'm not familiar with your coach but I have replaced my battery disconnect switch twice & that's exactly what happens when one goes bad.
__________________
2014 Essex, 2015 Ram 1500, 2008 Harley Road King
2 Dogs
jtovo is offline   Reply With Quote
Old 03-05-2014, 07:07 AM   #5
Senior Member
 
SteveR161's Avatar
 
Newmar Owners Club
Join Date: Mar 2011
Location: No home base "anywhere we park"
Posts: 101
I've had loose connections at the ignition switch that caused a no start situation. When this occurred, I could start the engine with a screwdriver at the starter connections.
I tightened the connections at the ignition switch, reinstalled, and no problems since.
__________________
Steve Richard and Ann Glaude
Shelby (poodle parti merle)
2002 MADP 3954 Cummins ISL 370 2003 Honda Pilot
SteveR161 is offline   Reply With Quote
Old 03-05-2014, 11:24 AM   #6
Senior Member
 
Mahakal's Avatar
 
Join Date: Aug 2012
Posts: 173
Thanks guys. Will look into it as weather permits and keep you posted.
__________________
2015 Ace 30.2
1981 Hondamatic
Mahakal is offline   Reply With Quote
Old 03-05-2014, 02:33 PM   #7
Senior Member
 
Randy125's Avatar
 
Newmar Owners Club
Join Date: Dec 2011
Posts: 475
Do you get any lights or buzzers when you turn the key?
__________________
2002 KSDP 3669/Freightliner XC CHASSIS/Cummins 5.9 ISB 300hp
Joplin, MO
Randy125 is offline   Reply With Quote
Old 03-05-2014, 03:01 PM   #8
Senior Member
 
Mahakal's Avatar
 
Join Date: Aug 2012
Posts: 173
No buzzer and lights. Backup camera start.
__________________
2015 Ace 30.2
1981 Hondamatic
Mahakal is offline   Reply With Quote
Old 03-05-2014, 04:12 PM   #9
Senior Member
 
GaryKD's Avatar
 
Newmar Owners Club
Join Date: Jul 2006
Location: Wellington, Florida
Posts: 13,558
Hi Mahakal,
1. If you have a chassis battery disconnect switch it will be in the engine compartment.
2. When the batteries were tested, was a load test done?
3. If the above are okay, take a VDC reading at the starter. You'll need an assistant to turn the ignition key to the start position when the reading is taken. If no VDC then you'll need to determine if the start relay and or any fuses in the start circuit are bad.
__________________
Gary
2005 Newmar KSDP 3910 + GMC ENVOY XUV 37K lbs Moving Down The Road
The Avatar Is Many Times Around The USA
Nobody Knows Your Coach Like Somebody Who Owns One Just Like Yours
GaryKD is offline   Reply With Quote
Old 03-05-2014, 04:31 PM   #10
Senior Member
 
Mahakal's Avatar
 
Join Date: Aug 2012
Posts: 173
Hi
The battery tested good. Both at 13.47v. What does vdc mean. Sorry not too familiar with the acronym.
__________________
2015 Ace 30.2
1981 Hondamatic
Mahakal is offline   Reply With Quote
Old 03-05-2014, 05:26 PM   #11
Member
 
Join Date: Mar 2012
Location: Anacortes, WA
Posts: 32
Is there any power at all to the dash panel?

We had an issue with ours where the entire dash panel was dead. It turned out the leveler tripped the engine breaker. The yellow rotating lever of that breaker is just visible through the rear engine cover on our DADP. Once I reset that breaker, the power to the dash was restored.
__________________
Tim Butterfield
2009 43' Dutch Aire, Spartan Mountain Master GT, Cummins ISL 425 HP, Onan 10KW diesel, 2014 Jeep Cherokee V6 Trailhawk, Blue Ox Aventa LX, Roadmaster base plate, Unified tow brake
TButterfield is offline   Reply With Quote
Old 03-05-2014, 05:52 PM   #12
Senior Member
 
Randy125's Avatar
 
Newmar Owners Club
Join Date: Dec 2011
Posts: 475
I also have a 2002 KSDP and the previous owner had a similiar problem and it turned out to be a 150 amp fuse located on the frame rails by the engine I believe that is where it was located.
__________________
2002 KSDP 3669/Freightliner XC CHASSIS/Cummins 5.9 ISB 300hp
Joplin, MO
Randy125 is offline   Reply With Quote
Old 03-06-2014, 08:00 AM   #13
Senior Member
 
HHIDan's Avatar
 
Join Date: Mar 2011
Location: Ottawa Ontario Canada
Posts: 1,260
Had exact same, turned out to be a loose wire near starter. Turn the key on then check the voltage at the engine kill switch if you have one. Should be 12v with the kill switch on or off. If you measure something like 3v or so with the kill switch in the on position, you have the same problem. Easy fix.
__________________
DanielB
Looking for small Class C, sold Newmar MADP
HHIDan is offline   Reply With Quote
Old 03-06-2014, 09:23 AM   #14
Senior Member
 
GaryKD's Avatar
 
Newmar Owners Club
Join Date: Jul 2006
Location: Wellington, Florida
Posts: 13,558
Hi Mahakal,
VDC is "volts DC". The question about the batteries being load tested has not been answered. A load test is just as or more important than the state of charge.
__________________

__________________
Gary
2005 Newmar KSDP 3910 + GMC ENVOY XUV 37K lbs Moving Down The Road
The Avatar Is Many Times Around The USA
Nobody Knows Your Coach Like Somebody Who Owns One Just Like Yours
GaryKD is offline   Reply With Quote
Reply

Tags
panel, power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pedestal or MH Power Problem sgtjoe National RV Owner's Forum 32 02-19-2014 06:47 PM
No power to appliances and outlets JustCruising Monaco Owner's Forum 23 02-19-2014 06:30 AM
Levelling jacks: Power Gear vs HWH Deucenut Class A Motorhome Discussions 1 02-03-2014 07:01 PM
Issue with no power @ outlets :( ShineGinny Travel Trailer Discussion 23 01-19-2014 09:24 PM
Power to antenna power booster Ace 123 Gulf Stream Owner's Forum 5 11-09-2013 08:38 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 02:19 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×