RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-02-2018, 09:07 AM   #1
Junior Member
 
mskier's Avatar
 
Join Date: Mar 2009
Location: Indio
Posts: 27
No power into coach

Everything has been working fine until last night. We have a 2017 Dutchstar and last night shore power quit. I knew because the heated floors were cold. I went to the power pole and there was no light on the surge protector. I disconnected the surge protector thinking it may have gone bad and plugged directly into the shore power and everything worked. Went. back to bed thinking I need a new surge protector. Woke up this morning to cold floors and inverting. The surge protector still shows no light when plugged in but the little green light on the power reel cord is on. Disconnected the power and ran the generator and all is well. Any suggestions on where to start troubleshooting? of course itís a holiday weekend but any advice is appreciated.
__________________

__________________
2017 Dutch Star 4002
mskier is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-02-2018, 09:12 AM   #2
Senior Member
 
Stuart W's Avatar


 
Newmar Owners Club
Join Date: Nov 2015
Location: LA CA
Posts: 6,190
No power into coach

I would try retracting and extending the cord real, the contacts have been very problematic. Try to end up at a different length
__________________

__________________

2018 Dutch Star 4369 Spartan!
2017 Jeep Wrangler Smoky Mountain
2016 Canyon Star 3710 SOLD
Stuart W is offline   Reply With Quote
Old 09-02-2018, 09:37 AM   #3
Junior Member
 
mskier's Avatar
 
Join Date: Mar 2009
Location: Indio
Posts: 27
That made sense, but no joy. Still scratching my head
__________________
2017 Dutch Star 4002
mskier is offline   Reply With Quote
Old 09-02-2018, 09:39 AM   #4
Junior Member
 
Join Date: Aug 2016
Posts: 20
The first thing I would do is reset the
30 amp breaker on the inverter. It is
located in the basement between the
frame rails.On the curb side.
Good luck
grummd is offline   Reply With Quote
Old 09-02-2018, 09:45 AM   #5
Senior Member
 
Stuart W's Avatar


 
Newmar Owners Club
Join Date: Nov 2015
Location: LA CA
Posts: 6,190
No power into coach

Well the reel could have failed completely (many have), or next it could be the transfer switch. Sometimes connections have been known to loosen up. The next diagnosis step assuming the power pedestal is ok would be to remove the cover on the transfer switch, note this is hazardous and should only be done if you have skills in this area. With a meter you could verify power coming in from the cord reel, next verify that power is making it through the transfer switch contacts. You could unplug, turn off auto start, inverter and solar if equipped and have a look inside the transfer switch for loose contacts, just use caution.
__________________

2018 Dutch Star 4369 Spartan!
2017 Jeep Wrangler Smoky Mountain
2016 Canyon Star 3710 SOLD
Stuart W is offline   Reply With Quote
Old 09-02-2018, 10:05 AM   #6
Senior Member
 
Stuart W's Avatar


 
Newmar Owners Club
Join Date: Nov 2015
Location: LA CA
Posts: 6,190
Quote:
Originally Posted by grummd View Post
The first thing I would do is reset the
30 amp breaker on the inverter. It is
located in the basement between the
frame rails.On the curb side.
Good luck


Yes also a good place to check
__________________

2018 Dutch Star 4369 Spartan!
2017 Jeep Wrangler Smoky Mountain
2016 Canyon Star 3710 SOLD
Stuart W is offline   Reply With Quote
Old 09-02-2018, 10:23 AM   #7
Senior Member
 
ewlee's Avatar
 
Join Date: Nov 2015
Posts: 694
Check the output at the shore power pole, first.
__________________
Wayne, Cindy, & Golden Retriever Finn
2017 London Aire, 2014 CRV, Go Hokies
ewlee is offline   Reply With Quote
Old 09-02-2018, 10:28 AM   #8
Junior Member
 
mskier's Avatar
 
Join Date: Mar 2009
Location: Indio
Posts: 27
The breaker is reset, but no joy.
__________________
2017 Dutch Star 4002
mskier is offline   Reply With Quote
Old 09-02-2018, 10:29 AM   #9
Junior Member
 
mskier's Avatar
 
Join Date: Mar 2009
Location: Indio
Posts: 27
Thanks, but that is beyond my skills but it gives me something to suggest if/when I find a technician
__________________
2017 Dutch Star 4002
mskier is offline   Reply With Quote
Old 09-02-2018, 10:39 AM   #10
Senior Member
 
Stuart W's Avatar


 
Newmar Owners Club
Join Date: Nov 2015
Location: LA CA
Posts: 6,190
Have you asked the park to check the pedestal ?
__________________

2018 Dutch Star 4369 Spartan!
2017 Jeep Wrangler Smoky Mountain
2016 Canyon Star 3710 SOLD
Stuart W is offline   Reply With Quote
Old 09-02-2018, 10:50 AM   #11
Senior Member
 
plane's Avatar
 
Newmar Owners Club
Join Date: Sep 2005
Location: Tulsa, OK
Posts: 584
Quote:
Originally Posted by Stuart W View Post
I would try retracting and extending the cord real, the contacts have been very problematic. Try to end up at a different length
As stated earlier this has been an issue for several, a friend that we were traveling with would have to unwind his cord completely and then, retract and see it it helped
__________________
Jim Mefford
2018 New Aire 3343
plane is offline   Reply With Quote
Old 09-02-2018, 11:02 AM   #12
Senior Member
 
Join Date: Jul 2011
Posts: 125
I had a similar issue, turned out to be the transfer switch, itís easy to check: unplug from shore power, turn off AGS, pop the plastic cover of the automatic transfer switch. You can test it by pressing the blue bar in. It should glide in with out issue. If it does not push in, you have found the issue. You can plug into shore power and watch the switch activate and if it is working properly, your will hear the loud click after a few moments. On mine, Newmar installed the bottom of the line transfer switch from Surge Guard.
ddowntown is offline   Reply With Quote
Old 09-02-2018, 11:05 AM   #13
Junior Member
 
mskier's Avatar
 
Join Date: Mar 2009
Location: Indio
Posts: 27
Problem resolved

Thanks for all the great responses, turns out it is the power pole. Not great, but better than having to troubleshoot the coach
__________________
2017 Dutch Star 4002
mskier is offline   Reply With Quote
Old 09-02-2018, 11:08 AM   #14
Senior Member
 
Stuart W's Avatar


 
Newmar Owners Club
Join Date: Nov 2015
Location: LA CA
Posts: 6,190
Happy ending
__________________

__________________

2018 Dutch Star 4369 Spartan!
2017 Jeep Wrangler Smoky Mountain
2016 Canyon Star 3710 SOLD
Stuart W is offline   Reply With Quote
Reply

Tags
power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is it bad to leave the coach plugged into shore power full time relaxn Class A Motorhome Discussions 33 04-04-2018 06:22 PM
House Batteries Not Providing Power. Cannot Get Into Coach. Trige Gleim Class A Motorhome Discussions 12 02-01-2018 08:19 PM
2013 Tiffin Allegro QBA - No Coach Power when plugged into Shore Power TiffnAllegro Tiffin Owner's Forum 4 05-16-2016 01:04 PM
Battery Disconnect BD1 only Operates when coach plugged into shore power kcolivier Newmar Owner's Forum 5 10-13-2015 10:18 PM
into Canada, back into US... MisterT Palazzo Motorhomes 15 10-06-2015 08:21 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 03:26 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×