Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-22-2021, 12:46 AM   #1
Senior Member
 
lrwinddancer's Avatar


 
Join Date: Sep 2020
Location: Athens, AL
Posts: 142
No Power to Coach

I have a 2020 Dutch Star with an issue. When plugged into a tested good 50amp shore power outlet I am not getting any power to the coach. Supply tested with 122VAC on both legs but the coach meter says no service. I also noticed the two green LEDS that are normally on in the surge protector when plugged in are not on. Any ideas? I am 2 days in on a 4 week trip.
lrwinddancer is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-22-2021, 03:24 AM   #2
Senior Member
 
Xmcdog's Avatar
 
Join Date: Dec 2019
Location: Nova Scotia
Posts: 1,473
You are not getting power to the surge protector. What is upstream of it?
__________________
Jeff and Annette Smith
04 Glendale Titanium 24E29 Fifth
2011 GMC Diesel 2500 HD
Xmcdog is online now   Reply With Quote
Old 04-22-2021, 05:36 AM   #3
Senior Member
 
ewlee's Avatar
 
Join Date: Nov 2015
Posts: 838
The surge protector is not allowing power from the pedestal to pass through. There can only be three issues given you have checked both legs and have 122VAC and the surge protector lights are not working. 1) the surge protector is bad. 2) There is a bad neutral on the pedestal. 3) There is a bad ground on the pedestal. Suggest you move to another source of power.
__________________
Wayne, Cindy, & Golden Retriever Finn
2017 London Aire, 2014 CRV, Go Hokies
ewlee is offline   Reply With Quote
Old 04-22-2021, 05:54 AM   #4
Senior Member
 
ThunderRidge's Avatar
 
Join Date: Jul 2020
Location: Winter: Fort Wilderness Campground
Posts: 254
Can you power the coach with the generator?
Did you test all legs of the power pedestal with a multi-meter?
Attached Thumbnails
Click image for larger version

Name:	91BD630A-36A6-494A-84A4-E5F281FBBC4E.jpeg
Views:	14
Size:	42.9 KB
ID:	325927  
__________________
Paul, Cathy and Chocolate Lab, RIO
2018 Newmar Dutch Star 4362 (Spartan)
2012 Ford F-150
ThunderRidge is offline   Reply With Quote
Old 04-22-2021, 08:02 AM   #5
Senior Member
 
lrwinddancer's Avatar


 
Join Date: Sep 2020
Location: Athens, AL
Posts: 142
Quote:
Originally Posted by ThunderRidge View Post
Can you power the coach with the generator?
Did you test all legs of the power pedestal with a multi-meter?
No the generator starts but does not power anything. I can not even get my inverter to come on. System just reads low battery. Called Newmar, tested breakers, reset GFI's through out. Mobil tech has been notified, waiting for call back. Suspect the surge protector or maybe something in the charging system is bad. Coach started but it gives me a low battery message. Been trying to charge batteries with generator but again nothing is charging. I guess this is the part where we are having fun!!!
Yes I used a DVM and measured 122VAC on both legs. Thanks for the ideas.
lrwinddancer is offline   Reply With Quote
Old 04-22-2021, 08:54 AM   #6
Senior Member
 
NoDents4U's Avatar
 
Join Date: Sep 2016
Location: Rapid City, SD
Posts: 115
I would check the connections in and out of the cord reel. I had a bad connection inside the cord reel and had intermittant power problems. I took the cord reel out and checked all connections. I had a loose connection from the cord reel to the surge protector.
__________________
Mark & Cathy McCormick
2016 Dutch Star 4369
2014 Honda CRV
NoDents4U is offline   Reply With Quote
Old 04-22-2021, 09:01 AM   #7
Senior Member
 
Ljwt330's Avatar
 
Join Date: Jan 2018
Location: Capistrano Beach, California
Posts: 3,401
Unless the surge protector is wired after the transfer switch, the fact that the generator also fails to send ac to the coach points to the transfer switch, IMO. It sounds like nothing is passing through the TS, assuming all breakers in the main panel have been checked.

Have you taken voltage readings at the input/output lugs of the TS?
Do you hear the TS “clunk” when shore power is switched to generator?
__________________
Larry, Eileen, and Finley
2004 Alpine 36FDDS
Third motor home, first Alpine, no need for another.
Ljwt330 is online now   Reply With Quote
Old 04-22-2021, 10:02 AM   #8
Senior Member
 
patgreenair's Avatar
 
Newmar Owners Club
Join Date: Mar 2017
Location: Panama City, Florida
Posts: 168
I too would be looking at the transfer switch. If you're sure all breakers are "on", that's the most obvious thing to me to start with. Not sure if the surge suppressor comes into play when running the generator or not, but I know the transfer switch does!
__________________
Pat & Peg (and our golden retrievers)
2016 London Aire 4519
2018 F-150
patgreenair is offline   Reply With Quote
Old 04-22-2021, 10:17 AM   #9
Senior Member
 
ewlee's Avatar
 
Join Date: Nov 2015
Posts: 838
Quote:
Originally Posted by lrwinddancer View Post
I have a 2020 Dutch Star with an issue. When plugged into a tested good 50amp shore power outlet I am not getting any power to the coach. Supply tested with 122VAC on both legs but the coach meter says no service. I also noticed the two green LEDS that are normally on in the surge protector when plugged in are not on. Any ideas? I am 2 days in on a 4 week trip.
When the OP states that the two green lights that are normally on are NOT, that leads me to think the surge protector is plugged into the pedestal and then the cord reel is plugged into the surge protector. In addition it doesn't compute that the generator is not producing power. Could he have overloaded the generator after the initial problem and this is a secondary issue. I wish we had more information.
__________________
Wayne, Cindy, & Golden Retriever Finn
2017 London Aire, 2014 CRV, Go Hokies
ewlee is offline   Reply With Quote
Old 04-22-2021, 11:34 AM   #10
"Formerly Diplomat Don"
 
Dutch Star Don's Avatar
 
Newmar Owners Club
Join Date: Apr 2005
Location: Moorpark, Ca.
Posts: 17,851
Most likely the OP has the combo "Surge Guard" Surge Protector/Transfer Switch that Newmar has been using for a coupe of years.

I would give Surge Guard a call while waiting for the mobile tech and see if they can walk you through a diagnosis. (800) 780-4324

I would also disconnect the shore power, roll the power cord a out a few more inches and then reconnect and see what happens. You could have a burned spot on the power cord reel. Just something to try while you're waiting.
__________________
Don & Mary
2019 Newmar Dutch Star 4018 (Freightliner)
2019 Ford Raptor
Dutch Star Don is offline   Reply With Quote
Old 04-23-2021, 08:45 AM   #11
Member
 
Join Date: Aug 2019
Posts: 68
Something I experienced on a 2019 Ventana 3709 that maybe worth checking. Bottom line is what are the condition of your house batteries. On my unit the house batteries went dead and the entire electrical system went down, both DC and AC. You could not get AC into the coach, without house DC, which operate all controls. Worth a check with a multimeter directly on the house batteries. In my case I charged the house batteries with a MANUAL charger. Newer automatic chargers will not work on dead or very low batteries. If no Manual charger is available, jump to a car or truck battery. JUST be sure to jump across a series pair of golf cart batteries, so you have 12 volts wiring on both ends. Extremely important to get across a series pair of golf cart house batteries.
__________________
Pete
2019 Newmar Ventana LE 37
IRV2 Member November 2019
PeteDr is offline   Reply With Quote
Old 04-29-2021, 12:47 PM   #12
Senior Member
 
lrwinddancer's Avatar


 
Join Date: Sep 2020
Location: Athens, AL
Posts: 142
Long story I will update when I get home to a keyboard. The transfer switch went bad. Quite an adventure getting a replacement.
__________________
Lynn
Athens, AL 35611
2020, Dutch Star 4081, 2020 Forest River FR3 34DS
lrwinddancer is offline   Reply With Quote
Old 05-01-2021, 07:10 PM   #13
Member
 
Join Date: Jan 2021
Posts: 39
Quote:
Originally Posted by lrwinddancer View Post
Long story I will update when I get home to a keyboard. The transfer switch went bad. Quite an adventure getting a replacement.
We do not have power to our coach all of the sudden, DC only, not sure what the problem could be, I also have a window in the half bath that has separated, we have never used the coach and already have these problems, we plan on using the coach a few weeks a year, really disappointing that we have these issues before our first trip. We did buy it used but it was never used, sat in storage 95 % of the time, 2019 model with 2400 miles.
Kampers is offline   Reply With Quote
Old 05-07-2021, 09:54 PM   #14
Junior Member
 
Newmar Owners Club
Freightliner Owners Club
Join Date: Jul 2020
Location: New Mexico
Posts: 6
Quote:
Originally Posted by lrwinddancer View Post
Long story I will update when I get home to a keyboard. The transfer switch went bad. Quite an adventure getting a replacement.
We are currently having the exact same problem with our 2020 New Aire 3545. It has been sitting in our storage facility since April 17th with a bad transfer switch. All 8 house batteries are now totally dead and the chassis batteries are barely hanging on. This week Newmar finally shipped the mobile tech the wrong transfer switch. They promised to next-day air the correct part on on Tuesday and it has yet to arrive.

We purchased the coach at the end of October 2020. It has 2600 miles on it. Has been used on 3 trips (including the trip home from the dealership where we purchased it.). It failed on that trip and spent a week at Freightliner. On the next trip it had a hydraulic system failure which rendered the slides and jacks inoperable. On trip number 3 we lost all power, had to bring the slides in on battery, and limped home in the middle of the night in a snowstorm rather than freeze to death with no heat. Oh, and both sleep number mattresses burst because we didn't have the power to deflate them before coming over the mountain.

Newmar's response to all of this has been, underwhelming, to put it mildly.

Prior to the New Air we owned a Leisure Travel Unity for 7 years. In that time we had no major system failures.

We are beginning to strongly regret our decision to purchase the Newmar New Aire.
Avalon is offline   Reply With Quote
Reply

Tags
no power, power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
AIM-HI :: 1995 country coach Kenai Coach 2005 Country Coach Intrigue 40' Suite AIM-HI iRV2 Owners Registry 0 12-14-2020 11:27 AM
No coach power. All chassis power items working. eddiehop Class A Motorhome Discussions 5 08-09-2015 06:04 AM
No coach power only generator or show power Retiredcable RV Systems & Appliances 6 06-07-2015 08:35 AM
Country Coach or American Coach or Alpine Coach Troys66 Class A Motorhome Discussions 14 01-04-2015 06:38 PM
No coach power w/o coach batteries Turbofans Newmar Owner's Forum 3 04-24-2014 04:21 AM


All times are GMT -6. The time now is 07:42 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.