Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-01-2015, 07:55 PM   #1
Junior Member
 
Join Date: Nov 2012
Posts: 12
Exclamation no power to eplex screen

The bedroom eplex screen quit working last year. We replaced a zone 1 sensor and had to program the eplex, all went well. We then noticed the bedroom screen had lit up but was no operable. unpluged the 2 power wires to the back of the bedroom screen hoping it would reset. the screen did some blinking but never came up. Now a bigger issue!!! we have no screen in the cockpit either. Everything seems to work on the coach but now we have no eplex system at all.
Can anyone help?
2006 Essex
alaska is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-01-2015, 08:30 PM   #2
Junior Member
 
Join Date: Nov 2012
Posts: 12
e-plex problem

The bedroom eplex screen quit working last year. We replaced a zone 1 sensor and had to program the eplex, all went well. We then noticed the bedroom screen had lit up but was no operable. unpluged the 2 power wires to the back of the bedroom screen hoping it would reset. the screen did some blinking but never came up. Now a bigger issue!!! we have no screen in the cockpit either. Everything seems to work on the coach but now we have no eplex system at all.
Can anyone help?
2006 Essex
alaska is offline   Reply With Quote
Old 03-01-2015, 09:09 PM   #3
Senior Member
 
FlyingDiver's Avatar
 
Newmar Owners Club
Join Date: May 2007
Location: Somewhere....
Posts: 4,054
Try forcing the whole system to reboot by removing all 12V from the coach. The Use/Store switch should do this if you select Store mode. Wait about 30 sec, then restore power and see if it comes back up.

If not, a call (and maybe a trip) to Nappanee is in your future.
__________________
2008 King Aire 4562, Spartan K3(GT) w/ Cummins ISX 600
2014 Jeep Grand Cherokee Overland 5.7L V8 Hemi w/ Blue Ox Aventa LX Tow Bar and baseplate, SMI Air Force One brake
FlyingDiver is offline   Reply With Quote
Old 03-01-2015, 09:39 PM   #4
Member
 
Newmar Owners Club
Join Date: Jun 2013
Location: Dickinson, Texas
Posts: 58
Sounds like your issue is more severe than the one I had, but a couple of months ago I had a completely dark bedroom screen. The Newmar tech told me to turn off the batteries at the main battery disconnect in the overhead cabinet above the dash and turn it back on after 30 seconds. I guess the equivalent of a reboot. In any event that worked for me- at least this time.
__________________
Bob and Monica, towing our Honda CRV behind a 2011 Essex with Gabby the Maltese and just beginning our retirement adventures!
Monfish is offline   Reply With Quote
Old 03-01-2015, 10:23 PM   #5
Junior Member
 
Join Date: Nov 2012
Posts: 12
Thanks for the suggestion. We tried the disconnect but didn't work. Hoping we didnt fry the system
alaska is offline   Reply With Quote
Old 03-01-2015, 11:09 PM   #6
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 30,743
Not sure you have these downloads that may help plus other threads in QT's # 3.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 03-03-2015, 01:03 PM   #7
Junior Member
 
Join Date: Nov 2012
Posts: 12
Solved. Newmar led us to a false door in the powercord compartment where another fuse box existed. A blown fuse. Whoo hoo. only a couple bucks
alaska is offline   Reply With Quote
Old 03-03-2015, 02:13 PM   #8
Senior Member
 
danleininger's Avatar


 
Newmar Owners Club
Join Date: Feb 2012
Location: Lake Wales, FL (Lake Ashton RV Community)
Posts: 924
Wow, another fuse box location!!!
Glad your fixed.
__________________
Dan Leininger
2019 Mountain Aire 4534 and a 2017 Ford Expedition 4x4
danleininger is offline   Reply With Quote
Old 03-03-2015, 02:54 PM   #9
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 30,743
Thanks for the follow up Alaska something to remember like where the Bird or B.I.M. maybe hiding also.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 03-05-2015, 02:03 AM   #10
Senior Member
 
spinn's Avatar
 
Join Date: Oct 2012
Location: Denton, TX, 76207
Posts: 2,158
Thanks Alaska good to know! And welcome to the forum
__________________
Steve Pinn
2008 Newmar Essex-4514
2009 Honda CRV
spinn is offline   Reply With Quote
Old 03-05-2015, 02:27 AM   #11
Senior Member
 
Lloydu's Avatar
 
Newmar Owners Club
Spartan Chassis
Join Date: Apr 2011
Location: Portland, Oregon
Posts: 549
Thanks. I will "subscribe" your post for future reference.
Lloydu is offline   Reply With Quote
Reply

Tags
power, scr



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Adding more power vs safety to engine Smitty77 Cummins Engines 15 10-13-2014 09:06 AM
No power to lift pump? stkhlm Country Coach Owners Forum 2 10-08-2014 02:02 PM
Hybrid Solar / Shore Power Solution Wanted SteveUpp Going Green 20 09-23-2014 07:32 AM
No Power from Shore Power and will not charge batteries Airstream14 Class A Motorhome Discussions 19 07-07-2014 09:04 AM
Pedestal or MH Power Problem sgtjoe National RV Owner's Forum 32 02-19-2014 07:47 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 10:18 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.