Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-14-2019, 06:10 PM   #1
Senior Member
 
Winepress's Avatar
 
Join Date: Jul 2012
Posts: 1,569
No Spin Zone

My Whirlpool washer doesnít want to spin with wet clothes in the machine. Passes all diagnostic tests. Searching the forum shows this to be a common problem, not a matter of if, but more like when. Not sure itís worth repairing considering the bad reputation of this series of machines. Thanks Newmar for going with the low cost bidder, thanks Whirlpool for making a POC.

Has anyone replaced theirs with a Splendide? I found one for about $739 delivered. Had a Splendide in my old motorhome, it was great. I think Newmar switched for 2020 to Splendide.
__________________
2018 Dutch Star 4369
Everything was working fine, until it wasn't.
Winepress is online now   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-14-2019, 07:43 PM   #2
Member
 
Join Date: Jul 2014
Posts: 67
Ours had that problem too. We turned off the breaker for 5 minutes and it reset itself.
mr-kolby is offline   Reply With Quote
Old 06-14-2019, 07:45 PM   #3
Junior Member
 
DanleyFarm's Avatar
 
Join Date: Apr 2013
Location: Franklinville, NJ
Posts: 24
Mine did the same thing as yours. Did same test with same results. Had enough of that crap and put in the Splendide last week and couldnít be any happier! My last Splendide was 11 yrs old and still going strong when I sold my last coach. Your cost is what I paid for mine. Good luck!
__________________
April & Colin
2017 Dutch Star 4369, 2006 Allegro Bus
2020 Jeep Gladiator, 2015 Fiat 500
DanleyFarm is offline   Reply With Quote
Old 06-15-2019, 07:50 AM   #4
Senior Member
 
what next's Avatar
 
Newmar Owners Club
Fleetwood Owners Club
Workhorse Chassis Owner
Spartan Chassis
Join Date: Feb 2012
Location: Northern IL
Posts: 561
After years of that same problem I switched ours out last month.
__________________
2010 Dutch Star 4333
2009 Honda Accord- Brakemaster
what next is offline   Reply With Quote
Old 06-15-2019, 08:03 AM   #5
Senior Member
 
FLJOE's Avatar
 
Join Date: Oct 2017
Location: Full Timing From SW Florida
Posts: 1,793
There has been at least two or three other threads on this exact subject. It seems Whirlpool had some defective, or at least "sensitive" washer models they produced around 2016/2017. Of course we got one in our Ventana.

For the first 18 months we fought it off and on. Whirlpool techs visited our coach twice (once at the factory) and did repairs/modifications. The last fix was the shim in the door latch deal.

We could get a final spin one out of 5 loads, or it might be 3 out of 5 loads.

We made a factory appointment for a chair issue and asked about getting a replacement. Newmar wasn't willing to do a "goodwill" replacement so we were planning on just paying and having them slap a Spendide in when we have our appointment in October...Ö.but.....

The last month or so it has been working much better. It has only failed to do the final spin probably once out of 20 loads. The only thing different we have done is switch to Splendide powder soap and we are now using a water softener. We have changed camp sites a few times so I can't believe it has anything to do with the leveling of the coach or machine.

We will see if it continues to function this good we may hold off on replacing it for now.
__________________
Stand For The Flag.....Kneel For The Fallen
2021 F350 pulling Cyclone 4006 Fiver
U.S. Army: VN 71-72 (64B20)
FLJOE is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hydro-hot HHE200 with two zone, only one zone delivers hot air swsarmyknife RV Systems & Appliances 8 06-15-2019 06:03 PM
DS 2017 - Zone 1 vs Zone 3 Furnace specmga1 Newmar Owner's Forum 3 02-08-2018 01:02 PM
Dometic Blizzard NXT 15k Dual zone system doesn't see second zone Nu2FullTime RV Systems & Appliances 7 06-12-2017 10:37 AM
Zone 2 AC not cold but Zone 1 is cold rosannemarie Newmar Owner's Forum 12 08-30-2012 08:08 PM
spin on filter price sal avitabile Allison Transmission Forum 4 12-01-2008 07:19 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 10:41 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.