RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-04-2016, 02:36 PM   #1
Member
 
Newmar Owners Club
Join Date: May 2015
Location: Mammoth Lakes, CA
Posts: 77
Oasis burner

I've turned our thermostat to furnace and the Oasis burner and electric element 1&2 on. The burner shuts off after about 4 minutes even though the thermostat temp has not been reached.

I've called the Oasis tech people and they walked me through some diagnostics and in the end said I need to take it to a service center. Problem is the nearest one to us is about 200 miles.

Has anyone else had this issue?
__________________

__________________
Joel, Janice and Jack
2015 Dutch Star 4018
2003 Toyota Tacoma 4x4 (flat towed)
jbrown000 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-04-2016, 02:46 PM   #2
Senior Member
 
Steve Ownby's Avatar
 
Join Date: Nov 2008
Location: Cosby, Tn
Posts: 6,587
Quote:
Originally Posted by jbrown000 View Post
I've turned our thermostat to furnace and the Oasis burner and electric element 1&2 on. The burner shuts off after about 4 minutes even though the thermostat temp has not been reached.



I've called the Oasis tech people and they walked me through some diagnostics and in the end said I need to take it to a service center. Problem is the nearest one to us is about 200 miles.



Has anyone else had this issue?

Even though the burner shuts down, do the fans on the heat exchangers keep running? If so, does the diesel burner ever fire back up?
__________________

__________________
Steve Ownby
Full time since 2007
2003 Monaco Signature
Steve Ownby is offline   Reply With Quote
Old 10-04-2016, 02:58 PM   #3
Senior Member
 
Carefree's Avatar


 
Newmar Owners Club
Join Date: Apr 2016
Location: Carefree, AZ
Posts: 595
I'm a little confused.The Oasis burner will only run as long as it takes to heat up the Anti-freeze. It will then shut off until a set minimum temperature of the anti-freeze is reached and fire back up. You should hear and feel a fan blowing continuously inside the coach until your thermostat reaches the set temperature. It's the same procedure as with hot water.
__________________
Juergen & Margit
2016 Newmar DS 4018
2016 Jeep GC Limited
Carefree is online now   Reply With Quote
Old 10-04-2016, 03:21 PM   #4
Senior Member
 
Algoma's Avatar
 
Join Date: Nov 2007
Location: Charleston, WV
Posts: 3,222
As Carefree says the burner is not controlled by the thermostat. Even if you had the thermostat OFF the burner would turn on now and then to keep that tank of coolant hot so that you would have instant hot water if needed.
Which zones have you set the thermostat to furnace? If you cannot feel heat in the radiators but still get hot water it may be a pump has failed. This has happened to some owners.
__________________
John and Mary Knight
2015 Newmar Ventana 4311 - wheelchair accessible
2015 Cadillac SRX Luxury AWD
Algoma is online now   Reply With Quote
Old 10-04-2016, 07:39 PM   #5
Senior Member
 
DocJim's Avatar
 
Join Date: May 2008
Location: Kelowna, B.C.
Posts: 194
The system will also shut down if you are low on hydronic fluid. Our expansion tank is high on the passengers side of the engine bay at the rear of the coach.
We check the level regularly and always carry extra fluid with us.
__________________
2018 Ram 1500 Longhorn
2019 Mustang Bullitt
DocJim is offline   Reply With Quote
Old 10-04-2016, 10:03 PM   #6
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 30,209
QT's # 3 you will find this thread by DS Don in his Mod section and other threads by him on the Oasis heating unit.
All the links below in my signature will lead you to this type of information for your Newmar.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 10-05-2016, 08:10 AM   #7
Member
 
Newmar Owners Club
Join Date: May 2015
Location: Mammoth Lakes, CA
Posts: 77
The fan in zone 1 continues to run and blow cold air. The burner will eventually fire up again, but not for a very long time. To test the system I've set the thermostat in zone 1 for 70 degrees and when the burner shuts off, after about 4 minutes, the thermostat reads the inside temp as 59.

The Oasis hydronic tank is just below the full at cold level.

I have both zones set to furnace. I do get warm air from the registers in zone 2, the rear of the coach, and that fan will shut off, however the zone 1 fan will continue to blow cold air when the burner shuts off.

We typically leave the burner off and the ac set to 1&2, and turn the burner on when we want to use the furnace or the city water is cold and want a boost for a shower.

Thanks everyone for the help.
__________________
Joel, Janice and Jack
2015 Dutch Star 4018
2003 Toyota Tacoma 4x4 (flat towed)
jbrown000 is offline   Reply With Quote
Old 10-05-2016, 08:50 AM   #8
Senior Member
 
Algoma's Avatar
 
Join Date: Nov 2007
Location: Charleston, WV
Posts: 3,222
Sounds like your zone 1 pump isn't working.
__________________
John and Mary Knight
2015 Newmar Ventana 4311 - wheelchair accessible
2015 Cadillac SRX Luxury AWD
Algoma is online now   Reply With Quote
Old 10-05-2016, 12:49 PM   #9
Member
 
Newmar Owners Club
Join Date: May 2015
Location: Mammoth Lakes, CA
Posts: 77
Any idea where this zone 1 pump is, and it is something I can fix?
__________________
Joel, Janice and Jack
2015 Dutch Star 4018
2003 Toyota Tacoma 4x4 (flat towed)
jbrown000 is offline   Reply With Quote
Old 10-05-2016, 01:22 PM   #10
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 30,209
If you looked through the thread link provided you would have come across this link in a following post its the brake down of the Oasis system and zones are controlled by the Heat Control Module.
I believe one motor pushes the hot water through the zones opened by control module.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 10-05-2016, 02:50 PM   #11
Senior Member
 
Algoma's Avatar
 
Join Date: Nov 2007
Location: Charleston, WV
Posts: 3,222
Quote:
Originally Posted by jbrown000 View Post
Any idea where this zone 1 pump is, and it is something I can fix?
Instructions on replacing the pump are on page 49 of the Service Manual. I am attaching a copy in case you don't have it. Haven't had to do mine yet but others have and said it wasn't too difficult.
Attached Files
File Type: pdf Oasis Service Manual.pdf (947.4 KB, 35 views)
__________________
John and Mary Knight
2015 Newmar Ventana 4311 - wheelchair accessible
2015 Cadillac SRX Luxury AWD
Algoma is online now   Reply With Quote
Old 10-05-2016, 09:44 PM   #12
Senior Member
 
Join Date: Mar 2005
Location: Northern Oklahoma
Posts: 4,451
Quote:
Originally Posted by DocJim View Post
The system will also shut down if you are low on hydronic fluid. Our expansion tank is high on the passengers side of the engine bay at the rear of the coach.
We check the level regularly and always carry extra fluid with us.
Where do you find the fluid to purchase it? I keep a watch on our fluid level but not sure what I'd do if I find it low.
wagonmaster2 is offline   Reply With Quote
Old 10-06-2016, 07:04 AM   #13
Senior Member
 
Algoma's Avatar
 
Join Date: Nov 2007
Location: Charleston, WV
Posts: 3,222
Quote:
Originally Posted by wagonmaster2 View Post
Where do you find the fluid to purchase it? I keep a watch on our fluid level but not sure what I'd do if I find it low.
Transfer fluid
__________________
John and Mary Knight
2015 Newmar Ventana 4311 - wheelchair accessible
2015 Cadillac SRX Luxury AWD
Algoma is online now   Reply With Quote
Old 10-06-2016, 08:19 AM   #14
Member
 
Newmar Owners Club
Join Date: May 2015
Location: Mammoth Lakes, CA
Posts: 77
Thanks all for the links. This maybe above my pay grade and a trip to a Oasis service center will be necessary.
__________________

__________________
Joel, Janice and Jack
2015 Dutch Star 4018
2003 Toyota Tacoma 4x4 (flat towed)
jbrown000 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Aqua Hot Diesel Burner/2001 Dynasty jlshand Monaco Owner's Forum 2 12-27-2008 03:32 AM
CC re-call problem still on back burner Izzyblueye Class A Motorhome Discussions 6 12-03-2007 12:14 AM
help, stove top burner igniter not working JONCAR 5th Wheel Discussion 3 04-17-2007 11:48 AM
Oasis Diesel Burner on the fritz again... rebelsbeach Newmar Owner's Forum 4 03-04-2007 03:38 PM
Mod for Range Burner Ignition mm58 Toy Haulers Discussion 2 02-02-2007 09:44 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 03:28 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×