Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-04-2020, 03:25 PM   #1
Junior Member
 
Join Date: Sep 2017
Location: Mesquite
Posts: 18
Oasis Water Heater

I have a Oasis hot water heater. The inside panel show a "Red" light on the zone fault. Power is on, the AC 1/AC II is on. The water heater outside has hot water in the hose. I can't get hot water to the cabin. I have tried to reset the heater with no luck. I presently have the heater set to Bypass mode. After turn switches on and off I got hot water to come in to the cabin. One hour later, no hot water. Is there a fuse and were would it be? I have a 2016 Newmar diesel pusher. Any ideas?
Kampnfool is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-04-2020, 06:05 PM   #2
Senior Member
 
Bushy's Avatar
 
Newmar Owners Club
Join Date: Jul 2015
Location: Fargo, North Dakota
Posts: 420
I hope someone with more technical knowledge than I have weighs in on your issue. To me, it sounds like a summer loop pump failure in your Oasis unit. I believe it may have three pumps, one of which is called the summer loop and provides domestic hot water within your coach. Using the bypass switch is a good temporary workaround for this failure but you shouldn't leave it on for too long as it will overwork your Oasis if you do. Use it briefly when you really need hot water and then turn it back off. Use it that way in the short term until you can get a tech to look at it. Just my thoughts. I've lived through similar issues. Good luck.
__________________
RB - North Dakota
2016 VTDP 3709
dragging a 2018 Jeep Wrangler JK Sahara
Bushy is offline   Reply With Quote
Old 10-04-2020, 06:27 PM   #3
ptw
Senior Member
 
ptw's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: Apr 2016
Posts: 1,347
The fuses for the pumps are in the silver box on the upper right side. The box is clipped onto the bracket. It can be removed to look at the fuses. Remove the cover and the fuses are under the cover. The lights on the front of the cover will turn red when a fuse is blown, but only when that function is on.

Let us know what lights are on. Sorry the picture is rotated to the right.
Attached Thumbnails
Click image for larger version

Name:	IMG_4799.jpg
Views:	52
Size:	359.3 KB
ID:	303381  
__________________
Paul, Christy and Leap
2017 Dutch Star 4018, 2021 Jeep Wrangler
ptw is offline   Reply With Quote
Old 10-05-2020, 12:12 AM   #4
Senior Member
 
capnqball's Avatar


 
Join Date: Mar 2012
Location: NW OREGON
Posts: 466
The fuse is more than likely blown and that indicates a summer loop pump failure. Replace both and you'll likely be good. The replacement pumps are a new design as I've been told are hopefully more dependable/long lasting. Been there done that this past spring at the Vancouver WA Oasis shop.
__________________
Ron in NW Oregon
2017 Ventana 3436
2021 Chevrolet Spark LT
capnqball is offline   Reply With Quote
Old 10-05-2020, 08:16 AM   #5
Senior Member
 
alan1's Avatar
 
Monaco Owners Club
Newmar Owners Club
Join Date: Aug 2000
Location: little rock, ar
Posts: 456
If fuses are ok then as a temporary fix turn the bypass on. It is located on the top of the stainless box the fuses are located in.
__________________
2007 Mountain Aire,2014 Mountain Aire
2016 King Aire,2020 Newmar Essex
2017 Ford Explorer toad
alan1 is offline   Reply With Quote
Old 10-06-2020, 05:11 PM   #6
Senior Member
 
woodosgood's Avatar


 
Join Date: Aug 2015
Location: Depends on the weather
Posts: 601
Oasis problem

Have you performed the annual service? I've had the fault lights come on, and the annual service fixed the problem. There is a YouTube video showing how to do the service. I've done it twice myself with no problems.

Parts are about $105 if you replace the ignitor, less if you don't.



If you are having an issue with the electric elements, try the diesel burner option.
__________________
Eric and Linda
2016 Newmar Ventana 4369 (Full Timers since May 2016)
2011 Honda Element & 2015 Co-Motion Equator Tandem
woodosgood is online now   Reply With Quote
Old 10-06-2020, 10:59 PM   #7
Junior Member
 
Join Date: Sep 2017
Location: Mesquite
Posts: 18
Update, reached out to Oasis and they recommended I order a pump. It's on it's way. Thanks for the help guys.
Kampnfool is offline   Reply With Quote
Old 10-06-2020, 11:33 PM   #8
Junior Member
 
Join Date: May 2017
Posts: 12
Oasis

You will soon discover those pumps can be a 'joy" to change. there are hose type clamps (Smooth Locking Plier Type) to seal off the flow of transfer fluid or two sets of needle nose vise grips work ok. be careful not to damage the hoses, there was not much extra in mine to work with. The Techs will actually walk you through while on the phone with them the pump replacement. also you can find the yellow Century Transfer Fluid on amazon. do not mix any other brand or you will make mud. I lost a cup or two mainly trying not to damage the hoses with the vice grips(use a rag in the vice grip). Good luck it is not impossible to do, I managed!! Make sure it is cooled off. God bless
__________________
Mark & Dara
2017 Newmar Ventana 4310-Bunks-SOLD
2014 NEWMAR Ventana 4037
Markdc is offline   Reply With Quote
Old 10-07-2020, 08:54 AM   #9
Senior Member
 
C.Martin's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: Aug 2015
Posts: 3,142
ITR has a manual with a troubleshooting guide.

If following that guide does not resolve the issue...they have an excellent reputation for giving very helpful guidance over the phone. I have seen case after case of ITR helping RV’s sort out some pretty perplexing issues.
__________________
Charlie & Ronni
2016 Ventana 4037
C.Martin is offline   Reply With Quote
Old 11-09-2020, 10:01 AM   #10
Senior Member
 
walkerhound's Avatar
 
Outdoors RV Owners Club
Join Date: Jan 2018
Posts: 263
good thread. thank you for the tip on how to get temp hot water while I wait for my pump. I didn't know and it was a cold shower.

called ITR and they are sending me a new pump. Like others mentioned the summer loop pump light is read and the F8 fuse blows out as soon as I put a new one in. my 2nd pump in 18 months. Oddly the last one broke almost 1 year to the date.

in case anyone is interested the price sure varies (ITR - 225, Nearby Dealer - 336, Newmar - 650).
walkerhound is offline   Reply With Quote
Old 11-17-2020, 06:36 PM   #11
Senior Member
 
walkerhound's Avatar
 
Outdoors RV Owners Club
Join Date: Jan 2018
Posts: 263
the diagram in the troubleshooting manual and the paper that came with the new pump doesn't match the insides of my Oasis Chinook system. I sent a picture to ITR asking for clarity, but grew impatient and flipped a coin.

Do not be like me and swap out the wrong pump...

I thought oh... I must be replace the pump with the same model #, which is the pump along the side. No... turns out the summer loop pump is the pump you see at the bottom of the oasis unit.
Attached Thumbnails
Click image for larger version

Name:	oasis pumps.jpg
Views:	47
Size:	405.5 KB
ID:	308391  
walkerhound is offline   Reply With Quote
Old 11-17-2020, 07:53 PM   #12
Senior Member


 
Join Date: Sep 2016
Posts: 537
Order these to clamp your hoses.
https://www.amazon.com/Juvale-Pack-H...5664259&sr=8-8
No damage to hose and very little leakage.
I changed 4 pumps in the first 18 months of ownership. No problems the last 30 months,
Good luck
__________________
John & Deb
Full Time since 2016
2016 Dutch Star 4369
Webz is offline   Reply With Quote
Old 11-17-2020, 08:15 PM   #13
Senior Member
 
DrPhil's Avatar
 
Join Date: Oct 2014
Posts: 1,056
You aren't really in the Newmar club until you've been baptized by century heat transfer fluid while changing out a summer loop pump!
__________________
Phil and Laura (and Sam too!)
2017 DSDP 4369 on Spartan K2
2017 Unltd Rhino Rubi Recon Toad
DrPhil is offline   Reply With Quote
Old 05-09-2021, 02:49 PM   #14
Member
 
DBDTIMES2's Avatar
 
Newmar Owners Club
Spartan Chassis
Join Date: Nov 2012
Location: full timers
Posts: 87
Summer loop......

Thanks to IR-V once again. Fault light is on the Oasis controller..."zone fault".


The comment to access the silver box to the rt side of the Oasis, where the red LED beacon said "summer loop" i took the cover off and found the blown fuse, went to plug another 10a, then it instantly blew.


Will call and relay to factory what going on, and will do the replacement my self.



Have fun travels yall......just another full time RVing day in paradise.


Currently residing on Big Pine key Encore Park.....not like we need much hot water!!!!



__________________
Dave and Dayna-Adult children x 2-Classic Buicks x 2-
Only Grandchild lives in Denver CO.
DBDTIMES2 is offline   Reply With Quote
Reply

Tags
heat, heater, oasis, water, water heater



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OASIS hot water heater Buly Newmar Owner's Forum 26 01-05-2019 07:41 AM
oasis water heater Btheresoon Newmar Owner's Forum 7 10-29-2017 01:14 PM
Oasis Hydronic Heater-no hot water dukenrock RV Systems & Appliances 8 03-17-2015 08:17 PM
Oasis Water Heater Question jimfryar Newmar Owner's Forum 14 02-10-2014 06:26 PM
Oasis Water Heater Temperature Fix Radioman Newmar Owner's Forum 7 07-31-2008 05:05 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 08:42 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.