Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-23-2021, 10:19 PM   #1
Junior Member
 
Navarm's Avatar
 
Join Date: Sep 2021
Posts: 6
Outlets(3) will not work

Outlet behind the passenger seat will not work. I plugged a little heater into it and of course I am the cause. We have checked the breaker, we are still trying to find every fuse box in our 2001 Dutchstar and the ones we have found seem fine. Checked the bathroom and kitchen GFIs and they are fine. Everything works but the passenger seat outlet and two outlets in the slides. I have read the forums on the inverter to reset and such. With being green as could be with these things….I cannot or do not want to mess something up worse than I may have already. Would appreciate anyone who has had any experience and a cure for this. Thank you
Navarm is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-24-2021, 06:09 AM   #2
Senior Member
 
Join Date: Apr 2020
Location: Parris Island, SC
Posts: 331
Quote:
Originally Posted by Navarm View Post
Outlet behind the passenger seat will not work. I plugged a little heater into it and of course I am the cause. We have checked the breaker, we are still trying to find every fuse box in our 2001 Dutchstar and the ones we have found seem fine. Checked the bathroom and kitchen GFIs and they are fine. Everything works but the passenger seat outlet and two outlets in the slides. I have read the forums on the inverter to reset and such. With being green as could be with these things….I cannot or do not want to mess something up worse than I may have already. Would appreciate anyone who has had any experience and a cure for this. Thank you
Find your breakers. Check bedroom cabinets.
__________________
Fast E.

2000 Monaco Executive. 350 Cummins.
Fast E is offline   Reply With Quote
Old 10-24-2021, 06:14 AM   #3
Senior Member
 
Join Date: Jul 2014
Posts: 28,970
Find the inverter/charger, our near the batteries, and check the breakers on it.
twinboat is online now   Reply With Quote
Old 10-24-2021, 07:36 AM   #4
Member
 
ScotS's Avatar
 
Join Date: May 2018
Location: Katy, TX
Posts: 90
The outlets used on my Ventana are the very shallow type where the wires press in, they are not held by screws like a residential outlet. These can work loose and cause a single outlet to fail on a circuit.
__________________
Scot & Donna (Katy, TX)
2018 Newmar Ventana 3407 (Freightliner) All Electric
Towed: 2003 Jeep Wrangler Sahara or 2015 Ram 1500 EcoDiesel, depending on mood.
ScotS is offline   Reply With Quote
Old 10-30-2021, 08:37 PM   #5
Junior Member
 
Navarm's Avatar
 
Join Date: Sep 2021
Posts: 6
Thank you for the information on the loose connections in the outlets. My husband and I checked every breaker, fuse, I even crawled around in the basement and looked for some hidden fuse box or GFI. We replaced the two questionable outlets with residential ones that have a much more secure connection….problem solved! Thank you again for the help, josh and Judi
Navarm is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C and outlets work on shore power but generator only powers A/C and not outlets jaay101 RV Systems & Appliances 15 12-07-2020 10:00 AM
HELP! Kitchen outlets (DS) and Outlets/Lights (PS) Don't Work offtosleep Monaco Owner's Forum 23 01-02-2018 03:22 PM
dash air wont shift from defrost outlets to dash outlets drrussell Monaco Owner's Forum 3 08-21-2016 04:30 PM
Not all outlets work on shore power! jerztime Winnebago Industries Owner's Forum 30 05-17-2015 09:21 PM
RV outlets work on generator, but not shore power vegasdingo Class A Motorhome Discussions 12 02-20-2014 02:16 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 05:21 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.