RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-21-2020, 12:08 PM   #1
Senior Member
 
Boilervol's Avatar


 
Newmar Owners Club
Spartan Chassis
Join Date: Aug 2018
Location: Knoxville, TN
Posts: 243
Power control monitor issue

I went to check on the coach today and found an issue with the Precision Circuits monitor panel. The coach is stored inside and plugged into 30 amp. The panel showed no shore power but the Magnum panel showed everything OK. The inverter was working and batteries were fully charged. I disconnected shore power and reconnected and got the same issue. There is 120v in the coach as I was able to run the hvac. I started the gen and it registered correctly on the power monitor. The line status showed the correct amps being used but showed the line status L1/L2 as 4v/8v (this was with shore or gen). The AC screen showed 0 amps even with the front AC on. The incoming power showed 120v each leg.

Anybody have any idea where I should look.
__________________
Bill & Mary
2019 Newmar DS 4369
Spartan K2 AF-1
2019 Jeep Cherokee Overland
Boilervol is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-21-2020, 12:29 PM   #2
Senior Member
 
Join Date: Jul 2014
Posts: 24,795
Did you happen to switch off any circuit breaker while stored ?

The device may use them for powering it.
twinboat is offline   Reply With Quote
Old 10-21-2020, 12:39 PM   #3
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 30,478
At the top of forum page you will find a search of irv2 forums, here is a search of your problem that may help you out until someone may have a better answer.
Not sure you may find answer here also.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 10-21-2020, 01:23 PM   #4
Senior Member
 
Boilervol's Avatar


 
Newmar Owners Club
Spartan Chassis
Join Date: Aug 2018
Location: Knoxville, TN
Posts: 243
Thanks for the input. I read some of the prior posts and it could be a breaker I turned off. Tomorrow Iíll run back over and check the breakers . I turn several off when in storage and might have hit an extra one this time. Sure hope itís this simple to correct.
__________________
Bill & Mary
2019 Newmar DS 4369
Spartan K2 AF-1
2019 Jeep Cherokee Overland
Boilervol is offline   Reply With Quote
Old 10-21-2020, 02:46 PM   #5
Senior Member
 
Newmar Owners Club
Spartan Chassis
Join Date: Oct 2014
Location: Lake McClure, CA
Posts: 1,183
twinboat is correct. There is a breaker that powers it along with one of the load shed items.
__________________
2018 Dutch Star 4369 Spartan Chassis
2016 Jeep Cherokee, 1952 Willys CJ3A
10 fan is online now   Reply With Quote
Old 10-22-2020, 11:02 AM   #6
Senior Member
 
Boilervol's Avatar


 
Newmar Owners Club
Spartan Chassis
Join Date: Aug 2018
Location: Knoxville, TN
Posts: 243
Well, I learned something. One leg was on one of the oasis breakers and the other on the engine block heater.

Thanks again - twin boat, 007, and 10 fan

This board is the best $15 I spend a year
__________________
Bill & Mary
2019 Newmar DS 4369
Spartan K2 AF-1
2019 Jeep Cherokee Overland
Boilervol is offline   Reply With Quote
Reply

Tags
monitor, power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Awning Power Control Awning Power Control Bruce Tuxhor Monaco Owner's Forum 4 09-26-2020 09:47 PM
Power Control System Monitor Panel Replacement? F29DCB Fleetwood Owner's Forum 0 09-23-2015 01:21 AM
Power Control System Central Monitor Panel dark display DennisJM Tiffin Owner's Forum 0 09-17-2015 09:31 PM
Power Control Monitor Says 120V/5 V Shore Power pagosajoe Fleetwood Owner's Forum 6 08-21-2013 05:03 PM
Cruise Control/Wiper Control/Bright Light Control cnjcampione Winnebago Industries Owner's Forum 2 05-21-2011 08:38 PM


All times are GMT -6. The time now is 12:32 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.