RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 02-19-2015, 08:26 AM   #1
Senior Member
 
Bruce H's Avatar
 
Join Date: Mar 2007
Location: Kingman AZ
Posts: 203
Reduced Engine Power

On my way home from a trip to California the motor home all of a sudden seemed like I turned off the key and it would not accelerate, but would idle. In the information center it said Reduced Engine Power. I let it set for 30 minutes and it ran for about a mile. I did have to be towed home and is now in the shop. I have read that sometimes sensors in the heat or oil areas can malfunction. To be clear the engine did not heat up nor was there any loss of oil pressure. All maintenance has been performed by a Workhorse authorized shop. The MH is a gas 2003 Scottsdale by Newmar with 80,000 miles. Never had an engine problem. Can the sensors be replaced just to be safe? Any info on this problem will be appreciated.Bruce H.
__________________

__________________
2004 Newmar/Scottsdale, W22, Toad/2000 Jeep Cherokee Classic 4X4 Auto Trans, US Gear Brake System, Blue OX Tow Bar, Garmin 1450 MT GPS. RVing Since 1989. Life Is Good!!!
Bruce H is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-19-2015, 09:32 AM   #2
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 30,196
Where you traveling through a rain storm?
__________________

__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 02-19-2015, 09:41 AM   #3
Senior Member
 
PDR John's Avatar
 
Join Date: May 2012
Posts: 3,645
The only problem is which sensor, my guess (and only a guess) would be mass air flow.

They should be able to tell which went bad when they hook up to their computer.
__________________
2013 DSDP 4347, all electric, 450 H.P. ISL
Air & hydraulic leveling
14 Jeep Grand Cherokee Overland toad
[SIGPIC][/SIGPIC]
PDR John is offline   Reply With Quote
Old 02-19-2015, 10:25 AM   #4
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 30,196
The reason I asked about the rain is because of this problem with that year GAS NEWMARS.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 02-19-2015, 01:02 PM   #5
Senior Member
 
Bruce H's Avatar
 
Join Date: Mar 2007
Location: Kingman AZ
Posts: 203
No 007 it was not raining. I did have that problem when I first got the MH and I put a gasket or a rubber type molding around the hood openings because the rain was coming down the windshield wiper then into the hood and down the tuba intake. Tnaks for the inout anyway.
__________________
2004 Newmar/Scottsdale, W22, Toad/2000 Jeep Cherokee Classic 4X4 Auto Trans, US Gear Brake System, Blue OX Tow Bar, Garmin 1450 MT GPS. RVing Since 1989. Life Is Good!!!
Bruce H is offline   Reply With Quote
Old 02-21-2015, 07:51 AM   #6
Senior Member
 
Bruce H's Avatar
 
Join Date: Mar 2007
Location: Kingman AZ
Posts: 203
Turns out the mechanic says it was the throttle body. Common to GM. Total cost $650. Happy camper now!
__________________
2004 Newmar/Scottsdale, W22, Toad/2000 Jeep Cherokee Classic 4X4 Auto Trans, US Gear Brake System, Blue OX Tow Bar, Garmin 1450 MT GPS. RVing Since 1989. Life Is Good!!!
Bruce H is offline   Reply With Quote
Old 02-21-2015, 12:17 PM   #7
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 30,196
Thanks for the follow up Bruce many continued safe travels.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 02-21-2015, 01:32 PM   #8
Senior Member
 
PDR John's Avatar
 
Join Date: May 2012
Posts: 3,645
Glad you found the problem.

Thanks for following up.
__________________

__________________
2013 DSDP 4347, all electric, 450 H.P. ISL
Air & hydraulic leveling
14 Jeep Grand Cherokee Overland toad
[SIGPIC][/SIGPIC]
PDR John is offline   Reply With Quote
Reply

Tags
power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
'96 Flair(22') is it shore power supposed to charge the engine battery? Motor7 Fleetwood Owner's Forum 12 01-11-2015 06:17 PM
Can I wire my Intelli Power 9000 to also charge my engine battery? Motor7 Class A Motorhome Discussions 10 01-01-2015 11:21 AM
No power to anything without engine running deepfish Class A Motorhome Discussions 2 07-17-2014 06:04 AM
The Doggone Yellow Check Engine Light (C.E.L.) troth Winnebago Industries Owner's Forum 1 05-06-2014 09:05 AM
Low engine power - Ignition reset? NavlAv8r Workhorse and Chevrolet Chassis Motorhome Forum 10 01-12-2014 02:21 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 02:08 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×