Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-29-2014, 10:30 AM   #1
Junior Member
 
Join Date: Apr 2014
Posts: 4
Starting & battery disconnect problems

Went out for my monthly start-up of my 1996 Kountry Star 35' driveway ornament and just heard a click, like a relay, not a starter sound. Cleaned all battery connections and charged all batteries, same thing. Chassis battery was four years old, so I went and got a new one, same thing. I then tried the battery disconnect switch and it does not light up either way that I rock it.

Could a bad Intellitec disconnect solenoid be causing both problems?
tarheel24 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-29-2014, 10:45 AM   #2
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 30,765
Welcome to the forum & irv2.
Here is a Brochure and 1997 Owners Guide. Oldest we have.
It could be or bad connection some place to the chassis frame for ground cables.
Check the chassis battery ground cable to frame and starter to ground.
Check out the links below with other related stuff to your Newmar.

INTELLITEC CONTROLS
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Reply

Tags
battery, battery disconnect



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting & battery disconnect problems tarheel24 Class A Motorhome Discussions 2 04-28-2014 02:56 PM
Battery Disconnect - Does not work redbaron73 Newmar Owner's Forum 6 02-23-2014 11:27 AM
73' Sportscoach Dual Battery Isolator Problem crosby716 Vintage RV's 7 01-30-2014 01:26 PM
Battery Disconnect boogerman iRV2.com General Discussion 5 01-10-2014 09:24 PM
battery disconnect relay trouble DawnAndChris RV Systems & Appliances 40 10-04-2013 04:51 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 10:58 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.