RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-20-2017, 12:00 PM   #1
Senior Member
 
fsudelt's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: Aug 2016
Location: Forest City, FL
Posts: 770
Toilet not flushing

We have a 2017 Dutch Star & just got back from a weekend trip. We went to flush once home to put some chemicals in and out front toilet is not flushing. When you hit button it just starts to fill with water but does not try to empty at all. Any ideas??

Thanks!
__________________

__________________
Brian
2017 Dutch Star 4310 (bunks)
2018 Ford Explorer Platinum
Previous: 2010 Tiffin Allegro Red 38QBA
fsudelt is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-20-2017, 01:40 PM   #2
Senior Member


 
Join Date: Sep 2016
Posts: 408
flush

Are you hooked up to shore power? I had a similar problem and I called Dometic. They said it sounded like a voltage problem. Good luck
__________________

__________________
John & Deb
Full Time since 2016
2016 Dutch Star 4369
Webz is offline   Reply With Quote
Old 08-20-2017, 03:00 PM   #3
Senior Member
 
fsudelt's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: Aug 2016
Location: Forest City, FL
Posts: 770
Tried it on both generator & 50amp hookup at our house. I have to bring it by our dealer this week to get a breaker changed out so I'll have them look at it. Was just curious if anybody else has had this issue, our other toilet in our coach is working perfectly fine
__________________
Brian
2017 Dutch Star 4310 (bunks)
2018 Ford Explorer Platinum
Previous: 2010 Tiffin Allegro Red 38QBA
fsudelt is offline   Reply With Quote
Reply

Tags
toilet



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with Aria Deluxe II toilet flushing problems sonnyj Monaco Owner's Forum 19 02-02-2016 08:31 AM
Smelly bubbles coming up when flushing 5th wheel toilet dkperez 5th Wheel Discussion 22 08-01-2014 08:04 PM
Toilet flushing with hot water TandI Travel RV Systems & Appliances 5 07-03-2014 05:49 PM
Toilet flushing - poltergeist???? djohn MH-General Discussions & Problems 8 02-20-2009 04:52 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 05:06 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×