RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-30-2012, 04:01 PM   #1
Member
 
Join Date: Apr 2010
Posts: 63
Trouble switching from ac/vent/heater

I have a 2005 Mountain Aire 4304, Spartan chassis.

On the dash controls for the ac/heater/vent, etc, when I go from one to another I have to open up the front hood and tap on the control motor to get it to switch to work.

There seems to be a electric motor that switches the functions.

Has anyone else had a problem like this? Is there a way to fix it or do I need a complete new one?
__________________

__________________
2005 Mountain Aire 4304
jayhawk1 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-30-2012, 07:49 PM   #2
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 30,118
Here is some information on the Evans system you have I would check ground wire locations and the vacume lines for controls.
Evans website info.
__________________

__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 03-31-2012, 05:21 AM   #3
Senior Member
 
mikelm48's Avatar
 
Newmar Owners Club
Spartan Chassis
Join Date: Nov 2010
Location: Grapevine, TX
Posts: 1,026
I had a similar problem. I couldn't swith over to A/C. I had the Electronic Coolant Valve replaced and it is working fine now. You can get the part number (depending on your year and A/C control type) from the Evans Tempcon site that "007" posted and then search for it on the internet. I bought it online from a dealer. I think it was around $180.
__________________
Mike
2005 Kountry Star 3907, ISC330, Spartan chassis, M&G braking, Blue Ox Aventa XL
mikelm48 is offline   Reply With Quote
Old 04-01-2012, 07:24 PM   #4
Senior Member
 
rvjimmy's Avatar
 
Monaco Owners Club
Join Date: Mar 2011
Location: Almond, Wisconsin
Posts: 1,472
Had trouble with mine, changed vacuum pump and problem solved.
__________________
2006 Monaco Camelot 40 PAQ 400ISL - Toad Jeep Grand Cherokee - DW is the Nagivator. Retired to travel and everything revolves around the price of diesel.
rvjimmy is offline   Reply With Quote
Old 04-03-2012, 09:41 AM   #5
Member
 
Join Date: Apr 2010
Posts: 63
My problem seems to be more electrical. There is two wires going into the box. When you select going from heater to AC for example you can hear a small motor within the box come on to switch the function. I have to now tap on the box to get it to switch.
I am going to un-plug the two wires and check the terminals for corrosion. If that don't work I would guess the small electric motor is going bad. Probably need a complete new box.
__________________
2005 Mountain Aire 4304
jayhawk1 is offline   Reply With Quote
Old 04-03-2012, 10:07 AM   #6
Junior Member
 
Jim01's Avatar
 
Join Date: Oct 2011
Location: Full Time
Posts: 26
Thanks so much for posting the link to the Evans site. I've been trying to figure out the heater/ac controls on our unit since we bought it last June.

Jim
__________________

__________________
Jim01
Full Time since 2001
2006 BT Cruiser 5272
Jim01 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
AC Compressor not coming on Oakley RV Systems & Appliances 7 04-05-2012 06:28 AM
New Guy from Joint Base Lewis McChord Cilrah New Member Check-In 25 04-05-2012 02:00 AM
Duotherm (dometic) ac noise fan vibration sciguy6 RV Systems & Appliances 4 03-31-2012 09:41 AM
Lessons learned from purchase experience DHart Class A Motorhome Discussions 10 03-30-2012 05:06 PM
From a police officer dash camera 1ciderdog Just Conversation 38 03-30-2012 08:21 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 12:56 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×