Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-22-2009, 05:54 PM   #1
Senior Member
 
stubeje's Avatar
 
Workhorse Chassis Owner
Join Date: Oct 2007
Posts: 152
WFCO 600TH Inverter

I think Newmar uses this inverter on a lot of their gas coaches and am wondering if anyone has had problems with this model. Since I purchased my KS 2005 new class A I have had (2) of these units fail...work one day...dead the next. This 600watt inverter works all of the electronics ie. tv,video,sat,etc. First one lasted 2 months...last one 4 years. No overload conditions or blown fuses...any comments will be welcomed and if replaced what unit did you get.
__________________
Newmar Kountry Star 2005 37'

8.1 Workhorse w/UltraPower,Taylor 409 plug wires,AC Delco 41-993 Plugs and OEM Engineering Fuel Filter Adaper
stubeje is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-23-2009, 10:12 PM   #2
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 30,699
My unit has been in use for 6 years never had a problem other than the GFI button popping at times when hooking up to different shore powers. Since installing a Surge Protector doesn't happen.
We have been using it for my wife's 110v oxygen generator while traveling this summer without problems.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 10-24-2009, 04:02 PM   #3
Senior Member
 
stubeje's Avatar
 
Workhorse Chassis Owner
Join Date: Oct 2007
Posts: 152
Thanks 007...we were powering the laptop on a trip to upper New York this month when the inverter just quit...no warning, nothing. Will probably order another WFCO 600TH...mine is the hard wired model.
__________________
Newmar Kountry Star 2005 37'

8.1 Workhorse w/UltraPower,Taylor 409 plug wires,AC Delco 41-993 Plugs and OEM Engineering Fuel Filter Adaper
stubeje is offline   Reply With Quote
Old 10-24-2009, 05:00 PM   #4
Senior Member
 
GaryKD's Avatar
 
Newmar Owners Club
Join Date: Jul 2006
Location: Wellington, Florida
Posts: 13,599
Hi stubeje,
Consider checking your batteries. Strange things happen when the coach batts are no performing.

1. water level
2. hydrometer check of each cell
3. if fully charged (12.6 VDC), disconnected from the coach, will they stay fully charged for one week (12.6 VDC)?
__________________
Gary
2005 Newmar KSDP 3910 + GMC ENVOY XUV 37K lbs Moving Down The Road
The Avatar Is Many Times Around The USA
Nobody Knows Your Coach Like Somebody Who Owns One Just Like Yours
GaryKD is offline   Reply With Quote
Old 10-24-2009, 06:05 PM   #5
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 30,699
Check out your alternator while coach is on the road it should be charging your batteries. May have a faulty solenoid.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Inverter Conversion MonacoMama Monaco Owner's Forum 5 10-16-2009 11:26 PM
RS 2000 new inverter/ solenoid Ed & Diane Alpine Coach Owner's Forum 6 03-25-2009 09:56 PM
inverter suggestions? JRock1014 Damon 4 03-10-2009 11:51 AM
Added 3-way plug to inverter. AKBrick Winnebago Industries Owner's Forum 3 08-25-2007 11:00 AM
Winnie Inverter Location? Blaine Winnebago Industries Owner's Forum 2 04-06-2005 01:10 PM


All times are GMT -6. The time now is 05:59 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.