Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Alpine Coach Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 12-26-2020, 06:43 PM   #15
Senior Member
 
Rusty Bear's Avatar
 
Alpine Owners Club
Join Date: Nov 2003
Location: Big Bear, Ca
Posts: 375
Quote:
Originally Posted by dennismhamm View Post
yes. fuel tank is full also just changed the oil fuel filter and air filter
Could be new fuel filter defective.
__________________
Jim & Vivian
2007 Alpine Apex
40FT FDFS #75725
Rusty Bear is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-27-2020, 06:04 AM   #16
Registered User
 
Join Date: Nov 2005
Posts: 6,749
…...defective fuel filter???????--probably not.....need to keep looking.
Old Scout is offline   Reply With Quote
Old 12-27-2020, 06:22 AM   #17
Senior Member
 
dennismhamm's Avatar
 
Alpine Owners Club
Join Date: Sep 2014
Location: FLORAL CITY,FL
Posts: 578
Blog Entries: 1
new fuel filter after it started it. still looking. at my sons now he's checking it out. we have checked all connections re tighten every connection and still no luck
__________________
Dennis & Brenda
2006 Alpine Coach 40Fd Limited
2020 Ram 2500 Heavy Duty Diesel
dennismhamm is offline   Reply With Quote
Old 12-27-2020, 06:31 AM   #18
Senior Member
 
Jeep401's Avatar
 
Join Date: Nov 2017
Location: Marysville, WA
Posts: 455
Did you happen to clear the codes and start over to see if it's still the same?

Mine did this the other day after running under load for about five minutes but clears it self up after restarting a few time.

I still need to go back and look at and clear codes. I didn't find out that I pulled them wrong until after I had come back in the house for the day and it was running fine.
__________________
Angelo & Leslie
2005 Alpine 36FDDS #75268
MARYSVILLE, WA.
Jeep401 is offline   Reply With Quote
Old 12-27-2020, 06:32 AM   #19
Senior Member
 
dennismhamm's Avatar
 
Alpine Owners Club
Join Date: Sep 2014
Location: FLORAL CITY,FL
Posts: 578
Blog Entries: 1
not to sure how to clear codes?
__________________
Dennis & Brenda
2006 Alpine Coach 40Fd Limited
2020 Ram 2500 Heavy Duty Diesel
dennismhamm is offline   Reply With Quote
Old 12-27-2020, 06:39 AM   #20
Senior Member
 
Bsipe01's Avatar
 
Tiffin Owners Club
Join Date: Oct 2019
Location: Southeast
Posts: 105
I've experienced problems when the tank goes between 1/2 & 1/4 & the genset shuts down. Have you re-primed thoroughly? If the engine kicks off but runs really rough & shuts down, it's probably fuel related. Since you mention filter in your post, and you're describing what sounds like fuel starving, I'd focus on priming thoroughly. AFAIK, the control module will time out if you prime it too long (I believe 3 mins), but other than that, there shouldn't be an issue. Time it, 3 minutes is a LONG time. No fuel, no joy. Good luck!
Bsipe01 is offline   Reply With Quote
Old 12-27-2020, 06:52 AM   #21
Senior Member
 
Jeep401's Avatar
 
Join Date: Nov 2017
Location: Marysville, WA
Posts: 455
Quote:
Originally Posted by dennismhamm View Post
not to sure how to clear codes?
Well I can't figure out how to give you a link to the PDF, sorry.
If you Google " Onan QD 7500 codes" a ton of info will come up including a PDF of the manual.
__________________
Angelo & Leslie
2005 Alpine 36FDDS #75268
MARYSVILLE, WA.
Jeep401 is offline   Reply With Quote
Old 12-27-2020, 06:56 AM   #22
Senior Member
 
Jeep401's Avatar
 
Join Date: Nov 2017
Location: Marysville, WA
Posts: 455
Quote:
Originally Posted by Bsipe01 View Post
I've experienced problems when the tank goes between 1/2 & 1/4 & the genset shuts down. Have you re-primed thoroughly? If the engine kicks off but runs really rough & shuts down, it's probably fuel related. Since you mention filter in your post, and you're describing what sounds like fuel starving, I'd focus on priming thoroughly. AFAIK, the control module will time out if you prime it too long (I believe 3 mins), but other than that, there shouldn't be an issue. Time it, 3 minutes is a LONG time. No fuel, no joy. Good luck!
I felt mine was fuel related also. I could hear the pump prime so I figured the filter is getting plugged or had a air pocket.
__________________
Angelo & Leslie
2005 Alpine 36FDDS #75268
MARYSVILLE, WA.
Jeep401 is offline   Reply With Quote
Old 12-27-2020, 12:20 PM   #23
Senior Member
 
Jeep401's Avatar
 
Join Date: Nov 2017
Location: Marysville, WA
Posts: 455
Quote:
Originally Posted by dennismhamm View Post
not to sure how to clear codes?
If there are no lights flashing on your manual switch push it to prime 3 times within 5 seconds this will get it flashing if there are any codes.
Count the flashes, in my case it was three.
This only told me I had codes when I looked it up.
Now press the prime again 1 time, this should give you a set of flashes that you need to count. A number of flashes then a pause and a second number of flashes.
This will be your code to look up and start to troubleshoot.
Press the prime 2 times to clear the codes and attempt to run the generator again and see what codes if any come back up.
Clear as mud right..
Just remember 3,1,2
3 times to wake it up.
1 time to get code.
2 times to clear.
Hopefully this will give you a new starting point and also make sure you are not trying to troubleshoot for a random old code.

Hope this get you going in the right direction.
__________________
Angelo & Leslie
2005 Alpine 36FDDS #75268
MARYSVILLE, WA.
Jeep401 is offline   Reply With Quote
Old 12-27-2020, 12:32 PM   #24
Registered User
 
Join Date: May 2013
Location: S. California
Posts: 1,076
Quote:
Originally Posted by dennismhamm View Post
Gen 7500 diesel will fire up and run for about 5 seconds then shuts down. I have changed the temp sensor but did not help at all. If anyone has any info your help will be most appreciated. Thank you in advance.
Had a very similar issue with my 7500 QD with I believe the same code. My issue was, it would run 5 mins then shut down. All the basics were fine such as oil, coolant level etc. Someone here mentioned that in the aviation business, they disconnect power to a plane to clear codes. He suggested I do the same, and it actually worked for me. What I did was: disconnect both power cables underneath from the generator for 30 mins. While disconnected I wire brushed both cable ends and the mounting studs they go to. They usually have a bit of corrosion there. Then, connect them back up. Hold the generator button down for 60 seconds. After 60 seconds, start generator. Honestly, this worked for my issue. Might be worth a shot on yours, unless you already had these disconnected to replace your sensor.
Mile Marker 42 is offline   Reply With Quote
Old 12-27-2020, 03:26 PM   #25
Registered User
 
Join Date: Nov 2005
Posts: 6,749
….you can also hold down the on/off switch on the genset [not the cabinet or dash] in the off position to manually prime the pump/engine.....while running, the pump sound should change pitch when a good prime has been achieved....
Old Scout is offline   Reply With Quote
Old 12-27-2020, 03:59 PM   #26
Senior Member
 
Join Date: Oct 2014
Posts: 3,309
Quote:
Originally Posted by Old Scout View Post
the pump sound should change pitch when a good prime has been achieved....

Yup, fuel pump speed/RPM higher pumping AIR. Once it pumps fuel, it will slow down/RPM will be lower.
__________________
Brett Wolfe
Ex: 2003 Alpine 38FDDS. Ex: 1997 Safari Sahara. Ex: 1993 Foretravel U240
wolfe10 is offline   Reply With Quote
Old 12-27-2020, 11:19 PM   #27
Senior Member
 
DrDaveMA's Avatar
 
Alpine Owners Club
Join Date: Jun 2007
Location: Lake Wales, FL
Posts: 3,026
Since you stated you just changed the fuel and air filters the first thing I would do is park my finger on the stop side of the start/stop switch for AT LEAST 3 minutes, while doing that listen to the fuel pump to see if the sound changes. This will prime the fuel system (in other words fill the new fuel filter). If that does not get it started read the error codes.
__________________
Dave, Bobbi and Fenway
2005 38' FDTS Alpine Limited, 2016 Jeep Grand Cherokee Limited
Lake Wales, FL
DrDaveMA is offline   Reply With Quote
Old 12-27-2020, 11:45 PM   #28
Junior Member
 
Join Date: Nov 2020
Posts: 1
Generator won't stay running

I had a similar problem run for 2 mins and stop ? It was fuel pump worn out ! Disconnect hose to carb and prime with switch and check flow! Hope that helps?
Coach nut is offline   Reply With Quote
Reply

Tags
generator



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Generator will not stay running scott 61 Monaco Owner's Forum 15 04-25-2020 07:57 PM
RV Onan 5500 QG generator will not stay running DAPeters iRV2.com General Discussion 20 10-13-2019 08:16 PM
2004 Onan 7.5 diesel generator will not stay running. npak National RV Owner's Forum 1 08-31-2017 07:16 AM
onan generator starts but will not stay running tyreman3726 RV Systems & Appliances 4 07-17-2012 03:21 PM
Generator will not stay running while driving Blackhillian Country Coach Owners Forum 8 10-21-2009 07:53 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 08:56 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.