Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Alpine Coach Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-25-2021, 11:29 AM   #1
Junior Member
 
Alpine Owners Club
Join Date: Feb 2021
Posts: 1
Inverter/Battery Charging Issues

Our 2009 Alpine Coach 34FDDS features a Xantrex RS2000 Inverter and Control Panel.

Inverter control panel turns off when disconnected from shore power or generator. Batteries also not charging when connected to shore power or when our generator is turned on. Fortunately our roof mounted solar panels are keeping our house batteries fully charged when we have a full day of clear skies.

We recently had our generator on, but when we turned off generator, the control panel starting beeping, the yellow light on panel came on, and panel read "low battery voltage, recharge batteries". Than the control panel turned off and quit working.

When we restarted the generator, it must have reset inverter as control panel turned on again. Same reset happens when we are plugged into shore power. Bottom line is...control panel turns off when coach is not on shore or generator power. And the only charging my house batteries are receiving is from our solar panels.

Has anyone had this issue overtime with their inverter? Our warranty will cover repair or replacement, but if there is an alternative fix, any advise would be welcomed.
BlaNics is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-25-2021, 04:28 PM   #2
Senior Member
 
Join Date: Jul 2014
Posts: 27,461
Dead batteries or dirty connections.
twinboat is online now   Reply With Quote
Old 02-25-2021, 04:47 PM   #3
Senior Member
 
Kiss4aFrog's Avatar
 
Join Date: Aug 2012
Location: WI 54016
Posts: 293
Welcome to iRV2 BlaNics

I came across an owners manual but it didn't have anything for troubleshooting. It does sound like it either has a bad connection at or between the batteries and control panel or the panel is bad.

Maybe try contacting them direct: https://www.xantrex.com/


.
__________________
2007 Fleetwood Providence 39V
Allison 3000MH 7.5 Onan
Kiss4aFrog is offline   Reply With Quote
Old 02-25-2021, 05:33 PM   #4
Junior Member
 
Alpine Owners Club
Join Date: Feb 2021
Posts: 1
BTW...our batteries are brand new AGM with new connectors. My solar control panels show 13.7 volts at 5:00 pm each day.
BlaNics is offline   Reply With Quote
Old 02-26-2021, 12:04 AM   #5
Senior Member
 
Join Date: Jul 2014
Posts: 27,461
Inverter/charger fuse bad. Look in inverter positive cable, near batteries.
twinboat is online now   Reply With Quote
Old 02-27-2021, 11:21 PM   #6
Senior Member
 
Cinequip's Avatar
 
Alpine Owners Club
Join Date: Apr 2009
Posts: 224
Check for good DC voltage at the inverter. Sounds like the inverter has a bad connection to the house batts. I recently found an inverter with the bolt on the positive cable somewhat loose. It had been overheating and discolored the bolt and copper pad. If it is a bad connection, after correcting, hold the red reset button on top of the RS2000 until the LED's go out. This forces a full reboot.
__________________
Scott & Marcia Hicks
2009 Alpine 40' FDQS 425 ISL
Portland, OR
Cinequip is offline   Reply With Quote
Reply

Tags
battery, charging, inverter



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Inverter 2015 Winnebago tour Inverter issues BRP Winnebago International Travelers Club (WIT) 2 01-19-2021 10:33 AM
Inverter/Charging issues dfuelman Country Coach Owners Forum 20 09-21-2020 05:17 PM
Inverter help/ new batteries charging issues. M725611 Country Coach Owners Forum 12 02-07-2020 08:55 AM


All times are GMT -6. The time now is 10:27 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.