Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > National RV Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-31-2014, 11:46 PM   #1
Junior Member
 
Join Date: Jan 2014
Posts: 3
1999 Sea View - Fuses? Back Up Camera? Radio?

On my last trip the radio would not turn on when I started my journey home. It worked great on the way there but it had no power on the way home.

And then about half hour away from home on a 4 hour journey the back up camera lost power.

When I look at the plug to the back up camera it looks burnt.

QUESTION:

were are the fuses to the Radio and Back up camera.

Any help is greatly appreciated since I am HORRIBLE with electrical, but hey I have a test light
Krawling is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-01-2014, 02:05 PM   #2
Senior Member
 
Join Date: Jan 2010
Location: indiana
Posts: 184
Quote:
Originally Posted by Krawling View Post
On my last trip the radio would not turn on when I started my journey home. It worked great on the way there but it had no power on the way home.

And then about half hour away from home on a 4 hour journey the back up camera lost power.

When I look at the plug to the back up camera it looks burnt.

QUESTION:

were are the fuses to the Radio and Back up camera.

Any help is greatly appreciated since I am HORRIBLE with electrical, but hey I have a test light

I have a 2000 model of this same rv---i'll try to help.
as for the radio---be sure switch on dashboard is turned on, also this radio is powered by house batteries, be sure switch by entry door is turned on--red light should be glowing. if neither idea cures the problem, i'm not sure were the fuse is located, it's still very cold outside & i dont want to check, maybe someone else can answer it for you.

as for the back-up camera---i've had the same problem. on the burnt plug, use a very small piece (about pencil point size) of aluminum foil (reynolds wrap or chewing gum foil wrapper will do) just to make tighter fit. be sure foil fits down in plug & not touching any other prongs---may short out causing more problems. i've used this remedy for years with no problems. my guess is road vibrations over the years have caused electrical arcing on this prong.

this works on voyager brand camera which i think you have.

good luck and welcome to this forum
two slides is offline   Reply With Quote
Old 02-07-2014, 12:19 PM   #3
Senior Member
 
CarlAda's Avatar
 
Country Coach Owners Club
Join Date: Jan 2014
Location: Medford, OR
Posts: 744
Regarding the fuse for the radio: On my 95 Tropical, the fuse is located in the house fuse box. Mine is labeled on the panel, but if I recall correctly, it was #7 or 8.
CarlAda is offline   Reply With Quote
Old 02-10-2014, 05:14 PM   #4
Member
 
Fleetwood Owners Club
Join Date: Apr 2013
Location: Fort Collins, CO
Posts: 44
99 Seaview Radio

We also have a 99 Seaview - owned less than a year. Our radio quits working occasionally, but seems to come back. My guess is that I have a loose connection, but haven't looked or found it yet. It's currently working.

We've had trouble with our backup camera in wet weather. For instance, it would cycle on-off with the turn signal. But it's fine when things dry out.
TBorstad is offline   Reply With Quote
Reply

Tags
camera, fuse, radio



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
In dash Radio Died Dmorgan6375 National RV Owner's Forum 22 08-18-2014 10:30 PM
Converter fuses blown vapor3000 Winnebago Industries Owner's Forum 30 03-23-2014 05:05 PM
Power to rear camera - upgraded system 04Beast Newmar Owner's Forum 10 01-28-2014 06:07 PM
Back up camera greg-1 Technology: Internet, TV, Satellite, Cell Phones, etc. 3 12-23-2013 07:19 PM
Bounder: Rear Camera and monitor BarryN514 Fleetwood Owner's Forum 11 11-05-2013 08:44 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 09:35 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.