Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > National RV Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-26-2021, 12:02 AM   #1
Junior Member
 
Join Date: Nov 2019
Posts: 12
2000 Tradewind 7373 Inverter/Charger red flashing lights

When we started the engine to the MH, I heard a loud sound like touching 2 energized battery cables together just louder about where the Xantrex 458 Inverter/Charger was located. We didn't see any smoke and coach batteries appeared OK. We went on a weekend trip and found out the microwave and bathroom GFCI wouldn't work. Reset the GFCI but still not working. Also noticed the heart interface display inside the coach under BATTERY STATE never got to green when the generator was running like it usually does and the AC IN light was in between red and green, the FAULT was red as well as OVERTEMP. DC volts were 13. Also reset all the breakers. When we got home, I noticed a fan sound coming from the inverter/charger area. Opened the bay and the Xantrex Freedom 458 Inverter/Charger had 2 red lights flashing: OVERTEMP OVERLOAD/AGM and LOW BATTERY/GEL 2 and the fan was running. Started pushing buttons near top left, looking at inverter, trying to stop inverter but none stopped it so loosened a battery cable slightly then retightened and red lights stopped flashing. The batteries didn't appear to have any acid leaks and were not warm at this time. Hooked up to shore power and lights were still out. This morning same as last night, the fan was running and same 2 flashing red lights. So this time removed a battery cable that joined 2 of the 4 6V golf batteries and now the charge button on inverter/charger flashes green whenever I hear a click. Fact: the Xantrex Freedom 458 Inverter/Charger was replaced in July 2018 new and 4 new 6V golf batteries around July 2021 and the temp sensor is located near the wall of the battery bay. Checked batteries for fluid about a month ago. I am assuming this has something to do with a battery/batteries gone bad but I would like to hear suggestions from the forum before I begin trying to remove the batteries that aren't on a slide to access them easily especially if you think there may be something else causing the problem. Note: the kitchen GFCI worked and we ran an electric heater like usual for a short period of time in the early morning while running generator. TIA
Wade2000 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-26-2021, 12:41 AM   #2
Senior Member
 
Join Date: May 2009
Location: Mariposa, CA
Posts: 3,586
Contact Xantrex.
__________________
2003 - 2010: 2004 35' National RV Sea Breeze LX 8341
2010 - 2021: 2001 41' Newmar Mountain Aire 4095
2021 - ???? : 2001 31' National RV Sea View 8311
TechWriter is offline   Reply With Quote
Reply

Tags
charger, inverter, light, lights, wind



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 Tradewind 7373 fresh water pump Wade2000 National RV Owner's Forum 13 11-21-2021 11:34 PM
THe Charger side of my Kisae Inverter/Charger died, is a separate Charger good idea? elkski RV Systems & Appliances 0 03-31-2020 02:51 PM
2000 National Tradewinds 7373 Turn Signal howbowthat Class A Motorhome Discussions 14 08-18-2016 05:28 AM
2000 tradewinds 7373 Dexter2009 National RV Owner's Forum 1 02-17-2014 07:40 PM
2000 Tradewinds 7373 Dexter2009 National RV Owner's Forum 2 02-12-2014 07:56 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 09:02 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.