Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > National RV Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-06-2015, 07:48 AM   #1
Member
 
Join Date: Feb 2015
Posts: 32
Question 98 Tradewinds Low Engine Power

I just joined the RV world and have an issue in my 98 Tradewinds. There is virtually no power when starting from a full stop - it just slowly starts rolling until it gets a little speed then it will begin to accelerate.

The dealer had the fuel filters changed and used a gel remover in the fuel. No change. He then took it to a Diesel shop and their diagnosis was a bad High Pressure Oil Pump which was only producing 300-400 PSI but should produce about 3,000 PSI. Dealer didn't like his answer so is having it looked at by two other mechanics.

Been two weeks since this all started and I still don't have my coach. Any ideas appreciated.
Tio Phil is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-06-2015, 08:51 AM   #2
Senior Member
 
Rook's Avatar
 
National RV Owners Club
Solo Rvers Club
Freightliner Owners Club
Join Date: Mar 2011
Location: FT for 6 years, NW in the summer, S in winter.
Posts: 1,173
Stand firm, insist on a fix from the Dealer......a new High Pressure Pump is expensive, parts and labor, thousands. Rook
__________________
When you get a chance to dance, or sit this one out......I hope you DANCE!

98 National Tradewinds 7370, powered by a 3126B 300HP CAT Turbo, Freightliner XC chassis
Rook is offline   Reply With Quote
Old 02-06-2015, 10:04 AM   #3
Member
 
Join Date: Feb 2015
Posts: 32
Thank you Rook -


I am not bending. The dealer has now told me that if the high pressure oil pump was bad the whole engine would have locked up. He is insisting it is a fuel issue.


From what I have been reading it sounds like and HEUI failure, which may be being referred to as the HPOP but another well respected Freightliner Tech confirmed the symptoms and said the diagnosis was probably correct.


The cost quoted is just over $2,900.00
Tio Phil is offline   Reply With Quote
Old 02-06-2015, 10:40 AM   #4
Senior Member
 
wb7auk's Avatar
 
National RV Owners Club
Join Date: Feb 2012
Location: Spokane Valley, Wa
Posts: 1,987
The dealer does not have a clue.
The high oil pressure from the HEIU pump goes to the injectors so when the injector is fired it pushes a plunger down forcing the diesel on the other side out the injector at very high pressure in the area of 20,000 lbs.
I agree you need a new HEUI pump not cheap
__________________
Art
1999 Trade Winds 7371 Cat 3126B w/current upgrades
1990 D 250 Dodge Ram Cummins Turbo
wb7auk is offline   Reply With Quote
Old 02-07-2015, 10:48 AM   #5
Senior Member
 
Theberrys's Avatar
 
National RV Owners Club
Join Date: Jun 2009
Posts: 2,618
Check your Air Filter.
__________________
1999 Tradewinds 7372 Cat 3126
Albuquerque, NM
Theberrys is offline   Reply With Quote
Old 02-07-2015, 03:46 PM   #6
Senior Member
 
sgtjoe's Avatar
 
National RV Owners Club
Join Date: May 2008
Posts: 2,079
Shot in the dark here, but I had a similar problem with my 2001 Tradewinds with the CAT 300 3126b. At a stop light when I got the green I stepped on the pedal but got no response. I shut her down and restarted and it was fine. It did it a few more times and I took it to freightliner. It was something to do with programming the Engine Computer. Haven't had a problem since. Just a thought. Can't remember cost from 10 years ago but it wasn't expensive.
__________________
Joe & Angie
Shih Tzu's Cookie & Rocky
2001 Tradewinds 7390 2011 CRV EX-L Navi w/ RoadMaster FuseMaster
sgtjoe is offline   Reply With Quote
Reply

Tags
power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
'96 Flair(22') is it shore power supposed to charge the engine battery? Motor7 Fleetwood Owner's Forum 12 01-11-2015 07:17 PM
Can I wire my Intelli Power 9000 to also charge my engine battery? Motor7 Class A Motorhome Discussions 10 01-01-2015 12:21 PM
No power to anything without engine running deepfish Class A Motorhome Discussions 2 07-17-2014 07:04 AM
Intermittent engine and power loss resqguy Freightliner Motorhome Chassis Forum 1 07-13-2014 08:30 PM
Low engine power - Ignition reset? NavlAv8r Workhorse and Chevrolet Chassis Motorhome Forum 10 01-12-2014 03:21 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 04:50 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.