Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > National RV Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-30-2020, 03:15 PM   #1
Senior Member
 
Join Date: Sep 2015
Posts: 108
Atwood furnace 8535-IV issues

Furnace will kick on and quit after a minute. I do not hear a clicking noise from the igniter. I disconnected the wire from the round black auto ignition on the circuit board and put a test light on the auto ignition. I didn’t get any power to the auto igniter when I turned on the furnace. Does anyone know if that should have had a pulsing power indication. TIA
Kasey is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-31-2020, 09:44 AM   #2
Registered User
 
Ford Super Duty Owner
Join Date: Nov 2014
Location: NW Ohio
Posts: 7,114
Verify that the sail switch is making. This switch senses airflow when the blower is running. If the airflow is low, nonexistant, or the switch is bad, the the gas valve will not open.
Waiter21 is offline   Reply With Quote
Old 03-06-2020, 05:06 PM   #3
Senior Member
 
Join Date: Sep 2015
Posts: 108
Update on my furnace issue. 1/2 of my squirrel cage had disintegrated so my sail switch wouldn’t activate! Thanks for everyone’s help! You guys are awesome!
Kasey is offline   Reply With Quote
Old 03-06-2020, 10:00 PM   #4
Registered User
 
Ford Super Duty Owner
Join Date: Nov 2014
Location: NW Ohio
Posts: 7,114
Great. Glad to hear you got it fixed and thanks for reporting back.
Waiter21 is offline   Reply With Quote
Old 03-24-2020, 09:55 PM   #5
Senior Member
 
Belgian's Avatar
 
National RV Owners Club
Join Date: Jun 2006
Location: Manhattan Beach, CA
Posts: 695
Just for your information, that little black thing that has a wire going to the igniter, is a capacitor and puts out a lot more than 12VDC. It's similar to an ignition coil.
__________________
Steve & Jeri
2004 Dolphin 5342
2000 Jeep Cherokee 4X4
Belgian is offline   Reply With Quote
Old 03-24-2020, 10:20 PM   #6
Senior Member
 
OldWEB's Avatar
 
Join Date: Sep 2018
Posts: 519
Check the manual.

Quote:
Originally Posted by Kasey View Post
Furnace will kick on and quit after a minute. I do not hear a clicking noise from the igniter. I disconnected the wire from the round black auto ignition on the circuit board and put a test light on the auto ignition. I didn’t get any power to the auto igniter when I turned on the furnace. Does anyone know if that should have had a pulsing power indication. TIA
In the future, that model has an LED that will flash, giving the IGNITION CONTROL DIAGNOSTIC CODE for a fault. It will be in the manual.
OldWEB is offline   Reply With Quote
Reply

Tags
ace, atwood, furnace


« Lamps | Onan 5500 »

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Atwood furnace 8535 III DCDan RV Systems & Appliances 10 11-24-2016 10:32 PM
Atwood 8535 iv furnace problem harvey59 RV Systems & Appliances 2 02-26-2014 01:59 PM
Atwood 8535 IV DCLP Furnace Problems kjmort RV Systems & Appliances 5 01-11-2013 03:42 AM
Problems with Atwood Furnace 8535 IV wa8yxm RV Systems & Appliances 8 11-01-2011 11:32 PM
atwood furnace model 8535 ran out of propane, won't restart now rewaters49 RV Systems & Appliances 6 12-15-2010 08:21 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 02:19 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.