Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > National RV Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-09-2019, 08:35 PM   #1
Junior Member
 
Join Date: Jul 2018
Posts: 28
Dashboard Cluster Alarm

Hey guys, we own a 2008 National RV Pacifica. On the last trip we experienced a dash alarm going on and off as we were going down the road. When the alarm was on the dashboard cluster would drop out, no speedometer, psi gauges, etc. all would freeze where they were. Then for no apparent reason the alarm would cease and all the gauges began working as normal. Pretty irritating. Freightliner suggested I had a bad wiring package (??) the white wires that plug into the back of all the gauges. Any thoughts?
Revfred is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-09-2019, 08:51 PM   #2
Senior Member
 
Forest River Owners Club
iRV2 No Limits Club
Join Date: May 2009
Location: Where I lay my head.
Posts: 1,491
Blog Entries: 5
Quote:
Originally Posted by Revfred View Post
Hey guys, we own a 2008 National RV Pacifica. On the last trip we experienced a dash alarm going on and off as we were going down the road. When the alarm was on the dashboard cluster would drop out, no speedometer, psi gauges, etc. all would freeze where they were. Then for no apparent reason the alarm would cease and all the gauges began working as normal. Pretty irritating. Freightliner suggested I had a bad wiring package (??) the white wires that plug into the back of all the gauges. Any thoughts?
First I would check all FUSES as a short would show there hopeful first. That will help you to zero in on what the problem may be. Then look under the dash to see if any wires are loose hanging down? The Alarm is for what JACKS? OVERHEAT? any Fuel level problems in a tank. Meaning when you're driving down the road with air on and generator tunning when the fuel level gets low the generator will cut off some also have an ALARM. Could that be the issue? Good Luck
Dogman635UT is offline   Reply With Quote
Old 10-11-2019, 10:01 AM   #3
Senior Member
 
Workhorse Chassis Owner
Join Date: Sep 2007
Location: st.charles mo.
Posts: 1,482
On my 05 the dash has done that a couple of times a year for the last 13 years and I have had no problems with it I have been told that the dash cluster just reboots itself every now an then.
speed racer is offline   Reply With Quote
Old 10-12-2019, 07:42 AM   #4
Junior Member
 
Join Date: Jul 2018
Posts: 28
Thanks, I think I have found the problem. The 5 white wire plug the plugs into my light bar is loose. It feels tight but I can pull it out without having to squeeze the clip. So, I'm working on a way to fix that.
Revfred is offline   Reply With Quote
Old 10-12-2019, 07:43 AM   #5
Junior Member
 
Join Date: Jul 2018
Posts: 28
Thanks, I think I have found the problem. The 5 white wire plug the plugs into my light bar is loose. It feels tight but I can pull it out without having to squeeze the clip. So, I'm working on a way to fix that.
Revfred is offline   Reply With Quote
Reply

Tags
dash, dashboard



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dashboard says "Alt Charge" with an audible alarm Cyanne RV Systems & Appliances 7 10-14-2018 08:09 PM
Workhorse Instrument Cluster Display Drifterpilot MH-General Discussions & Problems 19 04-23-2017 11:24 PM
Low Air Alarm - False Alarm??? Wingsfan Class A Motorhome Discussions 5 11-02-2015 10:28 PM
alarm & dashboard lights came on tomH02871 Workhorse and Chevrolet Chassis Motorhome Forum 5 09-20-2013 10:02 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 12:09 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.