Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > National RV Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-04-2022, 10:55 PM   #1
Member
 
National RV Owners Club
Join Date: Apr 2016
Posts: 34
Instrument panel

Hi, I have the 2005 Dolphin. Recently all my gauges quite on my dash. The odometer and light is on, but none of the gauges; speedometer, has, coolant and tech work. I have checked all the fuses and wiggled wires at the dash, any ideas would be so awesome. Thank you!
Akwoofer is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-05-2022, 06:30 AM   #2
Senior Member
 
Join Date: Oct 2019
Location: indiana/florida
Posts: 170
probably needs to be sent to ultra rv for a rebuild, had to send mine in on my 05 dolphin.
inbogie is offline   Reply With Quote
Old 01-05-2022, 07:29 AM   #3
Senior Member
 
JJH3rd's Avatar
 
National RV Owners Club
Workhorse Chassis Owner
Join Date: Feb 2011
Location: Covington, GA
Posts: 730
Send a message via Skype™ to JJH3rd
Here's the link:
https://www.ultrarvproducts.com/

The difficulty is that their basic product is a replacement LCD screen not the entire board. That may be because of this: "Changing the LCD screen DOES NOT change your mileage. Mileage is stored on a separate memory chip on the circuit board!". Loss of the total mileage number when replacing the gauge circuit board is the problem. (potential legal consequences)

I agree, a call to them would be my next step.
__________________
J.J. Hayden (KN4SH)
Covington, GA
2005 National Dolphin 5342
JJH3rd is offline   Reply With Quote
Old 01-06-2022, 06:20 AM   #4
Senior Member
 
Join Date: Oct 2019
Location: indiana/florida
Posts: 170
Quote:
Originally Posted by JJH3rd View Post
Here's the link:
https://www.ultrarvproducts.com/

The difficulty is that their basic product is a replacement LCD screen not the entire board. That may be because of this: "Changing the LCD screen DOES NOT change your mileage. Mileage is stored on a separate memory chip on the circuit board!". Loss of the total mileage number when replacing the gauge circuit board is the problem. (potential legal consequences)

I agree, a call to them would be my next step.
with all due respect one of us is misinformed, i had my dash done at ultra and here is my understanding, 1. my guages now work, 2.the mileage is stored in the eprom in the vehichle computer, law. 3. they replace all the guage motors. cost i don't remember off hand but about 350.00 i think. jmo.
inbogie is offline   Reply With Quote
Old 01-06-2022, 06:51 AM   #5
YC1
Senior Member
 
YC1's Avatar


 
Join Date: Jun 2011
Location: FL
Posts: 10,373
Grab a voltmeter and check the wires. Fuses can be fine but connections may not be.

Check both sides of any of the gauges. The positive and the negative side that is.

You could have a bad ground or bat power. Putting the meter on the negative lead IF you have voltage on the positive lead of the gauge will show voltage if the ground is bad.

The ignition switch may not be sending the voltage from the fuse block.
__________________
Myron & Deborah
08 HR Endeavor 40 SKQ
400 Isl, 400 HP/// Now 450 HP
2016 Ford F150 Limited V6 with Ready Brake
YC1 is offline   Reply With Quote
Old 01-06-2022, 06:57 AM   #6
Senior Member
 
Join Date: Oct 2019
Location: Blount County TN
Posts: 182
Quote:
Originally Posted by YC1 View Post
Grab a voltmeter and check the wires. Fuses can be fine but connections may not be.

Check both sides of any of the gauges. The positive and the negative side that is.

You could have a bad ground or bat power. Putting the meter on the negative lead IF you have voltage on the positive lead of the gauge will show voltage if the ground is bad.

The ignition switch may not be sending the voltage from the fuse block.

Yup - years of restoring/maintaining little British cars taught me to check the simple stuff first, ground connections being paramount!
__________________
Mickey Richaud
2020 Jayco Precept 31UL
2018 Wrangler JLU Sport Toad
MRichaud is online now   Reply With Quote
Old 02-01-2022, 06:46 AM   #7
Member
 
National RV Owners Club
Join Date: Apr 2016
Posts: 34
Thanks everyone for the great advice. I sent the board into Ultra RV as suggested, they were great. Had the board back in a week, $299 and solved the problem, thanks again
Akwoofer is offline   Reply With Quote
Old 02-01-2022, 07:49 PM   #8
Member
 
Julia2005's Avatar
 
National RV Owners Club
Workhorse Chassis Owner
RV Trip Wizard
Join Date: Jan 2022
Posts: 64
Glad Ultra RV worked out for you. Happy travels.
__________________
Bruce & Zoe
2005 SeaBreeze LX 8360 - 2020 Jeep Rubicon
Full Timers
Julia2005 is offline   Reply With Quote
Reply

Tags
panel



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Instrument Panel "Stop" Light Rnicfingrp Allison Transmission Forum 2 04-02-2009 05:07 PM
Allegro Bus Instrument panel lighting yudamann Tiffin Owner's Forum 3 02-16-2009 06:34 AM
"Stop" light/Buzzer on Instrument Panel Rnicfingrp Newmar Owner's Forum 5 01-23-2009 03:27 PM
Instrument panel lights Bill Barton Winnebago Industries Owner's Forum 4 11-19-2008 03:56 PM
Trans Selection LED Readout Fade-Instrument Panel JC2 Workhorse and Chevrolet Chassis Motorhome Forum 9 09-16-2007 07:06 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 05:43 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.