Free 7 Day Trial RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > National RV Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-02-2018, 07:06 PM   #15
Senior Member
 
National RV Owners Club
Freightliner Owners Club
Join Date: Oct 2002
Location: silverdale wa.
Posts: 1,163
Quote:
Originally Posted by sgtjoe View Post
Are you using a Surge Protector??
Never hook up with out it. However, it just got back from replacing the engine and mebbee they plugged it in w/o and it surged.
Tried to get it into three different places to have them look at it and the earliest date for that was May 10th to DROP IT OFF. The other two were last week in May and the third was middle of June.
Looking for a mobil RV guy now.
__________________
Bigdog
2001 National Tradewinds 7390 LTC
2002 Subaru Legacy outback Limited stick
bigdog is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-02-2018, 11:42 PM   #16
Senior Member
 
sgtjoe's Avatar
 
National RV Owners Club
Join Date: May 2008
Posts: 2,088
Have you looked inside the compartment with all the fuses and did you see any with a red light. Also, like others said check the inverter, it has two switches. On the inside my 2001 7390 has a breaker box close to the floor just before the bedroom, check each breaker and reset them. Do you have any power coming from the GFI by the bathroom sink? Try to reset it.
__________________
Joe & Angie
Shih Tzu's Cookie & Rocky
2001 Tradewinds 7390 2011 CRV EX-L Navi w/ RoadMaster FuseMaster
sgtjoe is offline   Reply With Quote
Old 04-03-2018, 04:05 PM   #17
Senior Member
 
National RV Owners Club
Freightliner Owners Club
Join Date: Oct 2002
Location: silverdale wa.
Posts: 1,163
Ok, another update. Checked ALL fuses I could find front and back with tester, no red lights and all showed continuity, checked all circuit breakers everywhere.
So this is the list of what I found with, 1. AC on,2. Gen on 3. Gen off and AC plugged back in.
Micro/kitGFI off,on and then on
water heater and sink GFI on,off,on
fridge. on, off,on
right side AC,on,off,on
Left side ACoff,off,off
Bathroom GFI, off,on,on
TV/SAT off, off, off
I was unable to check the air conditioners as it's still below 50 degrees here today.
__________________
Bigdog
2001 National Tradewinds 7390 LTC
2002 Subaru Legacy outback Limited stick
bigdog is offline   Reply With Quote
Old 04-03-2018, 05:06 PM   #18
Senior Member
 
Charlie 5320's Avatar
 
Join Date: Mar 2017
Posts: 698
Quote:
Originally Posted by bigdog View Post
Ok, another update. Checked ALL fuses I could find front and back with tester, no red lights and all showed continuity, checked all circuit breakers everywhere.
So this is the list of what I found with, 1. AC on,2. Gen on 3. Gen off and AC plugged back in.
Micro/kitGFI off,on and then on
water heater and sink GFI on,off,on
fridge. on, off,on
right side AC,on,off,on
Left side ACoff,off,off
Bathroom GFI, off,on,on
TV/SAT off, off, off
I was unable to check the air conditioners as it's still below 50 degrees here today.
Have you verified that your inverter is in fact turned on? Show us a pic of the front of the inverter. May have an external on off switch plus an on/off switch on the front of the inverter. The inverter may be bad and not passing power when plugged in.
__________________
1996 Challenger 313

2003 Dolphin 5320 sold
Charlie 5320 is offline   Reply With Quote
Old 04-03-2018, 05:08 PM   #19
Senior Member
 
homecan1's Avatar
 
National RV Owners Club
Freightliner Owners Club
Join Date: Oct 2013
Location: Southern California
Posts: 200
Have you checked the lugs in your transfer switch? Make sure everything is tight. That solved a similar problem in my coach.
__________________
Palm Springs, CA - 2005 National Tropi Cal 370LX on a Freightliner, Cat 350 power. Towing a Rinker R1 - Lake Havasu Bound!!
homecan1 is offline   Reply With Quote
Old 04-03-2018, 05:21 PM   #20
Senior Member
 
National RV Owners Club
Freightliner Owners Club
Join Date: Oct 2002
Location: silverdale wa.
Posts: 1,163
The inverter is humming away as usual and the breakers were turned on and off. The lights on the front that show the wet cell charging and the inverter lite is steady.
I thought about that also, but it's gonna have to wait till I get back from sunny southern Cal. Heading down to see an old high school friend and then going to the March AFB 100th anniversary open house and air show and meet up with some of my old SAC Boomer buddies from when we were stationed together in the mid 60s.
__________________
Bigdog
2001 National Tradewinds 7390 LTC
2002 Subaru Legacy outback Limited stick
bigdog is offline   Reply With Quote
Old 04-14-2018, 11:17 AM   #21
Senior Member
 
sgtjoe's Avatar
 
National RV Owners Club
Join Date: May 2008
Posts: 2,088
What happened to your engine to have to replace it? And have you found the electrical problem?
__________________
Joe & Angie
Shih Tzu's Cookie & Rocky
2001 Tradewinds 7390 2011 CRV EX-L Navi w/ RoadMaster FuseMaster
sgtjoe is offline   Reply With Quote
Old 04-14-2018, 05:05 PM   #22
Senior Member
 
National RV Owners Club
Freightliner Owners Club
Join Date: Oct 2002
Location: silverdale wa.
Posts: 1,163
Quote:
Originally Posted by sgtjoe View Post
What happened to your engine to have to replace it? And have you found the electrical problem?
Several theories on the motor and a couple involve the PO and one for me. One of the PO items was too long between oil changes and another was that there may have been damage from a fire in the engine comptartment. From what we can determine, the rear cap may be new as it is much whiter and there are signs of other damage like melted wires where you can hardly see them and melted foam insulation around the edges of the engine compartment. All of which were missed by the inspector and the real engine problems didn't show up till a couple of years after I got it. The other problem happened after I owned it and was pretty much inadvertant on my side and may be the main reason for the dusting, or not. I changed the air filter with the OEM suggested one and about 6 months later noticed that the minder was going full up on trips. Pulled the new filter and discovered that it was very wet and coming apasrt. In fact it weighed over 16 #s. When I changed it I noticed that there were no drain holes in it like the new replacement one. So the mechanics that pulled the pan and inspected it figgered it may have been a combination of all three or mebbee just one.
But, no matter who caused it, it still cost me $22K. First long trip not till second week in May and that's down to Eugene,over to Lincoln City,up to Mcminnville and then home thru Portland. Even got friends from out of town coming to visit ther friends and house sit for us.
On the electrical problem, I have checked everything that I have told about gnd have a hunch that it could be the power switch as stuff on the one leg is out and when I run the gennie,it seems as if it's all running off the inverter and the house batteries are dying. Goes in May 1st and hoping they find it quickly. I'm still thinking that the engine guys plugged it into a wrong socket with out the surge guard or mebbee when they were working on the gennie starter system.
__________________
Bigdog
2001 National Tradewinds 7390 LTC
2002 Subaru Legacy outback Limited stick
bigdog is offline   Reply With Quote
Reply

Tags
electric, power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Are You Missing Detailed Electric Drawings "007" Newmar Owner's Forum 12 10-29-2017 11:12 AM
Cummins missing power. Kramer Boy Cummins Engines 8 08-08-2015 10:41 AM
99 F53 First long trip - Missing, down on power (help!) cb1000rider Ford Motorhome Chassis Forum 16 08-26-2012 02:42 PM
Overloaded Electric & now NO electric unless using generator. themeowers RV Systems & Appliances 10 12-28-2011 10:53 AM
Missing Manual Found (and I didn't know it was missing JavaJelly Newmar Owner's Forum 5 12-21-2006 04:31 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 12:17 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.