Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > National RV Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-23-2018, 12:23 PM   #15
Member
 
Join Date: Jul 2018
Posts: 49
Hey thanks guys, the fluid looks good and I have tried it with the engine off. My thing is that the panel just won't turn on. I found a wiring diagram for it and it has the light labeled as "jacks down." I'm wondering if it's on in an error though. I found a bunch of faulty wiring on the solenoids which were also damaged, so I replaced them and fixed the wiring with no luck, but it was probably something that would have had to be done anyway. I'm going to have a shop troubleshoot it for a bit of I can't figure out out in a week or so. I'll be testing connections and stuff in the meantime. I also now have a bunch of those tiny round fuses if anyone needs some.
MongoBadger is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-20-2018, 08:48 PM   #16
Senior Member
 
Join Date: Nov 2015
Location: EAST TN
Posts: 123
JACKS

My 2000 - 7370 panels both look like yours. The power switch at the door has to be on. Ign switch has to be in on postion , eng not running. Has a fuse also at the resivor tank behind driver side rear wheel bay. Fuse is covered with rubber cap. Check also your tank is very secure to head,the screws would loosen up . I replaced my screws with allen head bolts. The red light on my pannel indicate the jacks are down. Sometimes if i start motor jacks will retract auto. As cap sticker should show tank fill cap is orentation senstive as it will turn red light off when jacks retract and fill oil resivor full. Your oil resivor may be low and red light thinks jacks are down. Jacks use atf fluid.
__________________
2000 NATIONAL TRADEWINDS 7370 - FREIGHTLINER XC - 3126B CAT 300 HP ALLISON 6 SPEED
10EC is offline   Reply With Quote
Old 08-21-2018, 04:30 AM   #17
Member
 
Join Date: Jul 2018
Posts: 49
Quote:
Originally Posted by 10EC View Post
My 2000 - 7370 panels both look like yours. The power switch at the door has to be on. Ign switch has to be in on postion , eng not running. Has a fuse also at the resivor tank behind driver side rear wheel bay. Fuse is covered with rubber cap. Check also your tank is very secure to head,the screws would loosen up . I replaced my screws with allen head bolts. The red light on my pannel indicate the jacks are down. Sometimes if i start motor jacks will retract auto. As cap sticker should show tank fill cap is orentation senstive as it will turn red light off when jacks retract and fill oil resivor full. Your oil resivor may be low and red light thinks jacks are down. Jacks use atf fluid.
Hey thanks for the reply. This may sound dumb, but how do you turn the switch at the door on? I've cycled the battery disconnect switch and nothing seems to happen. That may be the problem right there. It's in the shop right now, but I could pass that to them.
MongoBadger is offline   Reply With Quote
Old 08-21-2018, 04:07 PM   #18
Senior Member
 
Join Date: Nov 2015
Location: EAST TN
Posts: 123
The " disconnect" switch under the red light is a rocker switch. Rock it outward should power that pannel up and the red light above the "disconect" switch should light up to indicate the pannel is powered up. This switch also has to be "on" to get front window fans to work. Again , mine has to be on and the ingtion switch has to be in the on postion and then press power button on panel to get the jacks to work.

If this still is not working for you, you might need to pull the panel and see that you have 12v to the "disconnect" switch to start with. When i rock my "disconect" switch i can hear a latch silnoid somewhere kick in, as to hold power to the panel but i dont know where it is.
__________________
2000 NATIONAL TRADEWINDS 7370 - FREIGHTLINER XC - 3126B CAT 300 HP ALLISON 6 SPEED
10EC is offline   Reply With Quote
Old 08-21-2018, 04:23 PM   #19
Senior Member
 
Join Date: Nov 2015
Location: EAST TN
Posts: 123
Went to check latch silnoid for powering door panel. It is in my rear bay door , passenger side. (will try to post pic) on back side of fuse board. Top back outside of board.it is black 2x3 inch square 1 inch thick
Attached Thumbnails
Click image for larger version

Name:	IMG_0653.jpg
Views:	71
Size:	195.0 KB
ID:	215907   Click image for larger version

Name:	IMG_0654.jpg
Views:	55
Size:	280.4 KB
ID:	215908  

__________________
2000 NATIONAL TRADEWINDS 7370 - FREIGHTLINER XC - 3126B CAT 300 HP ALLISON 6 SPEED
10EC is offline   Reply With Quote
Old 08-21-2018, 04:30 PM   #20
Senior Member
 
Join Date: Nov 2015
Location: EAST TN
Posts: 123
What i done to mine to help me remeber. With dyno labler
Attached Thumbnails
Click image for larger version

Name:	IMG_0655.jpg
Views:	42
Size:	229.2 KB
ID:	215910  
__________________
2000 NATIONAL TRADEWINDS 7370 - FREIGHTLINER XC - 3126B CAT 300 HP ALLISON 6 SPEED
10EC is offline   Reply With Quote
Old 08-22-2018, 09:34 PM   #21
Member
 
Join Date: Jul 2018
Posts: 49
Thanks for the help, I'm stopped at a truck stop to sleep a little before heading out in the morning. I'll take a look then, but my switch doesn't do anything, but the front fans work and one of the light switches on that panel works, this seems to be the next logical place to start troubleshooting. I really appreciate the help.
MongoBadger is offline   Reply With Quote
Old 08-23-2018, 12:24 AM   #22
Junior Member
 
Moneyhan's Avatar
 
National RV Owners Club
Join Date: Jan 2015
Location: Phoenix, AZ
Posts: 11
Fuse

I doubt this is your problem but I pulled a bonehead move one time when checking fuses and accidentally put the fuse for the jack controller in an empty fuse slot right next to where I pulled it from when I went to put it back. Took a while to figure out that I had done that.
Moneyhan is offline   Reply With Quote
Old 08-24-2018, 06:51 AM   #23
Member
 
Join Date: Jul 2018
Posts: 49
Thanks, I make those simple mistake all of the time. In this case the panel has power though as three jacks down light is on.

Looking at my panel with the disconnect switch, the disconnect switch appears to be broken and the disconnect light won't come on, but everything on the panel appears to have power. That's what yours needs to work, right?

That solenoid didn't do anything I looked for the reset below the jacks pump as is printed on both of our unit's circuit boards, but didn't find it.
MongoBadger is offline   Reply With Quote
Old 08-24-2018, 11:28 PM   #24
Junior Member
 
Moneyhan's Avatar
 
National RV Owners Club
Join Date: Jan 2015
Location: Phoenix, AZ
Posts: 11
Disconnect

With mine, if the disconnect is engaged I get no power at all at the jack controller. The fact that you have a light is a good sign. Is the jack down light on with the jacks up or are they down? Have you checked the jack wiring in the engine compartment?
Moneyhan is offline   Reply With Quote
Old 08-27-2018, 06:47 AM   #25
Member
 
Join Date: Jul 2018
Posts: 49
Quote:
Originally Posted by Moneyhan View Post
With mine, if the disconnect is engaged I get no power at all at the jack controller. The fact that you have a light is a good sign. Is the jack down light on with the jacks up or are they down? Have you checked the jack wiring in the engine compartment?
Sorry for the late reply, been busy with my brother's wedding. I recently redid the wiring at the pump and matched it all up with the wiring diagram. I just found out that my disconnect switch is bad so I'm going to try relaxing it first.
MongoBadger is offline   Reply With Quote
Old 09-07-2018, 10:52 PM   #26
Member
 
Join Date: Jul 2018
Posts: 49
Hi guys, I haven't forgotten about you guys. The motorhome is in a shop a long way away. I had a bad power surge which fried some gauges. Then the tow truck driver forgot to remove part of the two piece drive shaft which damaged a cooling hose, destroyed my oil pan, and poked a hole in my transmission as it fell out and got lost. The tow company is denying everything, so I have insurance on my side making them pat for it.

On a cool note though I couldn't get a rental with my dogs so I bought a 1992 firebird on craigslist and drove it halfway across the country to get home all while listening to 80's hair bands.
MongoBadger is offline   Reply With Quote
Reply

Tags
jacks, leveling, leveling jacks, power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Leveling Jacks not leveling coach Oldguy2013 Entegra Owner's Forum 20 11-04-2017 04:54 PM
Power Gear Leveling Jacks Controller location, 36M DancinCampers Winnebago Industries Owner's Forum 3 08-07-2017 02:14 PM
Using leveling boards/jacks pads with class A jacks Unicorn Driver Class A Motorhome Discussions 22 08-06-2017 06:04 PM
Power gear jacks controller switching on while cornering Unicorn Driver RV Systems & Appliances 4 06-12-2017 06:16 AM
lost power to slide,jacks controller gatorv Alpine Coach Owner's Forum 4 03-19-2013 11:01 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 12:44 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.