RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > National RV Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-29-2016, 09:51 AM   #1
Senior Member
 
Join Date: May 2015
Location: Saco, Maine
Posts: 150
"Pop" sound under passenger side when taking turns

I own a 2006 national Dolphin 5355 with the Ford V-10 engine. Recently when taking turns, I can hear a "pop" sound or thump under the front passenger side of the RV. Does anyone know what this might be or has anyone experienced the same thing? I just had my annual state inspection in June and I asked the mechanic to do a thorough check underneath of the shocks, etc. He said everything looked good and it passed. But I am obviously concerned about the noise as my wife and I will head South this October and will be driving long distances. Any ideas or observations would be greatly appreciated.
Thanks,
Dave
__________________

dlduck is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-29-2016, 10:02 AM   #2
Senior Member
 
Floridakamper's Avatar
 
Workhorse Chassis Owner
Join Date: Nov 2006
Location: Fleming Island, Fl
Posts: 821
I had the same sound on my 06 Newmar Kountry Star. I'm on a Workhorse chassis and you're on a Ford so this may or may not be of any help. After much searching I discovered two "small" broken welds on the passenger side where the "front cap" was attached to the frame. It was a relatively easy and cheap fix once I discovered the problem. The other symptom I had other than the popping noise, which I usually heard at low speeds when turning, was the corners of my windshield were popping out of the gasket. I had them reset twice before I discovered the defective welds. I might never of found them if someone on this forum told me look for them because they had the same problem. Good luck finding the cause.
__________________

__________________
Bob & Leah, USN Retired
2016 Itasca Suncruiser 38Q/SOLD
2014 Chevy Equinox LTZ/Blue Ox Tow Bar
Floridakamper is offline   Reply With Quote
Old 07-29-2016, 10:23 AM   #3
Senior Member
 
Floridakamper's Avatar
 
Workhorse Chassis Owner
Join Date: Nov 2006
Location: Fleming Island, Fl
Posts: 821
On my rig, if I looked in the passenger side wheel well I can see the weld on the frame. Here's a pic that might help. I'm not sure how National attached the front cap to the frame but on my Newmar it appears a weld to the frame on each side is key.

Click image for larger version

Name:	Front Cap Weld.jpg
Views:	91
Size:	329.3 KB
ID:	134437
__________________
Bob & Leah, USN Retired
2016 Itasca Suncruiser 38Q/SOLD
2014 Chevy Equinox LTZ/Blue Ox Tow Bar
Floridakamper is offline   Reply With Quote
Old 07-29-2016, 10:52 AM   #4
Senior Member
 
Join Date: May 2015
Location: Saco, Maine
Posts: 150
"Pop" sound under passenger side when taking turns

Bob,
Thank you very much for your input and I will check my weld underneath the front end to see if I might have the same issue. It is certaintly annoying and could potentially be a serious safety issue. I have not had any problems yet with windshield issues (knock on wood). Thanks again for your insight.
Dave
dlduck is offline   Reply With Quote
Old 07-29-2016, 01:35 PM   #5
Senior Member
 
Join Date: Jan 2015
Posts: 1,072
I had this on my 2008 Bounder it was the front sway bar. Torqued the bolts to 68 lbs no more pop.
redcolorado is offline   Reply With Quote
Old 07-30-2016, 12:59 PM   #6
Senior Member
 
TOM356C's Avatar
 
National RV Owners Club
Join Date: Jul 2013
Location: JACKSONVILLE,FL ex Newport Beach,Ca
Posts: 213
This is the fix for the Ford chassis sway bar. I installed it myself on 02 Bounder I had. It is the cure. Not a hard job but takes quite a bit of time.
Ford: a motor home..front suspension..brackets..Bulletin
Tom 07 Pacifica
TOM356C is offline   Reply With Quote
Old 07-30-2016, 05:56 PM   #7
Senior Member
 
Join Date: Jan 2015
Posts: 1,072
Quote:
Originally Posted by TOM356C View Post
This is the fix for the Ford chassis sway bar. I installed it myself on 02 Bounder I had. It is the cure. Not a hard job but takes quite a bit of time.
Ford: a motor home..front suspension..brackets..Bulletin
Tom 07 Pacifica
I also installed the brackets.
redcolorado is offline   Reply With Quote
Old 09-06-2016, 01:03 PM   #8
Senior Member
 
m.elliott63's Avatar
 
National RV Owners Club
Join Date: Nov 2015
Location: Monrovia, IN
Posts: 369
Other possibilities are the ball joints and wheel bearings.
__________________

__________________
1998 National Seabreeze 1330 Limited Chevrolet P37 chassis 7.4 Vortec 2014 Jeep JKU Sport Toad
Me, Beautiful DW, sometimes kids & grandkids
m.elliott63 is online now   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Condensation under passenger side of dash ? AC Orange Ford Motorhome Chassis Forum 14 08-19-2015 03:44 PM
My '04 ISB 300 makes a "pop" sound..... patterbery Cummins Engines 27 06-30-2015 11:56 PM
Whirlpool washer turns on lights flash then turns off SuzzyQ Entegra Owner's Forum 17 06-21-2015 07:46 AM
Anyone convert from a pop up camper to "pop up concession"? xJoey Dubsx Pop Up, Tent Trailer and Teardrop Topics 3 08-19-2013 07:22 AM
Noise under dash on passenger side norlfran Thor Industries Owner's Forum 2 06-18-2012 10:04 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 08:54 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×