Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > National RV Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 02-15-2020, 06:24 PM   #1
Member
 
Holiday Rambler Owners Club
Join Date: Jan 2020
Location: Hudson, MA
Posts: 56
Running lights not working

Have a 2007 Dolphin LX, was just getting ready to head south, but all of a sudden I have no running, side marker, clearance lights or dash lights. Have checked the fuses under the drivers side (all three), all ok. Where else can I check? I checked the fuses in the box under the hood, all ok.
Have no where else to turn, greatly appreciate any and all help.
CaptLou is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-17-2020, 11:12 PM   #2
Senior Member
 
National RV Owners Club
Join Date: Jan 2015
Location: Thousand Oaks, Ca.
Posts: 139
Blog Entries: 1
Not sure if it helps, but I found fuses in the inverter cabinet.
__________________
Scott & Dawn 2007 National Tropical T330
stinespool is offline   Reply With Quote
Old 02-18-2020, 01:36 PM   #3
Senior Member
 
Vaflatlander's Avatar
 
National RV Owners Club
Join Date: Apr 2012
Location: Virginia Beach Va.
Posts: 170
Send a message via Skype™ to Vaflatlander
The three fuses you have checked I assume are all headlight running lights etc did you check to see if when you engage the headlight switch they have power to them it could be the headlight switch that is your problem.
__________________
Ed & Sharon Ward ,Virginia Beach, Va.
2000 National RV, 37' Tradewinds
3126 Cat 300hp Allison 6spd Fl xc chassis
Vaflatlander is offline   Reply With Quote
Old 03-10-2020, 01:33 PM   #4
Junior Member
 
Join Date: May 2019
Location: FAYETTEVILLE PA
Posts: 7
had same issue turned out to be bad headlight switch
firedan is offline   Reply With Quote
Reply

Tags
light, lights



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dash lights, running lights and brake lights are intermittent! flyr4u Monaco Owner's Forum 8 05-27-2019 07:32 AM
Tail and running lights not working on 3970 Escaper Ripnfix Damon 0 08-25-2015 08:28 AM
2002 Ambassador running lights not working. Okrver Monaco Owner's Forum 5 02-11-2015 05:04 PM
turn signals, running lights, tow lights side clearance lights not working gowhiz Tiffin Owner's Forum 3 02-26-2014 08:02 AM
Running lights not working Lisablue85 Class A Motorhome Discussions 10 08-09-2012 12:44 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 02:48 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.