Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Tiffin Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-21-2021, 04:06 PM   #1
Junior Member
 
Join Date: Jun 2021
Posts: 1
2016 31SA electrical issue

Patio light & bath fan/fan lid stopped working. All was good before we left home. Checked DC breaker panel, all is good. Suggestions?
Daryl11 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-23-2021, 01:20 PM   #2
Senior Member
 
Gulf Streamers Club
Ford Super Duty Owner
Join Date: Aug 2015
Location: Memphis, TN
Posts: 2,402
1) DC= Fuses; 2) My 20yo bath EXH toggle switch failed, new switch failed 6-months later, (both mechanical fails) new 3rd switch= good; Replaced all ceiling light rockers w/ (20/packet) Amazon/ china; year/so later 2-3 are erratic electrically. It happens
__________________
(TerryH.) 2000-GS Conquest Limited 6266 Class-C 99-E450SD V10
THenne1713 is offline   Reply With Quote
Old 08-05-2021, 12:07 PM   #3
Junior Member
 
Join Date: Dec 2015
Posts: 14
Check the ground at both locations
mollies33 is offline   Reply With Quote
Old 08-05-2021, 07:25 PM   #4
Senior Member
 
Join Date: Nov 2018
Location: Beaver Dam, Wisconsin
Posts: 2,411
Add to THenne1713's list loose connectors at fuse panel, at switches, and at the appliance.
__________________
Paul Bristol
Kodiak Cub 176RD
Nissan Pathfinder 2015
Persistent is offline   Reply With Quote
Old 08-07-2021, 04:45 AM   #5
Senior Member
 
Join Date: Aug 2016
Posts: 705
Long shot, bathroom GFI?
__________________
Pete , Stroudsburg , PA. 2017 Tiffin 32 SA 24K Chassis
Sumo Springs, Safe T Plus, F&R RM SB, R-TB, Front Koni FSD Quad Shocks, Rear Koni FSD Quad Shocks,2019 Jeep Cherokee Trailhawk Elite
Peter M is offline   Reply With Quote
Old 08-07-2021, 09:59 AM   #6
Senior Member
 
Tiffin Owners Club
Appalachian Campers
Mid Atlantic Campers
Coastal Campers
Freightliner Owners Club
Join Date: Jan 2015
Posts: 1,622
Those are 12v, nothing to do with the inverter function. Acquire an inexpensive digital voltmeter so you can check your house battery voltage, suspect something amiss since it's effecting multiple devices.
__________________
DaveB, Raleigh, NC
2015 Tiffin RED 33AA, w/Honda CRV
VMSpc, Magnum BMK/ARC50
Kiawah is offline   Reply With Quote
Old 08-12-2021, 08:01 PM   #7
Junior Member
 
Join Date: Aug 2021
Posts: 11
I second mollies33. Quite often 12v oddities are grounding problems. The two problems may not be related, just a coincidence. Look for push on connectors that are loose.
RonAz is offline   Reply With Quote
Old 08-13-2021, 07:27 AM   #8
Senior Member
 
Join Date: May 2021
Posts: 131
Quote:
Originally Posted by Daryl11 View Post
Patio light & bath fan/fan lid stopped working. All was good before we left home. Checked DC breaker panel, all is good. Suggestions?
It’s likely that the fan and light problem is connected. Although you said you checked the fuses and all appeared ok, double check. Sometimes fuses appear to be good but have shorted out. To help figure which one could be bad if they’re not labeled, start pulling fuses and check with an ohm meter for continuity.

After and if all that checks out, try checking voltage on load wires out of fuse panel. As suggested, ground problems cause many of these problems. Check ground connections closely.

Then I would pull a switch to check for voltage there to verify it’s not a switch. Remember, there is no ground wire at the 12v switches. The switch simply breaks the voltage to the light or fan. One of the wires should show voltage. If none, then you need to backtrack to find the problem.

A final thought. You could run a temporary bypass length of wire clipped to the frame or negative side of battery and then to the light to see if the light works. That way you can eliminate the possible grounding problems if it doesn’t help.
Country Road is offline   Reply With Quote
Reply

Tags
electric, electrical



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to turn in mirror on 2016 ALLEGRO 31SA jerztime Tiffin Owner's Forum 2 12-16-2016 04:28 PM
Buying Allegro 31SA-have option questions altrego52 Tiffin Owner's Forum 1 09-30-2013 08:03 AM
Allegro 31SA Entertainment Wiring ezridermd Tiffin Owner's Forum 1 06-11-2013 06:59 PM
Any Allegro 31SA Owners? szn8tt Tiffin Owner's Forum 0 05-12-2013 12:46 PM
Rear slide 31sa ezridermd Tiffin Owner's Forum 8 03-19-2013 05:20 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 10:51 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.