Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Tiffin Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 02-21-2014, 02:36 PM   #1
Senior Member
 
silverado574's Avatar
 
Tiffin Owners Club
Freightliner Owners Club
Join Date: Mar 2012
Posts: 115
34TGA Rear Monitor

We have a 2012 34 TGA and on the way home from Florida this week I noticed that the rear monitor, a Triple-Vision 7" LCD screen was going dark. When I turned on the turn signals the side cameras were dark as well so I figured it was the monitor. When I hit a pothole on 95 the screen would get brighter and seemed to be fine. Then it would go dark again. I called the manufacturer and they thought it might be a ground. I traced the wires from the back of the set and they go into a huge harness. Thinking about cutting the black ground out of the camera monitor harness and bugging a spliced ground into one I know works. Any body had this experience? Thanks.
silverado574 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-23-2014, 06:12 AM   #2
Senior Member
 
94-Newmar's Avatar
 
Join Date: Nov 2009
Posts: 2,043
I am not familiar with your exact setup. However, *most* camera installations utilize a camera controller module. The controller will have the R and L turn, and reverse sense wires going to it, and one video cable running from it to your monitor. The controller will also have a separate 12v power source. I agree with checking the ground (or 12v+) theory as being your problem is a good starting point for troubleshooting this, but if yours does indeed use a controller then I would try to find it as that is most likely where your loose or faulty ground or + wire problem is.

If your monitor has 3 different inputs, one for each camera, (no controller) then I would continue the direction you were heading with supplying a separate ground and even try a different 12v+ source as well temporarily to see if the problem goes away.
__________________
94-Newmar Kountry Star 40-KSDP
Spartan/Cummins 8.3C-300HP/Allison 3060 WTEC-II/25yr RV Tech RVIA Certified/Onan-Cummins Certified
94-Newmar is offline   Reply With Quote
Old 02-24-2014, 03:47 AM   #3
Senior Member
 
silverado574's Avatar
 
Tiffin Owners Club
Freightliner Owners Club
Join Date: Mar 2012
Posts: 115
34 TGA Rear Monitor

Thanks for that comeback information. Running another positive source is a good idea also. This is one of those situations if I take it back to the dealer for an extended warranty repair, I will drive 70 miles and with the intermittent condition like this is doing, usually with my luck it will not show up and there will be a big "nothing found" stamp on the ticket. Thanks again.
silverado574 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bounder: Rear Camera and monitor BarryN514 Fleetwood Owner's Forum 11 11-05-2013 07:44 PM
Rear Monitor not getting power esor5635 RV Systems & Appliances 1 09-21-2013 01:29 AM
New rear view color monitor adonh Class A Motorhome Discussions 4 09-08-2013 02:51 PM
videoman rear camara and monitor bigred726 iRV2.com General Discussion 1 06-12-2013 09:36 AM
Squirrely rear camera RJEV MH-General Discussions & Problems 8 06-08-2013 03:39 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 11:45 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.