Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Tiffin Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-26-2021, 12:26 PM   #1
Junior Member
 
Join Date: May 2021
Posts: 8
Aqua Hot 450D Problem no heat zone 2 (front)

Allegro Bus 45LP 2014 Aqua hot 450D

Aqua Hot cool air zone 2 (front)

1- All light are green
2- Plastic container at right level of anti-freeze when hot or cold.
3- Tap the check valve
4- Pump is working I can it hear running.
5- Check line zone 1 and zone 2 both hot from the check valve to Pump
6-Check both line after the pump and up pass the aqua hot housing both hot.(Note:Maybe the zone 1 'line is a tiny bit hotter than line 2)
7- Check all the line for king or leak (nothing found)
8- try to push antifreeze thru the system with a manual pump kit It worked but overfill plastic container.
8- Left it run for about one hour

I did # 8 thinking that I have a airlock and also did unscrew the top valve to let air out.

This is where I am not 100% sure how to get rid of an air lock (or pressurize the system). What would be the exact procedure step by step ?

Very discouraged, everything seems to work fine but still no heat zone 2
scepter20 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-27-2021, 07:38 AM   #2
Senior Member
 
DRM901's Avatar
 
Tiffin Owners Club
Texas Boomers Club
Join Date: Feb 2018
Location: North Texas
Posts: 668
Is the front radiator hot? Is that fan just not moving? If so, it sounds electrical, not the antifreeze. I would start by swapping the thermostat between the 2 zones to see that is the issue.
__________________
2014 Tiffin Allegro Bus 37AP
DRM901 is offline   Reply With Quote
Old 09-28-2021, 10:58 AM   #3
Junior Member
 
Join Date: May 2021
Posts: 8
Yes all the fan are moving but only cold air.
scepter20 is offline   Reply With Quote
Old 09-28-2021, 09:23 PM   #4
Senior Member
 
DRM901's Avatar
 
Tiffin Owners Club
Texas Boomers Club
Join Date: Feb 2018
Location: North Texas
Posts: 668
Is the radiator hot? I know on our 2014 Allegro Bus you can easily get to the front radiator by taking out the drawers in the pull out work top.

If it isn't, then I think it must be the circulation pump for that zone. There is one for each zone.
__________________
2014 Tiffin Allegro Bus 37AP
DRM901 is offline   Reply With Quote
Old 09-29-2021, 08:02 AM   #5
Senior Member
 
DRM901's Avatar
 
Tiffin Owners Club
Texas Boomers Club
Join Date: Feb 2018
Location: North Texas
Posts: 668
You could test out the pump by jumping 12v to the terminals to see if it works and moves fluid. If it runs but doesn't move fluid, it probably has a bad impeller.
__________________
2014 Tiffin Allegro Bus 37AP
DRM901 is offline   Reply With Quote
Reply

Tags
aqua hot, heat, problem



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hydro-hot HHE200 with two zone, only one zone delivers hot air swsarmyknife RV Systems & Appliances 8 06-15-2019 06:03 PM
Entegra Aqua Hot 450D brianw8602 Entegra Owner's Forum 36 05-31-2015 06:35 PM
Source for 450D Aqua Hot filters? brobox Entegra Owner's Forum 14 07-23-2014 05:18 PM
Aqua Hot 450D Five2o RV Systems & Appliances 7 05-04-2013 04:50 PM
Which DP's have aqua hot 450D standard? GARRYOWEN Class A Motorhome Discussions 10 09-28-2012 04:06 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 07:03 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.