RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Tiffin Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-16-2019, 06:15 AM   #1
Senior Member
 
Join Date: Aug 2016
Posts: 576
EMS HW 50 C Delay Jumper setting Question

What setting did you use for the time delay jumper?

The default setting is 15 sec or did you remove the jumper for the 136 sec delay.

My 2017 Tiffin 32 SA has the 15 K front and 13.5 A/C units.


Thanks
__________________

__________________
Pete , Stroudsburg , PA. 2017 Tiffin 32 SA 24K Chassis
Sumo Springs, Safe T Plus, F&R RM SB, R-TB, Front Koni FSD Quad Shocks, Rear Koni FSD Quad Shocks,2019 Jeep Cherokee Trailhawk Elite
Peter M is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-16-2019, 09:46 AM   #2
Senior Member
 
Join Date: Aug 2016
Posts: 576
Quote:
Originally Posted by Peter M View Post
What setting did you use for the time delay jumper?

The default setting is 15 sec or did you remove the jumper for the 136-sec delay.

My 2017 Tiffin 32 SA has the 15 K front and 13.5 A/C units.


Thanks
FYI for others. I decided to time how long it took the A/C units to engage the compressor. Both units took less than 5 seconds, decided not to remove the jumper, therefore, 15-sec delay.
Yes I'm a thread killer.
__________________

__________________
Pete , Stroudsburg , PA. 2017 Tiffin 32 SA 24K Chassis
Sumo Springs, Safe T Plus, F&R RM SB, R-TB, Front Koni FSD Quad Shocks, Rear Koni FSD Quad Shocks,2019 Jeep Cherokee Trailhawk Elite
Peter M is offline   Reply With Quote
Old 06-16-2019, 01:56 PM   #3
Senior Member
 
Lt Dan's Avatar


 
Tiffin Owners Club
Join Date: Sep 2013
Location: DFW, Texas
Posts: 4,087
The purpose of the delay in the HW50C is to protect the AC compressors in case of a power failure. The delay gives the compressors time to bleed down head pressure so they are not trying to start under pressure.

With that said, you don't need the delay on the EMS. The RVComfort thermostats have a built in two minute delay if a unit goes off, then power comes back. I contacted Airxcel (Coleman) directly to ask if the ACs had a delay. They said no, but the thermostat did.
__________________
Dan & Ro with two Rescued Boston "Terrorists" Jade & Jewel
2017 Phaeton 40IH XSH Maroon Coral - Power Glide Chassis with IFS (05/17)
Previously '15 Tiffin Allegro RED 38QRA and '06 Itasca Sunrise 35A
'16 Jeep JKU Wrangler Sahara or '08 Honda Goldwing
Lt Dan is online now   Reply With Quote
Reply

Tags
ems



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Progressive Ind. EMS-HW50C jumper question marjoa Class A Motorhome Discussions 10 11-13-2016 05:16 AM
Time delay on a EMS-HW50C ?? wolfcreek Class A Motorhome Discussions 10 11-27-2015 05:03 AM
Wiper, delay setting, not working J. C. R. Tiffin Owner's Forum 0 06-15-2015 03:09 PM
What do you have your delay set at on your 50 amp Progressive EMS? wengayle Monaco Owner's Forum 11 03-24-2015 11:00 AM
Jumper from coach to house batteries? RUNDLC Monaco Owner's Forum 8 07-02-2011 11:24 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 07:27 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×