Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Tiffin Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-21-2013, 10:08 PM   #1
Junior Member
 
Join Date: Mar 2013
Posts: 1
Help! 2010 Phaeton AC problems

I have had repeated electrical problems with my Phaeton. The RV Comfort thermostat that controls the 3 AC units and heaters has never worked properly.
It always resets to 00 and turns off/on on it's own accord.
I have replaced the thermostat for the third time, replaced two noise filters, swapped out the main AC control panel from unit 1 with unit 2 control panel.
Again and again it defaults to 00 and will not respond.

Not sure if it is related, but I had battery charging problems wwith my Xantec inverter that cooked my batteries. After sending it back to Xantec, the claimed it was working fine.

I have repeatedly done all the factory resets on the thermostat, disconnected the 12 Volt and reset, disconnected 110 and reset. Replaced the 110 circuit breaker. Upgraded the 20 amp breaker, replaced the 12 volt fuse.

Nada!

Any one have an idea?
Rolfr is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-22-2013, 03:05 AM   #2
Senior Member
 
94-Newmar's Avatar
 
Join Date: Nov 2009
Posts: 2,043
00 is definitely a communication error. On many Fleetwood coaches I've seen a plug-in choke/RFI filter that plugs directly into the thermostat, then your wiring plugs into the filter. Others seem to have had success by changing the control board in the primary AC unit. Your mileage may vary...

However.. it appears that 00 that you are seeing appears often.. here are some other links/threads you may be able to ask and follow up upon:

RV Comfort Control.ZC - Systems and appliances - FMCA Motorhome Forums

http://www.irv2.com/forums/f54/colem...s-91009-2.html

Thermostat Problem ?
__________________
94-Newmar Kountry Star 40-KSDP
Spartan/Cummins 8.3C-300HP/Allison 3060 WTEC-II/25yr RV Tech RVIA Certified/Onan-Cummins Certified
94-Newmar is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 07:17 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.