Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Tiffin Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-27-2021, 01:07 PM   #1
Junior Member
 
Join Date: Sep 2020
Posts: 7
Unhappy Help getting power back in coach

Thanks in advance for any help offered. We drove our 2017 Allegro Bus for 6 hours yesterday using the inverter to run refrigerator... and yes everything electrical is dead. Plugged it in last night but didn't take a charge. We have looked at another post with what we hope may be a solution but here is such a basic question we hate to have to ask it. "where is the battery boost button? Is that the auxiliary start button?
mossey is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-27-2021, 01:26 PM   #2
Senior Member
 
garykk's Avatar
 
Tiffin Owners Club
Freightliner Owners Club
Join Date: Apr 2012
Location: Southern NM
Posts: 2,526
Yes the auxiliary button is used to boost the starting battery, but that won’t help your house batteries. Are you saying the chassis batteries are dead? Will the generator charge the batteries?
If it’s the house batteries, make sure the inverter is on and has not tripped a breaker. Does you Mh have a Spyder panel that has the inverter listed, make sure it’s on charge.
__________________
2018 Allegro Bus 37AP
2014 Phaeton 40 QBH (sold)
2021 Ford F-150 King Ranch
garykk is offline   Reply With Quote
Old 10-27-2021, 02:22 PM   #3
Senior Member
 
deandec's Avatar
 
Country Coach Owners Club
Join Date: Jan 2006
Location: Northern California
Posts: 5,328
Your engine alternator should have been charging the chassis and house batteries when driving. The inverter draw down on the house batteries should have been replaced by the Alternator when driving.

"Every thing electrical is dead" if you have no 120v for the wall outlets and no 12v for lights and gauges:

1. Is your house battery switch turned to On?

2. Do you have power at the site power post? Is it turned to On?

3. If you start the generator (start the rig engine first) do you then get both AC and DC power?
__________________
Dean
1995 38' CC Magna #5280
C8.3L 300hp Cummins, 31,000lbs
Gillig Bus Chassis
deandec is offline   Reply With Quote
Old 10-27-2021, 02:58 PM   #4
Junior Member
 
Join Date: Sep 2020
Posts: 7
Okay I should have given more information and tell you we are pretty limited in our technology department. All your help is very appreciated. First the engine batteries are working, the generator won't start, and the magnam is reading 2.6. We saw another post that we tried to follow suggesting that we set the magnum shore power back to 5. press down the battery boost switch that is at the drivers side controls while running the engine at fast idle. We did this for approximately 3 minutes but nothing at all changed on the magnum display. If I am not describing adequately please let me know.
`
mossey is offline   Reply With Quote
Old 10-27-2021, 03:05 PM   #5
Junior Member
 
Join Date: Sep 2020
Posts: 7
I don't think we have a Spyder controller. We have a energy monitor up above the drivers seat in the cabinet where the inverter is but it is also dead. We are at our daughters house and have 50 amp service but we don't know how to test and see if it is coming into the coach.
mossey is offline   Reply With Quote
Old 10-27-2021, 04:06 PM   #6
Junior Member
 
Join Date: Sep 2020
Posts: 7
We do have power at the post. We are going to get a battery charger. When we do where do we hook it up to charge the house batteries? thanks for the help.
mossey is offline   Reply With Quote
Old 10-27-2021, 04:46 PM   #7
Senior Member
 
Join Date: Jul 2014
Posts: 28,967
If you ran the engine AND held the boost switch but didn't get a rise in voltage at the house batteries, the isolation solenoid or control for it isn't working.

Your magnum will not charge low or dead batteries. They need to be above 10 to 12 volts.

If you have jumper cables you can jump the chassis positive to the house positive. Use the posts that have the most cables on them, same if connecting a charger. That will bring the volts up on the house batteries.

If you can locate the isolation solenoid, you can check it out with a volt meter.
twinboat is offline   Reply With Quote
Old 10-27-2021, 05:08 PM   #8
Junior Member
 
Join Date: Sep 2020
Posts: 7
So that I am understanding we connect only the positive chassis to the house batteries only? Also our cables won't reach that far they are too far away unless you know of a closer access. If not can we use a portable battery charger? Thanks you guys are great sharing your knowledge with others.
mossey is offline   Reply With Quote
Old 10-27-2021, 05:14 PM   #9
Junior Member
 
Join Date: Sep 2020
Posts: 7
I meant portable jumper not charger.
mossey is offline   Reply With Quote
Reply

Tags
power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power not getting to Coach from genset Regwal RV Systems & Appliances 11 11-07-2020 04:26 PM
Not getting power to coach but am at box Palazzoteam Palazzo Motorhomes 11 06-25-2020 07:01 PM
Help needed getting closet doors back on track Karlos National RV Owner's Forum 4 09-12-2015 08:16 AM
2007 Monaco Dynasty getting no power to coach wilwag Monaco Owner's Forum 13 02-09-2015 11:37 AM
need help on getting power to the coach flyingpa12 Newmar Owner's Forum 9 12-09-2012 11:46 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 04:42 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.