RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Tiffin Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-27-2015, 09:26 PM   #1
Junior Member
 
mikemac3's Avatar
 
Join Date: Jul 2015
Posts: 29
Need to Replace Message Center 2000 Allegro Bus

Received some more awesome news about my coach. After 8 hours of diagnostics ($$$) at a Freightliner dealer, I need to replace a "message center" to make my gauges work. Also need to replace a blower motor, relay and harness for my heater/AC fan as it keeps blowing fuses in high speeds. I've read about others fixing issues with gauges by finding improper grounds or loose wires. Is it reasonable to think that a message center and a blower motor, etc. could fail around the same time? Click image for larger version

Name:	ImageUploadedByTapatalk1446002758.651949.jpg
Views:	42
Size:	219.9 KB
ID:	110546Anyone have experience?
__________________

mikemac3 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-29-2015, 10:19 AM   #2
Senior Member
 
Monkey Run's Avatar
 
Join Date: Apr 2013
Location: Sodus Point NY
Posts: 537
I'm interested in this, have the same rig but a 1999. I suspect they are replacing parts in hopes of nailing the problem. One thing I might suggest is to remove every connection in both battery banks and check/clean them all. I did this after delivery in 2013 and found connectors falling apart, bad connections etc. Completely unhook the power from the coach and the chassis when doing this, sometimes electronics will fire up after a complete reset.
Monkey Run is offline   Reply With Quote
Reply

Tags
ace, replace



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 Tiffin Allegro bus FL chassis heat TobinC Freightliner Motorhome Chassis Forum 4 10-23-2015 11:15 AM
2000 Allegro Bus Repair Quotes mikemac3 Tiffin Owner's Forum 3 09-22-2015 09:42 PM
Your thought on an 2010 Allegro bus 43QGP garykk Tiffin Owner's Forum 15 07-04-2014 09:33 PM
1999 Allegro Bus Bludiver Tiffin Owner's Forum 0 06-10-2014 09:20 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 01:32 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×