Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Tiffin Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-21-2021, 09:35 PM   #1
Member
 
Join Date: Apr 2013
Posts: 66
Rear camera died

Tiffin 2015 40QBH. Rear camera system shut down. I removed the slide out storage area under the dash and found a red colored connetor dangling in mid air. My junk box had a mating connector and I connected it to a 12 volt battery and plugged it into the red dangling connector. The system works fine, so it would be logical that I should find a mating connector to plug into the red connector. I have not found it. Three techs at Tiffin suggested things I should do, but none of them worked. I have a fiber optic camera and still did not find anything.
Has anyone had this problem?
CBTraveler is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-22-2021, 10:12 AM   #2
Senior Member
 
garykk's Avatar
 
Tiffin Owners Club
Freightliner Owners Club
Join Date: Apr 2012
Location: Southern NM
Posts: 2,478
Only suggestion is to keep looking itís a rats nest under there but your wire is in there, trouble is itís probably not red. Tiffin uses yellow for hot 12 volt.
__________________
2018 Allegro Bus 37AP
2014 Phaeton 40 QBH (sold)
2021 Ford F-150 King Ranch
garykk is offline   Reply With Quote
Old 06-23-2021, 04:48 PM   #3
Senior Member
 
Join Date: May 2018
Location: Boca Raton
Posts: 192
Did you check the connections under the dash access panel. Mine has three, left, right, and rear. I cleaned and reinserted them. That cleared the problem for me.

Paul
__________________
2018 Allegro 36LA
2017 Jeep Wrangler Sport/2D
Ready Brute Elite/Blue Ox BP
StaRVGazer is offline   Reply With Quote
Reply

Tags
camera, rear



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GPS/Side camera/Rear Camera DIY? Ogre Monaco Owner's Forum 2 05-08-2017 06:51 PM
2006 Bounder 35E Camera/Monitor died ramblingdon Fleetwood Owner's Forum 4 05-10-2015 11:20 AM
Magnetek/Parallax 6345 converter died after furnace died SatWorld RV Systems & Appliances 26 05-01-2015 06:23 AM
Replacing/upgrading back up camera system - rear camera removal? ScottRussell Class A Motorhome Discussions 5 07-07-2014 06:57 AM
Back up camera died Shellback1 Damon 9 04-12-2011 11:20 AM


All times are GMT -6. The time now is 02:20 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.