Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Tiffin Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-09-2022, 08:42 AM   #1
Member
 
Cheeseman1's Avatar
 
Tiffin Owners Club
Join Date: May 2019
Location: Caledonia, MI
Posts: 40
Triple vision TVR 4000s issue

Have an issue with my in-dash Triple Vision TRV4000s monitor. Worked great on our way to Florida this past winter. Sat for three months. Upon starting the engine to go home the screen flickered, was distorted, and went out. All of the buttons across the bottom just blink now at the same time. Unplugged the power connection at the harness at of course all blinking stopped. After plugging back in and turning on the power button all the buttons again blink and none are responsive when touched. Seems like it needs to be reset somehow, but maybe replaced? Any ideas on how to fix or where to find another 4000s monitor if thatís the right thing to do? Sure sucks backing up without it!
__________________
2014 Tiffin Allegro 36LA Open Road
Mark & Karen Young
Caledonia, MI with our Drahthaar Belle and Dachshund Rosie
Cheeseman1 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-09-2022, 08:51 AM   #2
Senior Member
 
Join Date: May 2018
Location: Boca Raton
Posts: 285
I don't have the contact info, someone here does I'm sure, but the company is in Redbay, AL and they are very helpful. Tiffin may be able to give you the contact info also.

Paul
__________________
2021 Dutch Star 4369/Spartan K2 (7/2022)
2018 Allegro 36LA (5/2018)
2017 Jeep Wrangler Sport/2D; NSA Ready Brute
StaRVGazer is offline   Reply With Quote
Old 05-09-2022, 05:09 PM   #3
Member
 
Cheeseman1's Avatar
 
Tiffin Owners Club
Join Date: May 2019
Location: Caledonia, MI
Posts: 40
From your post I was able to see that a company called Triple H makes Triple Vision camera systems. I plan to call them tomorrow. Still open to any thoughts and recommendations from this forum as well.
__________________
2014 Tiffin Allegro 36LA Open Road
Mark & Karen Young
Caledonia, MI with our Drahthaar Belle and Dachshund Rosie
Cheeseman1 is offline   Reply With Quote
Old 05-13-2022, 05:56 PM   #4
Member
 
Cheeseman1's Avatar
 
Tiffin Owners Club
Join Date: May 2019
Location: Caledonia, MI
Posts: 40
That didnít work

Bought a new TVR 4000s from Triple H in Red Bay. Triple H advised that it sounds like an issue with the monitor. But the new one when plugged into the existing wiring harness did not work and had the same all blinking and non responsive buttons. So do I need to take all of the wires apart and put in the new wiring harness? Do the wires actually go bad, so itís not the monitor? Obviously this electronic stuff is not my forte, so Iím really hoping someone with some expertise can point me in the right direction. TIA.
__________________
2014 Tiffin Allegro 36LA Open Road
Mark & Karen Young
Caledonia, MI with our Drahthaar Belle and Dachshund Rosie
Cheeseman1 is offline   Reply With Quote
Old 12-07-2022, 11:05 PM   #5
Junior Member
 
Join Date: Dec 2022
Posts: 1
I saw your post as I was searching for a answer to the exact same problem you had with your back up camera,Iím having exactly the same issue, same make and model, I see the post is a few months old but was wondering if you ever found the problem, thanks
Nm7710 is offline   Reply With Quote
Old 12-08-2022, 07:16 AM   #6
Member
 
Cheeseman1's Avatar
 
Tiffin Owners Club
Join Date: May 2019
Location: Caledonia, MI
Posts: 40
Unfortunately I never did get the camera to work. I bought a new monitor from Triple H (approx. $400 I believe) and that did not fix the issue. They did take it back, but I had a conversation with them about returning it before I gave it a try. I bought a wireless camera system from Amazon (approx $150). It works quite well. Rigged up a way to put in into the dashboard. Fit was not exact but looks fine. Have not added side view cameras but I’m mostly not missing lose as my mirrors seem to do fine. Good luck.
__________________
2014 Tiffin Allegro 36LA Open Road
Mark & Karen Young
Caledonia, MI with our Drahthaar Belle and Dachshund Rosie
Cheeseman1 is offline   Reply With Quote
Old 12-10-2022, 07:50 AM   #7
Senior Member
 
Tiffin Owners Club
Join Date: Sep 2020
Location: Houston, Texas
Posts: 477
Quote:
Originally Posted by Nm7710 View Post
I saw your post as I was searching for a answer to the exact same problem you had with your back up camera,I’m having exactly the same issue, same make and model, I see the post is a few months old but was wondering if you ever found the problem, thanks

Did you see this thread?
https://www.irv2.com/forums/f106/abo...em-600151.html
__________________
Tommy & Franci - Houston (Clear Lake), TX
2019 Allegro Red 340 33AL
2020 Jeep GC Limited-Blue Ox Avail-M&G Braking
Part Timers-Looking Fwd to being Anytimers
thegats1 is offline   Reply With Quote
Reply

Tags
vision



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Triple e Empress :: 1990 Triple e Empress DavidToz iRV2 Owners Registry 0 09-03-2020 03:09 AM
Triple Vision Cameras Went Dark bhazzard123 Tiffin Owner's Forum 1 09-19-2017 10:19 AM
Triple Vision back up camera deasnealy Tiffin Owner's Forum 8 01-23-2016 08:45 PM
Triple Vision Camera - Passenger Side W0GER Tiffin Owner's Forum 2 12-21-2015 05:49 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 11:37 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2023, vBulletin Solutions, Inc.