Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Tiffin Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-09-2021, 05:01 PM   #1
Junior Member
 
Join Date: Nov 2020
Posts: 14
TV Antenna stopped working

HI Everyone

Need your expertise. I have a 2016 31 Open Road SA. My TV antenna just stopped working. When I try to auto program channels I get zero local channels. Has anyone experienced this and figured out what is the cure?

I have the black circular antenna on top of my roof.

Thanks!
John Formon is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-09-2021, 05:07 PM   #2
Senior Member
 
kenandterry's Avatar
 
Join Date: Dec 2011
Location: Southern Ontario, Canada
Posts: 822
Quote:
Originally Posted by John Formon View Post
HI Everyone

Need your expertise. I have a 2016 31 Open Road SA. My TV antenna just stopped working. When I try to auto program channels I get zero local channels. Has anyone experienced this and figured out what is the cure?

I have the black circular antenna on top of my roof.

Thanks!
So, how long ago did it work okay?
We’re you in the same location before and after it worked?
Is the booster button and light ON?
__________________
kenandterry
2018 Sunseeker 2430S-CD carried by a 2017 Ford E450
Bye 2010 Georgetown 330TS after 10 terrific years, as we downsize for the next phase.
kenandterry is offline   Reply With Quote
Old 12-09-2021, 05:11 PM   #3
Community Administrator
 
Lt Dan's Avatar


 
Tiffin Owners Club
Join Date: Sep 2013
Location: DFW, Texas
Posts: 13,863
Does your 2016 have the Mini State HD360 Antenna? Tiffin changed some time around 2016 so it's hard to know which one you have. If it is the HD360, there will be a panel in the cabinet that lets the antenna rotate. If you do have that type, your only recourse is to replace it and most replace it with the Winegard Rayzar. Here's a thread with a couple of options for replacement.
https://www.irv2.com/forums/f106/ota...on-561822.html
__________________
2017 Phaeton 40IH XSH Maroon Coral - Power Glide Chassis with IFS
Previously '15 Tiffin Allegro RED 38QRA and '06 Itasca Sunrise 35A
'16 Jeep JKU Wrangler Sahara or '08 Honda Goldwing
Lt Dan is offline   Reply With Quote
Old 12-10-2021, 05:23 AM   #4
Member
 
Tiffin Owners Club
Join Date: Nov 2020
Posts: 52
Have you checked ALL the connections from the antenna thru the booster to the TV? I would be suspec,t especially if the reception died after a travel day
__________________
Laird
2020 Tiffin Allegro Open Road 32SA
windfall96 is offline   Reply With Quote
Old 12-10-2021, 08:51 AM   #5
Junior Member
 
Join Date: Nov 2020
Posts: 14
Hi Everyone

I REALLY appreciate the feedback.

The antenna died on a recent trip from Atlanta to Colorado Springs. The antenna worked fine before that.

My antenna is the disc type, but has no moving parts (I took it apart and checked)

My TV booster light is on (red light In my unit)

I’m thinking of taking a piece of coax cable and going directly from the booster to a tv and see what happens.

I’m also not positive when I run the “auto channel program routine” on the TV that I have the correct “input” selected. I need to work on this.

I’m a mechanical engineer but all this wiring is mind boggling (blue ray, sat dish, hdmi cables, coax)

Thanks again everyone
John Formon is offline   Reply With Quote
Old 12-10-2021, 08:59 AM   #6
Senior Member
 
KanzKran's Avatar
 
Join Date: Sep 2018
Posts: 1,944
Check for the light on the wall plate, and for 12V at the coax where it connects to the antenna, assuming it's amplified, which it probably is. Most antenna amplifiers won't pass any signal at all unless they're powered.

It's also not unusual for coax cable connections to get crappy with age and weather exposure. You can use a spare coax with F-type connectors (factory made is best) to go from the antenna to the wall plate with power switch to bypass the OEM cable to see if that fixes the problem, assuming you have a spare cable laying around. Just run it through a window for testing purposes.

As to the TV, make sure you're scanning for 'antenna', not 'cable', as they don't use the same frequencies for the most part.

I have an omnidirectional 'flying saucer' on my roof, and as they say, it's equally bad in all directions, but it works well enough for me as we never spend two nights in the same place anyway. Only once were we not able to get any channels at all, so we watched a movie, preloaded on my ipad from Netflix.
__________________
Tom & Jeri
2018 Coachmen Galleria 24T Li3
KanzKran is offline   Reply With Quote
Old 12-10-2021, 09:13 AM   #7
Senior Member
 
Tiffin Owners Club
Join Date: Feb 2019
Posts: 301
Quote:
Originally Posted by John Formon View Post
When I try to auto program channels I get zero local channels. Has anyone experienced this and figured out what is the cure?

I have the black circular antenna on top of my roof.
Have you tried in multiple locations? I used to have that Triplevision antenna on top of my rig but found it woefully inadequate. If you're currently in a zone with particularly weak reception you likely won't pick up any signal with it. I think it's highly unlikely that it just died, but there may be some electronics within it because I believe it does get fed a 12V boost on the line.

I was so dissatisfied with mine that I replaced it with a crank-up directional antenna. It required cutting a hole for the crank mechanism but it works much better.
__________________
2016 Tiffin Phaeton 36GH
2013 Nissan Xterra S 4WD manual transmission
jeskibuff is offline   Reply With Quote
Old 12-10-2021, 09:16 AM   #8
Senior Member
 
kenandterry's Avatar
 
Join Date: Dec 2011
Location: Southern Ontario, Canada
Posts: 822
Is it possible you’re so far from civilization that there’s no Over The Air (OTA) signals close by for you to “grab”?
__________________
kenandterry
2018 Sunseeker 2430S-CD carried by a 2017 Ford E450
Bye 2010 Georgetown 330TS after 10 terrific years, as we downsize for the next phase.
kenandterry is offline   Reply With Quote
Old 12-10-2021, 09:16 AM   #9
Senior Member
 
Tiffin Owners Club
Join Date: Feb 2019
Posts: 301
Quote:
Originally Posted by John Formon View Post
I’m also not positive when I run the “auto channel program routine” on the TV that I have the correct “input” selected.
You likely have only one coax antenna input to each TV and the auto channel will only work on it so if you're getting to that function, it's only got the one source it will look at.
__________________
2016 Tiffin Phaeton 36GH
2013 Nissan Xterra S 4WD manual transmission
jeskibuff is offline   Reply With Quote
Old 12-10-2021, 09:35 AM   #10
Junior Member
 
Join Date: Nov 2020
Posts: 14
Thanks everyone

I’m currently camping in a park where I used to get good antenna reception so I’m pretty confident in the incoming signal.

Quick question. In my wet bay I have 2 coax connections. 1 is “cable”. 2 is “tripod”

Can this tripod connection be used with a new TV antenna?
John Formon is offline   Reply With Quote
Old 12-10-2021, 09:43 AM   #11
Senior Member
 
Tiffin Owners Club
Join Date: Feb 2019
Posts: 301
Quote:
Originally Posted by John Formon View Post
In my wet bay I have 2 coax connections. 1 is “cable”. 2 is “tripod”

Can this tripod connection be used with a new TV antenna?
If hooking up an external antenna, I'd use the "cable" inlet. That should travel to the front cabinet where the booster is and where the signal is distributed to the other TVs. The "tripod" connection will likely be terminated in the back of your coach where the main A/V components are. You'd have to switch the boost switch off to make the "cable" connection.
__________________
2016 Tiffin Phaeton 36GH
2013 Nissan Xterra S 4WD manual transmission
jeskibuff is offline   Reply With Quote
Old 12-10-2021, 10:28 AM   #12
Senior Member
 
F4Gary's Avatar
 
Join Date: Feb 2015
Location: Grapevine, Tx
Posts: 4,485
My older crank up type OTA antenna has an inline fuse before it gets to the BOMB. If it is blown, I get very little reception.


The Tripod input might be for a portable fixed sat antenna (on a tripod ).
__________________
2004 Fleetwood Southwind 32VS W20
ReadyBrute Elite towing a 2017 Ford Edge Sport
F4Gary is online now   Reply With Quote
Old 12-10-2021, 10:44 AM   #13
Senior Member
 
Tiffin Owners Club
Join Date: Feb 2019
Posts: 301
Quote:
Originally Posted by F4Gary View Post
The Tripod input might be for a portable fixed sat antenna (on a tripod ).
...which would be connected to a satellite receiver in the A/V cabinet. That receiver would then send its output to the other TVs using the HDMI splitter system. That coax signal would end there, but it is possible to connect the tripod coax to the coax intended to go to the rear TV (add a coax splitter if you still wanted OTA reception on the rear TV) if you connected an external antenna to the tripod connector. The signal would travel up to the front coax splitter where it would be distributed to the other TVs. This wouldn't be optimal as it would compete with the signal coming out of the booster switch unless you disconnected the coax from the output of the booster. The easiest method is just using the "cable" inlet.
__________________
2016 Tiffin Phaeton 36GH
2013 Nissan Xterra S 4WD manual transmission
jeskibuff is offline   Reply With Quote
Old 12-10-2021, 05:59 PM   #14
Junior Member
 
Join Date: Nov 2020
Posts: 14
Antenna issue

I’m going to read all your posts this evening. The amount of help you have all offered is unbelievable. I just want to personally thank everyone.

Also on a positive note… I started to have issues with my captains chairs peeling. I called Tiffin and spoke to Karen Timbs. She said she would see what she could do. Next thing I know Bob Tiffin called to say new upholstery was on the way N/C. When does the president ever call a customer????

Fantastic service by Karen and Bob. This experience made me feel better about the Thor buy out. When I mention that to Bob he assured me the family was still in control

Thanks again everyone. I will let you know how I make out troubleshooting my antenna.
John Formon is offline   Reply With Quote
Reply

Tags
antenna



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
A/C stopped working ItstheTrip National RV Owner's Forum 5 06-04-2007 07:34 PM
Power mirror adjusment stopped working rvrat Winnebago Industries Owner's Forum 5 06-01-2007 06:46 AM
Anyone stopped OR NOT stopped for pulling motorcycle trailer behind TT? tammyinwv Trailer Towing and Tow Vehicles Discussion 17 02-26-2007 08:54 PM
Door Stop Stopped Working JavaJelly Newmar Owner's Forum 11 02-24-2007 02:33 AM
HWH Jacks working, not working and working again? Bob&Pat Winnebago Industries Owner's Forum 6 06-08-2006 04:22 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 12:40 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.