Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-30-2010, 02:24 PM   #1
Junior Member
 
Join Date: Aug 2010
Posts: 11
'03 Fleetwood Terra

Hi guys back again for some more advice, my 0'3 terra on the workhorse p32 won't start. We last drove it about a month ago everything seemed fine except I did notice that the left side turn signal on the coach and my tow(09 jeep) did not work.When I came back in about three wks. my coach wouldn't start , it made a clicking sound also the step wouldn't go out, it made a werring sound.Even after useing the house batteries plus coach batteries it still wouldn,t start.Are these two problems related?,my jeep drove away with no problem.
belkin is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-30-2010, 02:27 PM   #2
Moderator Emeritus
 
DriVer's Avatar
 
Winnebago Owners Club
Workhorse Chassis Owner
Coastal Campers
Carolina Campers
Join Date: Jan 2000
Location: Conway, SC
Posts: 23,643
Blog Entries: 70
Quote:
Originally Posted by belkin View Post
Even after useing the house batteries plus coach batteries it still wouldn,t start.Are these two problems related?,my jeep drove away with no problem.
belkin,


You're going to have to hook up a battery charger and cook up those batteries for a while. We can't do a thing unless we have a functioning automotive battery.

Let us know how you made out and please come back and see us.
__________________
03 Adventurer 38G, Workhorse W22
F&R Track Bars, Safety+ , Ultrapower, Taylor Extremes, SGII
TST 507, Blue Ox, SMI, Koni FSD, CrossFire
RV/MH Hall of Fame - Lifetime Member
DriVer is offline   Reply With Quote
Old 08-30-2010, 05:49 PM   #3
Senior Member
 
Max Hubrich's Avatar
 
Workhorse Chassis Owner
Join Date: Mar 2007
Location: Pikeville, NC
Posts: 1,775
Sounds like a bad chassis battery (or house batteries too). Clean all the connections and the chassis grounds also. if the batteries are original, about 7 years old, go buy new ones.
I use Wal-mart, or Sam's Club, can't beat their price and warranty.

The RV/MH doesn't care whose name is on the batteries .
__________________
Max H,
2002 Newmar Mountain Aire, 37', 3778, W-22, 8.1 Vortac, Ultra Power upgrade, CAI (cold air intake), Taylor wires, colder plugs, Koni shocks.
Max Hubrich is offline   Reply With Quote
Old 10-11-2010, 12:26 PM   #4
Junior Member
 
Join Date: Aug 2010
Posts: 11
'03 fleetwood terra, fuses

I came home from a short trip and found my brake lights and right rear turn signal doesn't work.We have checked the bulbs, replaced the battery, checked the fuse box under dash , i'ts fine so now I'am looking at the fuse box under the hood above the battery.How do you get it open? It seems to have two little latches on the front to open but I still can't get it to open, anyone have any tricks to open this? Also is there another smaller fuse box under the hood some where I should check,man you really have to work to find some of these things! any help useful.
belkin is offline   Reply With Quote
Old 10-11-2010, 12:34 PM   #5
Junior Member
 
Join Date: Aug 2010
Posts: 11
She starts now new battery, brake lights and right rear signal light don't work,bulbs fine
belkin is offline   Reply With Quote
Old 10-11-2010, 12:52 PM   #6
Junior Member
 
Join Date: Aug 2010
Posts: 11
'03 Fleetwood Terra fuses?

Well we replaced the battery checked the blubs and fuses under the dash drivers side all good! The brake lights and right rear turn signal lights still don't work. So now the fuse box in front under the hood, but how do you open it? There seems to be two latches but whenI turn them the cover still won't come off any suggestions? also is there another fuse box somewere under here?
belkin is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fleetwood Terra 32S Walby Class A Motorhome Discussions 16 12-11-2015 03:21 PM
2007 Fleetwood Terra LX 32K countrypair Fleetwood Owner's Forum 5 09-18-2010 05:57 PM
Any thoughts on the Fleetwood Terra LX Daddyscooltv Fleetwood Owner's Forum 27 07-08-2007 07:11 AM
Fleetwood Terra toilet clogging Rich Perry MH-General Discussions & Problems 18 12-09-2005 09:10 AM
Fleetwood To Break New Ground With Launch Of Fleetwood Vacation Club In Spring 2005 DriVer RV Industry Press 2 01-21-2005 01:34 AM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 08:57 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2023, vBulletin Solutions, Inc.