Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 12-23-2017, 08:57 AM   #1
Member
 
db71's Avatar
 
Join Date: Feb 2017
Location: Deer Island , Oregon
Posts: 43
12v outlets not working

Our 2004 Southwind 36E has multiple 12v outlets inside the coach and also in many of the basement storage compartments. None of them work with the exception of the one on the dash (obviously on its own circuit). I have hunted hi and low for a blown fuse in all the fuse panels and come up empty. Hoping one of you might be able to help.
Thanks, Dean
__________________
Dean , Erika and Roscoe, the flat coat retriever
2004 Southwind 36E ,W22
db71 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 12-23-2017, 01:18 PM   #2
Senior Member
 
pointrow's Avatar
 
Join Date: Dec 2014
Location: Cen Il.
Posts: 681
Having just helped a neighbor track down this same problem I would suggest to start simple. Does the 12volt fuse box have power at the buss bar?
If not check the switch by the entry door.
Only spent an hour to learn that.

Good luck
Pointrow
__________________
2014 Fleetwood Providence 42p
pointrow is offline   Reply With Quote
Old 12-25-2017, 10:48 AM   #3
Member
 
db71's Avatar
 
Join Date: Feb 2017
Location: Deer Island , Oregon
Posts: 43
Thanks Pointrow,
The switch by the door is working fine, all lights in the bays will turn off and on with the switch. All 12v buss bars have power too. The problem I'm having is I can't even locate a fuse that serves those 12v plugs. My worry is that there is a inline fuse hidden in the floor or a wall someplace.
__________________
Dean , Erika and Roscoe, the flat coat retriever
2004 Southwind 36E ,W22
db71 is offline   Reply With Quote
Old 01-09-2018, 12:16 PM   #4
Senior Member
 
JLWoodward's Avatar
 
Join Date: Nov 2016
Posts: 375
All the external plugs should be wired to a gfi interior outlet, so their not working because the inside ones are dead. Is this on shore power, invert or either that you have no power.
JLWoodward is offline   Reply With Quote
Old 01-09-2018, 12:17 PM   #5
Senior Member
 
JLWoodward's Avatar
 
Join Date: Nov 2016
Posts: 375
Quote:
Originally Posted by JLWoodward View Post
All the external plugs should be wired to a gfi interior outlet, so their not working because the inside ones are dead. Is this on shore power, invert or either that you have no power.


Never mind you said 12v. Apologies.
JLWoodward is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP! Kitchen outlets (DS) and Outlets/Lights (PS) Don't Work offtosleep Monaco Owner's Forum 23 01-02-2018 02:22 PM
dash air wont shift from defrost outlets to dash outlets drrussell Monaco Owner's Forum 3 08-21-2016 03:30 PM
is it normal, to not have any of the outlets NOT working when driving? 8SEC6SPD Thor Industries Owner's Forum 14 12-07-2012 04:39 PM
120v Electrical Outlets not working in 03 MDDS rbguinn Alpine Coach Owner's Forum 8 09-11-2008 06:35 PM
HWH Jacks working, not working and working again? Bob&Pat Winnebago Industries Owner's Forum 6 06-08-2006 04:22 AM


All times are GMT -6. The time now is 01:19 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.