Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-28-2021, 08:31 PM   #1
Member
 
Fleetwood Owners Club
Freightliner Owners Club
Join Date: Oct 2021
Location: Helena, MT
Posts: 36
2001 Discovery Rear/driver's side furnace not working

Hi guys, I need some assistance.
I went and filled up the propane on the rig today and when I got back turned the heaters on to test them out.
The front one turns on just fine and produces heat.
The rear one, however, does not. No fan, no burner.
When I flip the switch to turn it on, I hear a click, presumably from the control box under the fridge.
But the furnace itself isn't doing anything.
The rig is new enough to me that I don't get know where or what to check to make it work.
Any and all assistance is appreciated.
__________________
Chris and Kayti and family
2001 Fleetwood Discovery 36T DP
2014 Jeep Grand Cherokee Overland EcoDiesel TOAD
un4givn85 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-04-2022, 02:26 PM   #2
Senior Member
 
Join Date: Oct 2018
Location: Washington
Posts: 241
So many possibilities here - does the fan come on? If not, check the DC fuse. Is it blown? Is there 12V on both sides?
If the fuse is OK, get into the heater and see if there is 12V being supplied ot the heater fan (when the fan is called to run)
If there is 12V, but the fan motor does not run, bad fan. If not, trace the wiring to figure out where the 12V stops.

Wiring diagrams for the rig and for the heater would be very helpful, they will help you determine where all the fuses are, and to trace the circuit.

Good luck!
__________________
2003 Fleetwood Discovery 39L
JohnLoves2Sk is offline   Reply With Quote
Old 07-04-2022, 04:08 PM   #3
Senior Member
 
Tha_Rooster's Avatar
 
Join Date: Aug 2008
Location: Georgia
Posts: 7,761
Quote:
Originally Posted by un4givn85 View Post
Hi guys, I need some assistance.
I went and filled up the propane on the rig today and when I got back turned the heaters on to test them out.
The front one turns on just fine and produces heat.
The rear one, however, does not. No fan, no burner.
When I flip the switch to turn it on, I hear a click, presumably from the control box under the fridge.
But the furnace itself isn't doing anything.
The rig is new enough to me that I don't get know where or what to check to make it work.
Any and all assistance is appreciated.


Remove outside cover there is a reset button.
Check fuses
__________________
2007 Fleetwood Revolution LE 40V
Tha_Rooster is offline   Reply With Quote
Old 07-04-2022, 04:22 PM   #4
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 26,963
Fan runs but produces no heat .
Propane operators are required to shut off the supply valve before filling ; did it get turned back on ?
Have you tried the stove top burners ?

Two furnaces , in a 36' coach is rare , can you post a picture of the switch your turning on ?
Is the second furnace on a separate thermostat ?
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 07-05-2022, 09:04 AM   #5
Member
 
Fleetwood Owners Club
Freightliner Owners Club
Join Date: Oct 2021
Location: Helena, MT
Posts: 36
Hey all, not sure why this was resurrected, but I have since removed the rear heater in favor of a Cheap Heat Stand-A-Lone unit.
Thanks for the suggestions tho.
__________________
Chris and Kayti and family
2001 Fleetwood Discovery 36T DP
2014 Jeep Grand Cherokee Overland EcoDiesel TOAD
un4givn85 is offline   Reply With Quote
Old 07-05-2022, 09:14 AM   #6
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 26,963
Quote:
Originally Posted by un4givn85 View Post
Hey all, not sure why this was resurrected, but I have since removed the rear heater in favor of a Cheap Heat Stand-A-Lone unit.
Thanks for the suggestions tho.
Most of the responders ; including myself ; didn't check the original post date and just threw in our ideas when the thread came up in the currently active list.

Thanks for bringing the thread to a conclusion , by posting your repair .
__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Reply

Tags
ace, cover, discovery, driver, furnace, rear



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 Driver's Side Rear Quarter Panel Part # Cajun Joe Alpine Coach Owner's Forum 4 11-05-2021 02:17 PM
Ventana Remote Cargo Lock works on passenger side but not driver side dougakadvs Newmar Owner's Forum 5 10-09-2017 01:28 PM
2001 Winnebago Adventurer 35u Ford chassis: driver and shotgun fans not working Textronics Winnebago Industries Owner's Forum 7 08-26-2016 10:36 AM
2006 Discovery wire in driver side rear wheel well Bleu zoo Fleetwood Owner's Forum 8 08-08-2013 04:41 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 05:50 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.