RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-27-2019, 10:24 AM   #1
Senior Member
 
akeyzoo's Avatar
 
Join Date: May 2013
Posts: 961
2005 Revolution Brake Light Issue

Folks,
Have a 2005 Rev, Spartan chassis. About 4 years ago I replaced all tail light/indicator bulbs with LED, works well.


Recently, I have had an issue with one of my brake lights, drivers side, illuminating occasionally. Rig can be parked. Always the same drivers side brake light (top light on this revolution).



Any idears where to start troubleshooting? I can't imagine if there were an issue why one side would light up but not the other. Both light up when I press the brakes.


Chris
__________________
------------------------------------
American Revolution 40L CAT C9
Samsung 197, TireMinder, Ready Brute Elite with Wrangler
akeyzoo is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-27-2019, 03:00 PM   #2
Senior Member
 
Tha_Rooster's Avatar
 
Join Date: Aug 2008
Location: Georgia
Posts: 6,399
I donít know about yours but the sockets are crap. Try removing bulb sand contacts.
__________________
2007 Fleetwood Revolution LE 40V
Tha_Rooster is offline   Reply With Quote
Old 09-28-2019, 07:37 PM   #3
Senior Member
 
MrWzrd's Avatar
 
Fleetwood Owners Club
Freightliner Owners Club
Join Date: Mar 2018
Location: Hebron, IL
Posts: 144
Likely the LED bulbs you are using are able to light regardless of which what power is applied and they are being lit by voltage coming from the ground side. (Something else has lost a good ground and is sourcing its ground through the LED to the unpowered, and grounded, feed side of the tail lights)
These are loads of fun to find but if you are lucky.....look for any ground points/wires that do not look solid and clean. (or detached)
If none found.... it's schematic time and probing through the circuits that interconnect.
I'll drag out my schematics (2004) and see if I can spot anything to check.
__________________
Doug & Kathy
2004 Fleetwood Revolution 40C
KD9PK
MrWzrd is offline   Reply With Quote
Old 09-30-2019, 10:42 AM   #4
Senior Member
 
akeyzoo's Avatar
 
Join Date: May 2013
Posts: 961
MrWzrd,
Good idea, will begin my investigation there. What confuses me is that the two lights dont light up simultaneously (left and right), perhaps as you said a current leak into ground on left is why.


I will start with towed connections (ready brute and the trailer connections)


Chris
__________________
------------------------------------
American Revolution 40L CAT C9
Samsung 197, TireMinder, Ready Brute Elite with Wrangler
akeyzoo is offline   Reply With Quote
Old 10-10-2019, 06:49 PM   #5
Junior Member
 
Jhoskins's Avatar
 
American Coach Owners Club
Join Date: Oct 2018
Location: Lockhart, Texas
Posts: 25
Very interesting... both of my brake lights along with the 3rd brake light occasionally light up while parked with the engine & lights turned off. They are all new LED bulbs with new sockets, and they blink repeatedly. If they donít stop, I pull the fuse until itís time to roll.

Iíll search for the guilty ground wire(s) in an attempt to resolve this issue. Thx.
__________________
James Hoskins
Modernized 2004 American Coach EAGLE
Jhoskins is offline   Reply With Quote
Reply

Tags
brake, light, revolution



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Revolution :: 2003 Fleetwood Revolution CaptainVideo iRV2 Owners Registry 0 03-09-2017 04:25 AM
Revolution LE 38X :: 2005 Fleetwood Revolution LE krivanj iRV2 Owners Registry 0 10-19-2016 02:48 PM
American Coach: 2005 Revolution le entry light randymarlar Fleetwood Owner's Forum 5 09-05-2016 07:40 PM
Revolution vs. Revolution LE moldtech Fleetwood Owner's Forum 11 07-04-2012 08:54 PM
Brake light fuse location 2005 Revolution lyledavid Fleetwood Owner's Forum 5 07-04-2011 09:42 AM


All times are GMT -6. The time now is 06:40 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.