Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Fleetwood Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 05-28-2021, 06:19 PM   #1
Junior Member
 
angigibaby's Avatar
 
Fleetwood Owners Club
American Coach Owners Club
Spartan Chassis
Join Date: Mar 2021
Location: Polson, MT
Posts: 24
2008 Revolution Slide Issues

Hey all. This is our first big motorhome and we are struggling with some issues. We purchased a new to us 2008 Revolution 42K LE. The big wall slide on the driver's side worked when we picked it up but not when we got it home. We have the jacks down and engine running. Checked the fuses under the driver's door and they were good. We didn't receive any paperwork with this coach, so we are pretty much flying blind. I have searched but can't find anything that is helpful.



Any ideas? We are prepared to take it to a pro, but feel like it's something simple that we are missing. Any help would be appreciated.



~Angie
__________________
2008 Fleetwood Revolution LE 42K
2019 Chevrolet Colorado AEV Bison
angigibaby is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 05-28-2021, 06:27 PM   #2
Member
 
jimjenturner's Avatar
 
Join Date: Jul 2016
Posts: 51
Check that E Brake is on.
jimjenturner is offline   Reply With Quote
Old 05-28-2021, 06:38 PM   #3
Junior Member
 
angigibaby's Avatar
 
Fleetwood Owners Club
American Coach Owners Club
Spartan Chassis
Join Date: Mar 2021
Location: Polson, MT
Posts: 24
Here are some images. DH texted them to me. I'm not sure what they go to.
Attached Thumbnails
Click image for larger version

Name:	IMG_2765.jpg
Views:	23
Size:	350.8 KB
ID:	329953   Click image for larger version

Name:	IMG_2764.jpg
Views:	29
Size:	377.0 KB
ID:	329954  

Click image for larger version

Name:	IMG_2763.jpg
Views:	32
Size:	494.2 KB
ID:	329955   Click image for larger version

Name:	IMG_2762.jpg
Views:	26
Size:	338.6 KB
ID:	329956  

__________________
2008 Fleetwood Revolution LE 42K
2019 Chevrolet Colorado AEV Bison
angigibaby is offline   Reply With Quote
Old 05-28-2021, 06:38 PM   #4
Junior Member
 
angigibaby's Avatar
 
Fleetwood Owners Club
American Coach Owners Club
Spartan Chassis
Join Date: Mar 2021
Location: Polson, MT
Posts: 24
Quote:
Originally Posted by jimjenturner View Post
Check that E Brake is on.

That's the air brake, right? Yes.
__________________
2008 Fleetwood Revolution LE 42K
2019 Chevrolet Colorado AEV Bison
angigibaby is offline   Reply With Quote
Old 05-31-2021, 06:33 PM   #5
Senior Member
 
Cat320's Avatar
 
Fleetwood Owners Club
American Coach Owners Club
Join Date: Mar 2011
Posts: 6,019
You said the jacks were down...but is your coach level, and use high idle when moving the FWS.
__________________
2014 American Eagle 45T
DD 13, 500 HP
Pulling a Honda CRV
Cat320 is offline   Reply With Quote
Old 06-01-2021, 05:23 AM   #6
Senior Member
 
Tha_Rooster's Avatar
 
Join Date: Aug 2008
Location: Georgia
Posts: 6,990
2008 Revolution Slide Issues

Quote:
Originally Posted by angigibaby View Post
Hey all. This is our first big motorhome and we are struggling with some issues. We purchased a new to us 2008 Revolution 42K LE. The big wall slide on the driver's side worked when we picked it up but not when we got it home. We have the jacks down and engine running. Checked the fuses under the driver's door and they were good. We didn't receive any paperwork with this coach, so we are pretty much flying blind. I have searched but can't find anything that is helpful.



Any ideas? We are prepared to take it to a pro, but feel like it's something simple that we are missing. Any help would be appreciated.



~Angie


Does your slide have slide locks and are they moving? What is your coach battery voltage because slides and wires to them. Try hitting auxiliary start button at same time trying to open. Check voltage at slide controller in your picture. Also what is you engine voltage gauge while running?
__________________
2007 Fleetwood Revolution LE 40V
Tha_Rooster is offline   Reply With Quote
Old 06-01-2021, 05:39 PM   #7
Junior Member
 
angigibaby's Avatar
 
Fleetwood Owners Club
American Coach Owners Club
Spartan Chassis
Join Date: Mar 2021
Location: Polson, MT
Posts: 24
Quote:
Originally Posted by Tha_Rooster View Post
Does your slide have slide locks and are they moving? What is your coach battery voltage because slides and wires to them. Try hitting auxiliary start button at same time trying to open. Check voltage at slide controller in your picture. Also what is you engine voltage gauge while running?

Thanks. So we didn't know about the high idle. We did that and messed around with it. It seems that the key switch is backwards. So we were able to get the locks to come off, but nothing else. Now we can't get the locks to go back down. So maybe it's the key system?
Attached Thumbnails
Click image for larger version

Name:	IMG_2827.jpg
Views:	22
Size:	550.8 KB
ID:	330460  
__________________
2008 Fleetwood Revolution LE 42K
2019 Chevrolet Colorado AEV Bison
angigibaby is offline   Reply With Quote
Old 06-02-2021, 05:14 AM   #8
Senior Member
 
Tha_Rooster's Avatar
 
Join Date: Aug 2008
Location: Georgia
Posts: 6,990
2008 Revolution Slide Issues

Quote:
Originally Posted by angigibaby View Post
Thanks. So we didn't know about the high idle. We did that and messed around with it. It seems that the key switch is backwards. So we were able to get the locks to come off, but nothing else. Now we can't get the locks to go back down. So maybe it's the key system?


If a fast idle did anything you probably have a low voltage problem. According to manual you need in the mid 13 volts for operation thatís why engine should be running. Have you tried engine running and aux start button down while trying? Slide needs to be opened then closed for locks to close back. Remember slide is running off of house batteries not chassis batteries.
__________________
2007 Fleetwood Revolution LE 40V
Tha_Rooster is offline   Reply With Quote
Old 06-02-2021, 07:34 AM   #9
Junior Member
 
angigibaby's Avatar
 
Fleetwood Owners Club
American Coach Owners Club
Spartan Chassis
Join Date: Mar 2021
Location: Polson, MT
Posts: 24
The gauge at the inverter and solar charger system both read 14.1. I assume that refers to the house batteries. Is this wrong?
__________________
2008 Fleetwood Revolution LE 42K
2019 Chevrolet Colorado AEV Bison
angigibaby is offline   Reply With Quote
Old 06-02-2021, 09:03 AM   #10
Senior Member
 
Tha_Rooster's Avatar
 
Join Date: Aug 2008
Location: Georgia
Posts: 6,990
Quote:
Originally Posted by angigibaby View Post
The gauge at the inverter and solar charger system both read 14.1. I assume that refers to the house batteries. Is this wrong?


Thatís good,no one push the reset button on slide control panel did they? If not donít. I would still try push aux start button while trying slides.
__________________
2007 Fleetwood Revolution LE 40V
Tha_Rooster is offline   Reply With Quote
Old 06-02-2021, 11:43 AM   #11
Junior Member
 
angigibaby's Avatar
 
Fleetwood Owners Club
American Coach Owners Club
Spartan Chassis
Join Date: Mar 2021
Location: Polson, MT
Posts: 24
I appreciate your time responding. We have not set the reset, I don't think we know where that is. If we did, it was accidental. We will try the aux start this afternoon.



Just to clarify, the two passenger slides have no problems. It's just the big wall slide on the driver's side.
__________________
2008 Fleetwood Revolution LE 42K
2019 Chevrolet Colorado AEV Bison
angigibaby is offline   Reply With Quote
Old 06-02-2021, 01:16 PM   #12
Senior Member
 
Tha_Rooster's Avatar
 
Join Date: Aug 2008
Location: Georgia
Posts: 6,990
2008 Revolution Slide Issues

Quote:
Originally Posted by Tha_Rooster View Post
Thatís good,no one push the reset button on slide control panel did they? If not donít. I would still try push aux start button while trying slides.


In your picture of controller it says field reset in and out. Those buttons set the slide to the outter and inner limits. So if you had hit it while closed it would think itís open. Check all the plugs and fuses on that controller. Power gear has a multiple page how to on your slide.
__________________
2007 Fleetwood Revolution LE 40V
Tha_Rooster is offline   Reply With Quote
Old 06-05-2021, 09:52 AM   #13
Senior Member
 
Tha_Rooster's Avatar
 
Join Date: Aug 2008
Location: Georgia
Posts: 6,990
2008 Revolution Slide Issues

Quote:
Originally Posted by angigibaby View Post
Thanks. So we didn't know about the high idle. We did that and messed around with it. It seems that the key switch is backwards. So we were able to get the locks to come off, but nothing else. Now we can't get the locks to go back down. So maybe it's the key system?


You could alway remove switch panel and jump the key switch.I also have a cabinet door in bedroom with a safety switch on it and slide will not operate if it comes open.
__________________
2007 Fleetwood Revolution LE 40V
Tha_Rooster is offline   Reply With Quote
Old 06-06-2021, 05:02 PM   #14
Senior Member
 
Join Date: Jul 2018
Location: Oklahoma
Posts: 119
Im probably too late here but, on our Tradition, the smaller slide opposite the super slide has to extend first. Dont know w hy, it just does.
__________________
Questios, questions, questions. Yeah, Iím that guy. But, Iím learnin!
2009 American Tradition 42P. ISL Cummins 425hp, Spartan chassis w/ tag, Allison trans,
Jandcinok is offline   Reply With Quote
Reply

Tags
revolution, slide



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fleetwood Revolution/American Tradition/Revolution aknavy Fleetwood Owner's Forum 11 01-15-2019 01:02 PM
Revolution :: 2003 Fleetwood Revolution CaptainVideo iRV2 Owners Registry 0 03-09-2017 03:25 AM
Revolution LE 38X :: 2005 Fleetwood Revolution LE krivanj iRV2 Owners Registry 0 10-19-2016 01:48 PM
Revolution vs. Revolution LE moldtech Fleetwood Owner's Forum 11 07-04-2012 07:54 PM

» Featured Campgrounds

Reviews provided by


All times are GMT -6. The time now is 12:02 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.